ActiveX™ Technology for Interactive Software Agents icon

ActiveX™ Technology for Interactive Software Agents




Скачати 49.79 Kb.
НазваActiveX™ Technology for Interactive Software Agents
Дата20.09.2012
Розмір49.79 Kb.
ТипДокументи


Using the Microsoft Agent Character Editor

ActiveX™ Technology for Interactive Software Agents





Last updated: August 1997
Microsoft Corporation

Note: This document describes the Microsoft Agent Character Editor for Microsoft Agent, which you can download from http://www.microsoft.com/workshop/prog/agent/agentdl.htm.

Note: This document is provided for informational purposes only and Microsoft makes no warranties, either expressed or implied, in this document. The entire risk of the use or the results of this document remains with the user.

Information in this document is subject to change without notice. Companies, names, and data used in examples herein are fictitious unless otherwise noted. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents or pending patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. The furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property rights. Microsoft, MS, MS-DOS, Windows, Windows NT, and the Windows logo are either registered trademarks or trademarks of Microsoft Corporation in the U.S. and/or other countries. Other product and company names mentioned herein may be the trademarks of their respective owners.

Contents

Introduction

Installing the Agent Character Editor

Starting the Agent Character Editor

Defining a New Character

Command Reference

Toolbar buttons

Introduction


The Microsoft® Agent Character Editor enables you to compile character animations for use with Microsoft Agent. You can define animations by importing Windows bitmap images, setting their duration, and optionally including branching, sound effects, and speaking overlays. For information about designing a character's animation, see Designing Characters for Microsoft Agent.

With the Agent Character Editor you can define the character's name and description as well as output options, including text-to-speech (TTS), synthesized voice output, pop-up menu support, and the character's word balloon design.
^

Installing the Agent Character Editor


To install the Microsoft Agent Character Editor, open its self-extracting cabinet file. This will automatically install the appropriate files on your system. If you are downloading the Agent Character Editor from the Microsoft Web site, the downloading software gives you the option to save the file and open it or open it automatically as soon as the download completes.

If you plan to use a TTS engine for your character's output, you need to install that engine before you begin creating your character. A special version of the Lernout & Hauspie® TruVoice text-to-speech engine (American English language) can be downloaded from the Microsoft Agent Web site. You can use and distribute this engine as part of a Microsoft Agent application, subject to the conditions described in the End User Licensing Agreement that displays when you install the engine. If you plan to use another TTS engine, contact that vendor to confirm their support for Microsoft Agent and for information on their licensing provisions for use and redistribution.
^

Starting the Agent Character Editor


To run the Agent Character Editor, choose the Agent Character Editor option from the Windows Taskbar's Start menu, or double-click the Microsoft Agent Character Editor icon on your desktop. The Editor's window will open, displaying its menus, a toolbar with frequently used commands, a tree listing the components that make up a character's definition, and a set of tabbed pages that change based on your selection in the component tree.




^ Figure 1. Microsoft Agent Character Editor window

To access fields in the window from the keyboard, you can use the tab key and shift+tab to navigate between controls, or use the access key (alt+underlined letter) to move to a specific control. Once the Editor completes starting up, you can begin creating a new character definition or load an existing character definition.

The status bar displays information about commands or toolbar buttons when you move the pointer over them. It also displays summary information about your character animation data and status information when you build a character.
^

Defining a New Character


To define a new character, run the Agent Character Editor. If you have an existing character file loaded, choose the New command from the File menu or the New button on the toolbar. This action selects the Character icon in the tree and displays its property pages on the right side of the window. The following sections describe how to set your character's properties and how to create animations for the character.
^

Setting Your Character's Properties


To begin defining a character, provide the character's name by entering it in the Name text box (32 characters maximum). Because Microsoft Agent uses the name to allow users to access the character, specify a user-friendly name. Supply a name that can be pronounced using conventional spelling, or you may disable speech input for the character. You can also specify a short optional description (256 characters) for your character in the Description text box. The server exposes what you enter in the Description text box to client applications.

For your character's spoken output, Microsoft Agent provides the choice of a synthesized, text-to-speech (TTS) voice or a voice that uses recorded sound files. If you want to use a synthesized voice, check the Use Synthesized Speech For Voice Output option. This will add a Voice page for selecting the characteristics of the voice. Choose the Voice page and use the controls on it page to select a voice, speed, and pitch of any compatible TTS engines you have installed. The range of the voice parameters you can select depends on TTS engines. If you have not yet installed a TTS engine, the Voice ID list will be empty. You must have a TTS engine installed before you define your character's voice settings in the Agent Character Editor.

If you plan to use a TTS engine for your character's output, you must also install that engine on the user's system. For more information on how to install the Lernout & Hauspie® TruVoice engine on a user's system from a Web script, see Programming The Microsoft Agent Control. If you are using another TTS engine, check with the vendor for appropriate installation information. If you select a voice based on a particular TTS engine, but the user has a different TTS engine installed, the server attempts to fit the voice based on the characteristics you defined in the Agent Character Editor.

If you plan to use recorded sound files (.WAV files) for your character's spoken output, do not check the Use Synthesized Speech For Voice Output option. Instead, you will need to record the spoken output audio files separately and load them from your application code.

The Use Word Balloon on the character's Properties page enables you to determine whether you want to support this feature for your character. Once defined, it cannot be changed through the Microsoft Agent programming interface.

When the Use Word Balloon option is checked, you can access the Word Balloon page. The options on the Word Balloon page enable you to change the default characteristics of your word balloon. The Characters Per Line setting enables you to define the width of the balloon based on the average number of characters per line. You can set the default height based on either a fixed number of lines you want to display at once or automatically sized to the text you supply in the Speak method. You can also set whether the balloon automatically hides after a Speak method is completed and whether the balloon automatically displays or “paces” words to the character’s speech output speed setting.

The Word Balloon page also enables you to set the default font for the character’s word balloon and the balloon’s display colors. However, be aware that users can override your word balloon font settings using the Microsoft Agent property sheet.

Each character requires a unique identifier (GUID). The server uses the identifier to differentiate characters. When you create a new character, the Editor automatically creates a new identifier for your character. You need to change a character's identifier only if you copied the character definition file of another character or if you intentionally want to differentiate a character from a former version. To change a character's identifier, click the New GUID button and the Editor will generate a new identifier.
^

Creating Animations


To begin creating animations for your character, select the Animations icon in the tree. This displays the Properties page with the default settings for all animations. You can alter the frame size, the default frame duration, and color palette settings on the Properties page. The animation frame height and width must remain constant throughout the entire character definition (that is, for all of that character's animations). Although you can change the frame size from its default setting (128 x 128 pixels), images displayed in the Editor will be scaled to fit default display size. If you change the default frame setting, you can display the frame’s full, non-scaled size by choosing Open Frame Window from the Edit menu.

By default, the Editor uses the first bitmap image you load to set your character's default color palette, and sets the color in the 11th palette position as your transparency color. However, you can change these settings using the buttons in the Palette Information group. Your character's color palette must not remap the standard system colors. The Editor will automatically reserve the system's color palette when displaying images. In addition, make sure all your animation images use the same color palette and transparency color. If they do not, you may see color remapping of your images when you load them into the Editor.

Once you have determined your global animation settings, you can begin creating animations. To create a new animation, choose New Animation from the Edit menu or the New Animation button on the toolbar. This adds a new animation icon in the tree under the Animations icon and assigns the new icon a default name. You can rename your animation by typing in the Animation Name field. Note that animation names within a character definition must be unique. Also, avoid using characters in the name that are not valid characters for filenames.

Every animation is composed of frames. To create a new frame for your animation, choose New Frame from either the Edit menu or the toolbar. This adds a new frame icon to the tree under your animation icon, and displays three tabbed pages. The General page includes controls that enable you to load and adjust an image for your frame. It also includes a display area for the frame's appearance.



^ Figure 2: The Frame Image display and controls

A frame can contain one or more images. To define an image for a frame, click the Add Image File button just above the Images list box. The Select Image Files dialog box displays, which allows you to select a bitmap image file.



^ Figure 3. The Select Image Files dialog box

Select the file you want to load, choose Open, and the image appears in the frame display on the General page. The Editor accepts images stored as 1-bit (monochrome), 4-bit, or 8-bit Windows bitmap format, or as GIF format.

You can use the four arrow buttons beneath the image in the Position box to adjust the image's appearance within the frame. If the image is larger than your frame's size, only the portion of the image that appears within the frame will display. If you increase the frame size, the image may be scaled to fit within the display area of the Editor.

You can also display a frame by choosing Open Frame Window from the Edit menu. This displays the current frame in a separate window without scaling the images loaded into the frame. This window's initial size is based on your frame's height and width settings. You can resize it smaller, but not larger. The Frame Window reflects the changes you make using the controls in the Editor and also allows you view the frame while viewing its other property pages.



^ Figure 4. Image Position controls

You can compose a frame from multiple images. Each time you select the Add Image button and choose another image, the image gets added to the list and to the image display area. You can also add multiple images by selecting more than one file. Press shift or ctrl while you click in the Select Image Files dialog box, and then choose Open. The Move Up and Move Down buttons above the Images list box move a selected image in the display order (z-order) for the frame. You can also move images by dragging them within the list. Selecting an image in the list and clicking the Delete button removes an image. To change an image you have loaded to another image file, you can click the filename to edit it directly or use the Ellipsis (…) button to bring up the Select Image Files dialog box and select a different file.



^ Figure 5. The Ellipsis button

You can use the Duration text box to set the duration for the frame; that is, how long the frame will be displayed. If a frame has no image and zero duration, the frame will not be displayed when the animation plays.

You can also specify a sound effect file to play when the frame is displayed. If you plan to load the character from a Web server, you may want to compress the sound effect file to minimize load time. You can then specify the compressed sound file in the Agent Character Editor. In addition, avoid using a sound effect with a duration longer than the duration of your animation and especially avoid a sound effect that loops, because the Microsoft Agent animation services do not send an animation complete event until the sound completes. Also avoid specifying a sound effect for any animation you assign to the Listening or Hearing states, because this interferes with speech input. Finally, while you can include more than one sound effect in an animation, avoid placing them so they overlap, because this may affect the timing of the animation. Also, keep in mind that sound effects may play at different rates based on the user’s hardware.

To add frames to your animation, choose the New Frame command again and follow the same procedure. As an option, you can also load multiple images and automatically generate new frames for them. To use this feature, choose New Frames From Images from the Edit menu. The frames will be created in alphabetic order based on the image filenames. When you are finished defining all frames for your animation, you can choose the New Animation command again to begin a new animation.

There are other ways to add frames to animations and move frames within or between animations. You can select another frame (from the same or another animation) and choose Cut or Copy, then select the animation or a frame in that animation and choose Paste. You can also drag a frame from one animation to another. If you drag within an animation, the action moves the frame. If you drag to another animation, it copies the frame. Dragging to a preceding frame in the same animation inserts the frame before the frame to which you drag. Dragging to a following frame places it after the frame to which you drag. If you drag a frame using the right mouse button, releasing the button displays a pop-up menu with your transfer choices.

You can also create an animation by copying an existing animation (select the animation and choose Copy), and selecting the Animations icon or another animation icon and choosing Paste. The Editor automatically creates a new name for the animation, although you can change the name.

Branching


When you create a frame, you can also define which frame plays next. By default, the next frame played in the animation sequence is always the next frame in the z-order. However, by choosing the Branching page, you can set the probability for up to three other frames that the server may play. Enter the probability percentage and the target frame number in the appropriate fields. You can specify branching even for frames that don't have images and have their duration set to zero. This enables you to branch without first displaying a particular image.




^ Figure 6. The Branching page

You can use the branching feature to create animations that will loop indefinitely. However, note that when a looping animation plays, other animations in the character's queue will not play until an event—such as a user pressing the push-to-talk key or the client application calling the Stop method—halts the looping animation. Therefore, carefully consider the context in which the animation will be used before creating a looping animation.
^

Previewing an Animation


You can preview your animation in the Agent Character Editor by choosing the Preview command on the Edit menu or the Preview button on the toolbar. This plays your animation, including any branches and sound effects, starting from the current selected frame. It resets to the current selected frame when the animation completes. To play your entire animation, go to the tree view, select the animation's icon or first frame of the animation, and choose the Preview command. The Editor animates your frames on the General page. To stop the preview before it ends, choose the Stop Preview command. The Preview command automatically changes to Stop Preview while the preview plays.
^

Assigning Speaking Overlays


You can define a character so that it speaks during the last frame of its animation. On this frame, choose the Overlay page. This page enables you to load and assign mouth image files to the standard mouth positions supported by Microsoft Agent. Click the Add Image button and select the image from the dialog box. You can also select multiple images, and the Editor will load and assign the images starting with the mouth position you selected. Click the Move Up and Move Down buttons or drag an entry to change an image assignment in the list. Click the Delete button to remove an image. You can also edit the pathname of an assigned file by clicking its entry in the list and retyping its filename, or by choosing the Ellipsis (…) button to display the Select Image Files dialog box.



Figure 7. The Overlay page image controls
^

Assigning a Return Animation


To create a smooth transition from one animation to the next, design your animation sequences to begin and end with a neutral image. For more information, see Designing Characters for Microsoft Agent(http://www.microsoft.com/workshop/prog/agent/deschar.htm). However, this does not mean that every animation must end at the neutral position. You can animate a character through a sequence of frames, have it speak during the last frame, and create a separate, complementary animation that returns the character to the neutral position. This complementary animation is called a Return animation. Define a Return animation like any other animation. To assign the Return animation, select an animation in the tree, and select the Return animation you created from the Return Animation drop-down list on the Properties page.

Creating and assigning a Return animation has an added benefit: When the server gets a request to play another animation, it will attempt to play the Return animation for the last animation it played, if a Return animation is assigned. This ensures a smooth transition. If an animation begins and ends at the neutral position, you don't need to define a Return animation. Similarly, if you intend to handle transitions from one animation to another yourself, you may not need to assign a Return animation.
^

Assigning Animations to States


The Microsoft Agent animation services automatically play animations when the hosting client application uses certain methods. For example, when an application calls the MoveTo and GestureAt methods, the server automatically determines where the character is displayed and plays an appropriate animation. Similarly, Microsoft Agent automatically plays Idle animations when the user has not interacted with the character for several seconds. These conditions when the server automatically plays animations on an application's behalf are called states. However, for the server to know which animation to play, you must assign animations to these states.

To define a state, create the appropriate animation, expand the States entry in the tree view of the Editor window, and select the State icon. The list of animations you have created appear in a list box on the right side of the window. Check the animation you want to assign to this state. Note that you can assign more than one animation to the same state. This allows the server to randomly select different animations for the state. Assigning an animation to a state does not prevent an animation from playing that animation directly.

You can also assign an animation to a state by selecting the animation's entry in the tree. The Assign To State list box on the Properties page lists the states. Select the check box of the state to which you're assigning the animation.
^

Saving Your Character Definition


You can save your character's definition file by choosing the Save command on the File menu or the Save Character Definition button on the toolbar. If you want to save the character definition file with a new name, choose the Save As command on the File menu. The Editor saves a character's editable definition as an Agent Character Definition (.ACD) file. You can also edit this self-documenting text file format with most text editors and word processing applications.
^

Printing Your Character Definition


To print your character's definition, choose the Print command on the File menu or the Print button on the toolbar. To set the properties for your printed output, choose the Page Setup command and choose your settings before selecting the Print command.
^

Building A Character


When you are done creating your animations, the character and images must be compiled into a special format that Microsoft Agent uses to load this data. To build a character, select the Build Character command on the File menu or from the toolbar. If you have unsaved edits in your character definition file, the Editor saves the definition file before displaying the Build Character dialog box.



^ Figure 8: The Build Character dialog box

The Agent Character Editor will automatically propose a filename based on your character definition filename. The Build Character dialog box also includes a drop-down list so you can choose between building the character as a single storage file (.ACS) or as multiple files. If you choose the latter, the Editor builds an .ACF file that includes character's data and an .AAF file for each animation you created. If you plan to install and access a character stored on the same machine as your client application, you would typically choose the single structured file format. This format provides easy and efficient installation of and access to the character. However, if the character will be accessed from a Web server using the HTTP protocol, build your character using the .ACF (individual) file format. This latter file structure allows a Web page script to load individual animation files, storing the data in the user's browser file cache. It provides more efficient access over the Web because animation data can be downloaded as needed rather than requiring the user to wait for the entire set of animations to download at one time. In addition, because the character's data is stored in the browser cache, the file space can be automatically reclaimed.

Although you can also download character data (either as a single structured file or multiple files) from a Web server and install elsewhere on a user's machine, such a method requires security provisions for downloading and installation. As a result, Microsoft Agent does not include support for downloadable installation of a character except to the browser's cache. However, you can still support this scenario by creating your own installation control and distribute it following appropriate security conventions. For more information, see the Microsoft Internet Client Software Development Kit.

The Compress option enables you to set whether the character data is compressed. Typically, you will want to set this option to compact your character data, although building a character with the compacted data takes longer.

Once you build a character, subsequent builds will be faster if you build the character to the same directory location. The character editor automatically verifies and copies those files that have not changed, and recompiles any data that has been edited.
^

Editing an Existing Character


To edit an existing character, choose Open on the File menu, select the character's definition file (.ACD) in the resulting dialog box, and choose Open. The file will load into the Editor. Note that you cannot load compiled character files (.ACS, .ACF, or .AAF) with the Editor.

Because the character’s definition file (.ACD) is a text file, you can also edit a character’s definition by opening the file with a text editor or word processing program. However, when completing your changes, make sureto save the file in its original format before loading it into the character editor for compilation.
^

Storing Additional Data in Your Character Definition


You can also store your own data as part of your character. You can use this capability to include special information about your character or other data. Once compiled with the character editor, this information can be accessed at run time when the character is loaded by using the ExtraData property.

To define your own data as part of the character’s definition, you must load the character’s definition file (.ACD) into a text editor. Then in the DefineCharacter section of the file (between the DefineCharacter and EndCharacter tags), add an entry using the following syntax:

ExtraData = “string

The string you supply should appear between two double-quotes and can include any characters other than double quotes, provided that the programming language you use to read the data at run time supports them. You can only include a single ExtraData entry, but the string you supply with it can be of any length.

To compile this data with your character, save the file in the original text format and load the character definition file into the character editor. Then build the character following the normal conventions. You can access the data at run time using the ExtraData property.
^

Command Reference

The File Menu


New

Resets the Agent Character Editor for creating a new character definition. If an existing character is loaded and has unsaved edits, the Editor displays a message to determine whether to save or discard unsaved changes.

Open

Displays the Open File dialog box, enabling you to open an existing character definition file for editing. If an existing character is loaded and has unsaved edits to a file, the Editor displays a message to determine whether to save or discard unsaved changes.

Save

Saves the character definition. If the character definition does not exist (has not been named), the Editor displays the Save As dialog box for input of the filename.

^ Save As

Displays the Save As dialog box, enabling you to enter a new name for the character definition file.

Print

Displays the Print dialog box, enabling you to choose a printing option and to print the character definition file.

Build Character

Displays the Build Character dialog box, which includes options for defining how to build a character's data and animation files for use with Microsoft Agent.

^ Page Setup

Displays the Page Setup dialog box that enables you to set the printing options for the character definition file.

Most Recently Open Files

Keeps track of the recent character definition files you opened. Choosing a file automatically opens that file for editing. If an existing character is loaded and has unsaved edits to a file, the Editor displays a message to determine whether to save or discard unsaved changes.

Exit

Quits the Agent Character Editor. If an existing character is loaded and has unsaved edits to a file, the Editor displays a message to determine whether to save or discard unsaved changes.

^

The Edit Menu


Undo

Removes a change made in the Editor.

Redo

Reverses an undo action in the Editor.

Cut

Removes the selected item from the Editor and places it on the Windows Clipboard.

Copy

Copies the selected item in the Editor to the Windows Clipboard.

^ Paste

Copies data from the current Windows Clipboard to the selected location.

Delete

Removes the selected item from the Editor.

New Animation

Creates a new animation object in the Editor.

New Frame

Creates a new frame for an animation.

^ New Frames from Files

Displays the Select Image Files dialog box and creates frames using the selected files.

Preview | Stop Preview

Plays an animation, starting from its selected frame.

Open Frame Window

Displays the current frame and its images in a separate window without scaling the images loaded into the frame.

^

The Help Menu


Help Topics

Displays the Help Topics dialog box, enabling you to select a Editor help topic.

About Microsoft Editor

Displays a dialog box with copyright and version information for the Editor.

Toolbar buttons




New

Resets the Editor for creating a new character definition. If an existing character is loaded and has unsaved edits to a file(s), the Editor displays a message to determine whether to save or discard unsaved changes.



Open

Displays the Open File dialog box, enabling you to open an existing character definition file for editing. If an existing character is loaded and has unsaved edits to a file(s), the Editor displays a message to determine whether to save or discard unsaved changes.



Save

Saves the character definition. If the character definition does not exist (has not been named), the Editor displays the Save As dialog box for input of the filename.



Print

Prints the current character definition file open in the Editor.



Cut

Removes the selected item in the Editor and places it on the Windows Clipboard.



Copy

Copies the selected item in the Editor to the Windows Clipboard.



Paste

Copies data from the current Windows Clipboard to the selected location.



Delete

Removes the selected item from the Editor.



Undo

Removes a change made in the Editor.



Redo

Reverses an undo action in the Editor.



^ New Animation

Creates a new animation object in the Editor.



New Frame

Creates a new frame for an animation.



Preview

Plays an animation, starting from its selected frame.



Stop Preview

Stops playing the preview of an animation.



Add Image File

Displays the Select Image File dialog box. Selected images are added to the list.



Move Up

Moves an image up in the ordered (z-ordered) list. In a frame's images list, this moves the image up in the visual z-order.



Move Down

Moves an image down in the ordered (z-ordered) list. In a frame's images list, this moves the image down in the visual z-order.

Схожі:

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

ActiveX™ Technology for Interactive Software Agents iconActiveX™ Technology for Interactive Software Agents

Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи