Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba icon

Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba




НазваVisual basic for applications (vba) Глава 1 Создание приложений с помощью vba
Сторінка1/5
Дата11.09.2012
Розмір0.61 Mb.
ТипДокументи
  1   2   3   4   5

400

ЧАСТЬ VI

visual BASIC FOR applications (VBA)

Глава 6.1 Создание приложений с помощью VBA

Возможности Visual Basic


Visual Basic является мощным программным средством, с помощью которого можно реализовать широкий спектр прак­тических задач. Основное достоинство этого языка програм­мирования состоит в том, что он оптимально сочетает в себе простоту использования, доступность и большой набор разно­образных возможностей, позволяющих охватить все основные области программистской деятельности.

В названии этого языка слово Visual означает способ, при помо­щи которого данным программным средством создается графиче­ский пользовательский интерфейс (Graphical User Guide, или со­кращенно GUI). Вместо того чтобы описывать в программе, где и каким образом появится на экране тот или иной объект, програм­мист может просто расположить его в нужном месте еще на этапе разработки своего приложения. В качестве таких "заготовок" в по­давляющем большинстве случаев используются встроенные эле­менты управления, то есть уже созданные объекты с заданными на­борами свойств и методов. Программист может изменять значения тех или иных свойств у выбранного объекта, а также описывать для него разнообразные методы. Кроме этого, имеется возможность обработки программистом различных событий, которые могут воз­никать в результате каких-либо действий пользователя.

^ Основные возможности языка Visual Basic:


401

• Реализация разработчиком максимально гибкого и удоб­ного интерфейса для своего приложения, который сможет удовлетворить потребности даже самого взыска­тельного пользователя;

• Обработка событий мыши и клавиатуры, вывод на экран различных графических изображений;

• Использование стандартных диалогов;

• Обработка файлов и каталогов на жестком диске;

• Доступ к базам данных.

Во всех приложениях пакета Microsoft Office 2000 исполь­зуется единая система программирования, которая носит на­звание ^ Visual Basic for Applications (VBA). Языком програм­мирования в данной системе является Visual Basic, а среда программирования реализована в виде Редактора Visual Basic (VBE), который может быть открыт из любого приложения пакета Office.
^

Редактор Visual Basic (VBE)


Для того чтобы запустить редактор VBE, необходимо вы­полнить следующую последовательность действий:

1. Открыть приложение пакета Microsoft Office 2000, на­пример, Word.

2. Выполнить команду Сервис \ Макрос Редактор Visual Basic.

После выполнения этих действий на экране откроется окно редактора Visual Basic (см. рис. 6.1).

Основными элементами VBE являются:

Меню. В состав этого элемента входят все команды, кото­рые используются при создании приложений в редакторе VBE. Среди пунктов меню есть как стандартные, присущие боль­шинству окон Windows (File, Edit, View, Window, Help), так и пункты, при помощи которых разработчик может запускать или отлаживать свое приложение (Debug, Run). На рис. 6.1 Меню расположено в верхней части VBE под заголовком окна.

Tool Bar (Панели инструментов). Эти элементы представляют со­бой различные группы кнопок с изображенными на них иконками. При помощи данных кнопок можно выполнять те или иные опера­ции, предусмотренные в среде разработки, не используя при этом меню; то есть выполнять одно действие - нажатие соответствующей


402

кнопки - вместо нескольких, в случае выполнения этой же операции при помощи меню. На рис. 6.1 панели инструментов расположены в верхней части VBE, под элементом Меню.



В VBE существует четыре основные панели инструментов:

^ Debug (Отладка)

Edit (Правка)

Standard (Стандартная)

UserForm (Пользовательская форма)

По умолчанию отображается только панель Standard. Для того чтобы добавить или удалить какую-либо панель инструментов, следует выбрать команду ToolBars из пункта меню View (или подвести указатель мыши к строке меню и щелкнуть правой кнопкой мыши, вызывая контекстное меню). После этого появится окно со списком основных панелей инструментов (см. рис. 6.2), причем некоторые из них могут иметь слева пометку, что означает наличие их на экране. Выбор панели из списка приведет либо к ее появлению (если радом с названием не было пометки), либо к исчезновению с экрана (если пометка присутствовала).


403



Далее будут рассмотрены панели среды разработки с кратким описанием их назначения и перечислением основных функций.

^ Панель Debug (см. рис. 6.3) предназначена для выполнения отладки (тестирования) программы с исправлением возникающих ошибок (пункт меню Debug). В Visual Basic предусмотрены ши­рокие возможности для отладки приложения, такие как отслежи­вание текущих значений переменных программы, пошаговое вы­полнение приложения (на каждом шаге выполняется один опера­тор), временная остановка выполнения программы на определен­ном шаге и т. д. Перечень всех элементов панели Debug пред­ставлен в табл. 6.1.






404



Панель Edit (см рис. 6.4) предназначена для работы с текстом программы (пункт меню Edit). Эта панель реализует возможности простейшего текстового редактора: копирование и вырезание текста в буфер обмена, вставка из буфера, поиск или замена слов и фраз в тексте программы и т. д. Список всех элементов панели Edit представлен в табл. 6.2.


405






406



Панель VserForm (см. рис. 6.5) предназначена для перемещения элементов управления в форме, изменения их размеров, выравнива­ния относительно границ формы (пункт меню Format). Перечень всех элементов панели Form Editor представлен в табл. 6.3.






407



В случае выравнивания элементов формы относительно эта­лона (пункт Align Lefts в табл. 6.3) при выполнении одной из воз­можных команд (см. рис. 6.6) изображение кнопки выравнивания на панели Form Editor изменяется в соответствии с выбранным пунктом. Возможны следующие команды:

^ Lefts - выравнивание всех выделенных объектов относительно левого края эталонного объекта;

Centers - выравнивание по центру эталона относительно вер­тикальной оси;

Rights - выравнивание относительно правого края эталона;

Tops - выравнивание по верхней границе эталонного объекта;




408

Middles - выравнивание по центру эталона относительно го­ризонтальной оси;

Bottoms - выравнивание относительно нижнего края эталон­ного объекта.

Расположение элементов формы относительно ее центра (пункт Center Horizontally в табл. 6.3), которое задается при по­мощи одной из возможных команд (см. рис. 6.7), приводит к из­менению изображения соответствующей кнопки на панели Form Editor аналогично предыдущему пункту (см. рис. 6.6). При этом возможны следующие команды:



Horizontally - выравнивание относительно вертикальной оси. Vertically — выравнивание относительно горизонтальной оси.

Аналогично предыдущим рассмотренным возможностям пре­образование размера выбранных элементов формы (пункт Make With Same Size в табл. 6.3) также приводит к изменению соответ­ствующей кнопки в панели Form Editor. В данном случае возмо­жен выбор одного из следующих пунктов (см. рис. 6.8):



^ Width — приведение ширины выделенных объектов к эталонной;

Height - преобразование высоты выделенных объектов к вы­соте эталона;

Both - приведение ширины и высоты объектов на форме к эта­лонным размерам.

Панель Standard, или стандартная панель инструментов, является основной в VBE. С ее помощью можно выполнить широкий спектр действий, которые реализованы в пунктах меню File (Файл), Insert (Вставка), Debug (Отладка) и Run (За­пуск). Стандартная панель обычно расположена под строкой


409

меню. Однако при помощи мыши ее можно перетаскивать в любые другие области экрана, при этом панель приобретает вид окна (см. рис. 6.9). В табл. 6.4 приведены основные эле­менты панели Standard и их назначение.






410






411

Properties (Окно свойств). Используется для того, чтобы из­менять свойства текущего объекта, например, документа Word (см. рис. 6.11). В VBE окно свойств, как правило, находится в левом нижнем углу (см. рис. 6.1).



Code (Окно редактирования кода). Предназначено для созда­ния или редактирования кода программы (см. рис. 6.12). Для лю­бой формы или модуля проекта окно редактирования кода мож­но открыть с помощью команды View \ Code.




412

Project (Окно проектов). Используется для удобства работы с элементами проекта (формами и модулями), а также в случае необходимости работы с несколькими проектами одновремен­но (т. е. если VBE был запущен сразу из нескольких одно­именных приложений, например, из нескольких документов Word) (см. рис. 6.13). Содержимое этого окна отображает ие­рархические структуры, в которых вершинами всех иерархий являются открытые в данный момент проекты, а исходящие от них ветви являются составными частями проектов (например, формы или модули). В VBE окно проектов обычно расположено над окном Properties (см. рис. 6.1).


^

Управление проектами в VBE


Проектом называется набор модулей, которые используются для разработки приложения. В состав проекта входят модули следующих категорий:

• Объекты приложения;

• Формы;

• Стандартные модули;

• Модули классов.

Объекты приложения Office. Представляют собой один или не­сколько документов того приложения Office, из которого был открыт редактор Visual Basic. Например, если таким приложением является Word, то категория называется Microsoft Word Objects.


413

Формы. В данной категории находятся пользовательские формы, составляющие их элементы, а также объявляемые пере­менные, константы, процедуры обработки событий и пользова­тельские процедуры и функции. Для каждой формы проекта соз­дается отдельный модуль.

Стандартные модули. Их содержимым являются процедуры, функции, а также объявляемые переменные и константы, которые можно использовать в других модулях данного приложения.

Модули классов. Предназначены для создания разработчиком собственных классов с описанием их методов и свойств. Модули классов похожи на модули форм, но, в отличие от них, не имеют отображаемого пользовательского интерфейса.

Все открытые проекты и список составляющих их файлов можно увидеть в окне Project (см. рис. 6.13), кнопки которого позволяют выполнять следующие действия:




Открывать окно кода для выбранной формы;




Показывать выбранную форму;




Выводить или прятать категории проекта, показывае­мые в виде папок (например, папка ^ Forms).

Для того чтобы добавить форму (или какой-либо другой объ­ект) в открытый проект, необходимо в меню Insert выбрать пункт


User Form (пользовательская форма) или нажать кнопку



на стандартной панели.

При необходимости удаления какого-либо элемента из проек­та следует:

1. Выбрать в окне Project название соответствующего элемен­та (формы или модуля).

2. Выполнить команду Remove меню Project или контекстного меню выбранного элемента.


414
  1   2   3   4   5

Схожі:

Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconЛекція 18 "Інформатика та комп'ютерна техніка" Тема Мова програмування Visual Basic в застосуванні до ms excel об’єкти vba: комірка, область, елемент керування, сторінка, книга, застосування, та їх методи
Багато з них мають візуальне відображення на екрані: комірки таблиці, робочі листи, панелі керування І навіть Excel в цілому – все...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconОсновы языка Visual Basic for Applications
Если необходимо узнать, какая команда позволяет программно реализовать ту или иную возможность Word, то можно воспользоваться средством...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconПрограммирование в vba
Вместо того чтобы вручную делать отнимающие много времени и повторяющиеся действия, можно создать и запускать один макрос, который...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconРешение задач в Microsoft Excel
Цель: Научиться создавать программы на vba с использованием форм для ввода исходных данных и вывода результатов, научиться применять...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconУчебник для общеобразовательных учебных заведений. Академический уровень. К.: Генеза, 2010
Цель: Научиться выполнять вычисления с использованием функций и операторов vba, организовывать ввод и вывод данных, научиться выполнять...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconРобочий зошит з дисципліни „Іноземна мова ”
Модуль Computers today: computer applications in everyday life, the basic structure of a computer system
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconЛабораторна робота №11: " Мова програмування Visual Basic в застосуванні до ms excel "
Мета роботи: Засвоїти основні принципи програмування та налагоджування програм. Навчитися використанню автозапису макросів для автоматизації...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconУдк 004. 652 Разработка фреймворка семантических приложений для распределенной высоконагруженной базы знаний
Целью данной работы является исследование технологий доступа к распределенным информационным ресурсам и проектирование, разработка...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconКак набирать вопросы, пользуясь шаблоном в документе word
Использование редактора word существенно ускоряет создание текстовых вопросов, особенно если речь идет о большом количестве подобных...
Visual basic for applications (vba) Глава 1 Создание приложений с помощью vba iconДокументи
1. /Глава 3 Электрические явления/1 Конспект урока по теме Электризация тел Два рода зарядов...
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи