Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" icon

Лабораторна робота №6: " Автоматизація розробки документів засобами ms word "




Скачати 290.57 Kb.
НазваЛабораторна робота №6: " Автоматизація розробки документів засобами ms word "
Дата12.09.2012
Розмір290.57 Kb.
ТипДокументи

Інформатика та комп’ютерна техніка MS Word

Лабораторна робота №6: " Автоматизація розробки документів засобами MS Word "


Мета роботи: Навчитися ефективно використовувати засоби MS Word і застосовувати макроси для автоматизації рутинної роботи

1.Теоретичні відомості

    1. Терміни та визначення


  • Зміст. Зміст зручно використовувати для швидкого переміщення по документу, який переглядається на екрані: для переходу до будь-якого заголовка документа достатньо клацнути відповідний йому номер сторінки в змісті. Зміст можна зробити з використанням умонтованих стилів заголовків і з використанням стилів структури. У Word є дев'ять умонтованих стилів заголовків: ("Заголовок 1" - "Заголовок9").

^ Щоб мати можливість працювати з документом у режимі структури, документу варто привласнити ієрархічну структуру. Це можна зробити двома засобами: відформатувати текст за допомогою умонтованих стилів заголовків ("Заголовок 1" - " Заголовок 9") або за допомогою присвоєння абзацам структурних рівнів ("Уровень 1" - "Уровень 9").

^ Структурні рівні можна використовувати, якщо необхідно зберегти зовнішній вигляд тексту (стилі заголовків певним чином форматують текст, а структурні рівні привласнюють йому "невидимий" формат).

  • Предметний покажчик - список слів і сполучень, що зустрічаються в документі, із указівкою номерів сторінок, на яких вони з'являються.

Створення предметного покажчика починається з позначки елементів покажчика в документі. Для економії часу можна виконати автоматичну позначку елементів предметного покажчика за допомогою допоміжного файла (файла словника). Word автоматично знайде і позначить у документі всі елементи для предметного покажчика.

При створенні допоміжного файла створюється таблиця з двох колонок, у першій колонці поміщаються слова, що потрібно знайти в тексті, а в другій - текст, який буде в предметному покажчику.

  • Автоматична перевірка орфографії:

  • вибрати команду Параметры в меню Сервис, а потім закладку Орфография (Правописание);

  • установити прапорці автоматически проверять орфографию;

  • зняти прапорець не выделять слова с ошибками.

У процесі вводу тексту документа Word підкреслює можливі орфографічні помилки червоною хвилястою лінією, а граматичні помилки - зеленою хвилястою лінією. Для виправлення помилки підведіть покажчик миші до слова, підкресленого хвилястою лінією, і натисніть праву кнопку миші, а потім виберіть правильний варіант написання в контекстному меню.

Щоб скористатися додатковими можливостями, виберіть у контекстному меню пункт Орфография.

Якщо хвилясте підкреслення заважає роботі з документом, можна до початку роботи над помилками скасувати відображення цих ліній. Перейдіть на закладку Орфография (Правописание) і встановіть прапорці Не выделять слова с ошибками.

  • Автозаміна й автотекст - два засоби збереження і швидкої вставки часто використовуваної текстової або графічної інформації.

У обох випадках існують утворювані і що редагуються користувачем списки елементів заміни, у яких ключу ставиться у відповідність більш довгий текстовий рядок або комбінація тексту і графіки.

^ Розходження між автотекстом і автозаміною:

Автозаміна

Автотекст

Елемент автоматично поміщається в текст при запровадженні імені елемента, за яким випливає прогалина або пунктуація.

Призначена для виправлення простих помилок


Елемент поміщається в текст при вводі імені елемента і натисканні клавіші .


Призначений для збереження часто використовуваного набору слів або вводу спеціальних символів тексту і швидкої вставки його в документ

Для створення або модифікації елемента автозаміни виберіть команду ^ Сервис > Автозамена.

Якщо необхідно, щоб Word зберіг форматування для того або іншого елементу автозаміни, наберіть текст заміни в документі й відформатуйте його. Потім виділіть його і викликайте команду Сервис > Автозамена. У результаті цей текст буде розміщений у полі на, після цього заповніть поле заменить і клацніть на кнопці Добавить.

У список елементів автозаміни можна додати спеціальні символи, вставка яких у документ здійснюється при виконанні команди ^ Вставка > Символ.

Автотекст дозволяє вам зберігати слова, фрази і більш довгі фрагменти тексту і графіки під тим ім'ям, що ви самі їм привласните. Для виклику збереженого тексту треба просто набрати ім'я відповідного елемента автотексту і натиснути - клавішу автотексту.

Для створення елемента автотексту в документі помічають фрагмент, який замінюється, і виконують команду Сервис > Автозамена (закладка Автотекст). У вікні Имя элемента вводять ім'я автотексту та натискають кнопку Добавить (у вікні Образец знаходиться виділений текст).

  • Виправлення. При розсилці документів на рецензію, для того, щоб бути в курсі всіх змін, внесених у документ і ін., використовують засоби реєстрації виправлень Word. Будь-який видалений текст залишається в документі, але відображується закресленим. Вставлений текст відзначається підкресленням. А будь-який рядок, що містить зміни, позначається вертикальною лінією на полях. Це дозволяє швидко переглядати документ і знаходити внесені в нього зміни.

Виправлення простіше усього прослідкувати шляхом вмикання засобу позначки виправлень для редагування документу.

Настроювання опцій виправлення виконується за допомогою такої процедури:

  1. Виконайте команду Сервис > Исправления.

  2. У діалоговому вікні Исправления застосуйте опцію Записывать исправления. Це змусить Word відслідковувати зміни, зроблені під час редагування документу.

  3. Якщо ви не хочете, щоб позначки про зміни з'являлися на екрані під час редагування, відключіть опцію ^ Показывать (отображать) исправления на экране.

  4. Клацніть на кнопці ОК. Діалогове вікно Исправления зникне з екрана. У рядку стану з'явиться напис ИСПР. Це говорить про те, що Word почав відслідковувати внесені в документ зміни.

Для того, щоб врахувати або відмовитися від виправлень, виконайте таку процедуру:

  1. Виконайте команду ^ Сервис > Исправления.

  2. Якщо ви вирішили прийняти виправлення, клацніть на кнопці Принять все, а якщо вирішили відмовитися від них - на кнопці Отказ от всех.

Word реєструє виправлення тільки в тому випадку, якщо користувач включив опцію ^ Записывать исправления діалогового вікна Исправления.

Порівняння документів виконується за допомогою такої процедури:

  1. Відкрийте більш пізню версію документу, що ви хочете порівняти з його попередньою версією.

  2. Виконайте команду Сервис > Исправления. На екрані з'явиться діалогове вікно Исправления.

  3. Виберіть кнопку (опцію) Сравнить версии. На екрані з'явиться діалогове вікно Сравнение версий, яке виглядає майже так само, як діалогове Відкриття документа.

  4. Виберіть файл, з яким ви хотіли б порівняти поточну версію документу. Іншими словами, виберіть більш стару версію відкритого файла.

  5. Клацніть на кнопці ОК. В результаті Word порівняє зазначені вами файли й автоматично зареєструє виправлення в більш пізній версії документу.

При розгляді документу декількома користувачами, кожний із яких вносив у нього свої поправки, злиття різноманітних виправлень можна виконати в тому випадку, якщо кожний користувач редагував документ із включеною опцією запису виправлень. Для цього потрібно виконати таку процедуру:

  1. Відкрийте документ, відредагований першим користувачем, поправки якого ви хотіли б зберегти в остаточній редакції документу.

  2. Виконайте команду Сервис > Объединить исправления . На екрані з'явиться діалогове вікно Объединение исправлений.

  3. Виберіть вихідну версію документу і клацніть на кнопці Открыть. Виправлення і примітки з першого документа поміщаються в другий документ.

  4. Перегляньте виправлення, при цьому приймаючи їх або відмовляючись від них.

  5. Збережіть файл.

Повторюйте п.п. 1-5 для кожної версії документу.

  • Форма - це особливий тип документа, у якому користувачу дозволено вводити інформацію лише в заздалегідь визначені області документа, які називаються полями.

^ Основна ідея створення і заповнення форм: насамперед потрібно створити новий шаблон. Потім у цей шаблон необхідно ввести незмінний текст і поля (поля можна вставити в шаблон за допомогою команди Вставка > Поле формы). Закінчивши створення бланка, потрібно вибрати команду Сервис > Установить защиту, щоб заборонити користувачу змінювати усе, крім полів, і, нарешті, зберегти створений шаблон.

Документ для заповнення форми необхідно створити на основі шаблону форми. Якщо шаблон був створений коректно, Word дозволить переміщати позицію вводу лише в поля форми. Після заповнення полів форма може бути надрукована і\або збережена у виді звичайного документа.

У Word існує три основних типи полів, що можуть бути вставлені у форму: текстові поля, поля списків і поля прапорців.

Текстовое поле - це поле форми, у який користувач уводить текстову інформацію.

Поле списка подібно текстовому полю. Проте в це поле не можна ввести текст безпосередньо. Замість цього користувач повинний вибрати потрібний варіант із попередньо складеного списку. Списки дуже зручні для таких полів: роднний стан, стать, засіб перевезення вантажу й ін. Іншими словами, це поля з обмеженим набором можливих значень. Значенням поля списку, заданим по умовчанню, є перший елемент списку (він відображується в полі при відкритті файла форми).

Поле Флажка - це поле, у якому користувач може встановити або зняти прапорець. Поле прапорця працює точно так само, як і прапорці діалогових вікон: ви просто клацаєте на них, щоб зняти або встановити прапорець. Створюючи поле прапорця, встановіть його стан по умовчанню Установлен або Снят.

Для вставки полів використовують кнопки ^ Флажок, Поле со списком і Текстовое поле на панелі інструментів Формы, що підключається по команді Вид > Панели инструментов > Формы ).

Word для кожного поля форми дозволяє створити контекстно-залежну довідку. Якщо під час заповнення форми ви забудете, для чого потрібне те або інше поле, текст довідки нагадає, яку інформацію потрібно ввести.

Для кожного поля форми може бути створено два типи довідки. Довідка в рядку стану - це текст, який з'являється в рядку стану в той момент, коли позиція вводу переходить у поле форми. У Word довжина тексту довідки в рядку стану не повинна перевищувати 138 символів, тому що розміри самого рядка стану не дозволяють відобразити більш довгий текст. Якщо довідки в рядку стану недостатньо, можете створити текст довідки, що викликається при натисканні функціональної клавіші <F1>. Текст такої довідки може містити до 256 символів.

Довідку для поля форми можна створити в діалоговому вікні Параметры поля. Клацніть на кнопці Текст справки для виклику діалогового вікна Текст справки для поля формы.

При створенні форми для документів, що будуть друкуватися на готових стандартних бланках, сформуйте шаблон форми таким чином, щоб поля раздрукованої форми точно збігалися з полями стандартного бланка. Потім, щоб надрукувати заповнену форму на бланку, виберіть команду Сервис > Параметры, клацніть на закладці Печать. Після цього включіть опцію Печатать только данные для форм. У результаті Word надрукує тільки дані, введені в поля форми, не друкуючи самого шаблону. Якщо шаблон форми розмічений точно у відповідності зі стандартним бланком форми, дані будуть акуратно введені в потрібні поля стандартного бланка.

  • Злиття - процес підготовки пачки однотипних листів (документів) шляхом об'єднання файла, що містить список імен і адрес, із файлом, що містить шаблон листа. Процес злиття складається з таких етапів:

^ Створення основного документа. Основний документ містить шаблон типового листа. Шаблон складається з тексту, що буде надрукований у кожному листі, і полів злиття, що вказують місце для вставки конкретної інформації про кожного кореспондента.

^ Визначення джерела даних - списку імен і адрес. Джерелом даних звичайно є таблиця Word, у кожному рядку якої записане ім'я й адреса (В інформатиці подібні рядки даних, що стосуються однієї особи , називаються записами. Запис складається зі значень полів). Кожне поле - ім'я, прізвище, адреса, місто, країна, поштовий індекс займає окремий стовпчик. Такі таблиці можна створювати вручну або імпортувати з файлів баз даних або з адресної книги Microsoft Exchange.

^ Злиття основного документа і джерела даних. При цьому для кожного рядка таблиці в джерелі даних буде згенерований типовий документ. Створені таким засобом документи можна помістити в окремий файл, по одному документу на сторінці, або направити прямо на принтер.

Процедуру злиття можна використовувати не тільки для створення типових листів, але і для друку поштових конвертів або наліпок і навіть для створення документів, що не мають ніякого відношення до листування, наприклад списків або каталогів. Коротше кажучи, злиття можна (і потрібно!) застосовувати там, де деякий список даних повинний бути перетворений у документ (або документи), у якому всі ці дані відформатовані однаково.

Якщо ви хочете направити сгенеровані документи прямо на принтер, виберіть значення Принтер у полі Назначение діалогового вікна Слияние, клацніть на кнопці Объединить, або просто клацніть на кнопці Слияние при печати панелі інструментів Слияние.

Якщо ви хочете переглянути перед друком всі згенеровані документи, виберіть у полі призначення пункт ^ Новый документ і клацніть на кнопці Объединить. При цьому всі згенеровані документи будуть записані в окремий документ, у котрому кожний квиток буде знаходитися на окремій сторінці (або на двох сторінках, якщо основний документ займає дві сторінки). Весь документ можна переглянути перед друком.

Якщо потрібно, щоб згенерована кореспонденція була відправлена по електронній пошті або факсу, у поле Назначение виберіть Электронная почта. Потім, клацнувши на кнопці Настройка, викликайте діалогове вікно Настройка слияния. У списку Поле данных с адресом или номером факса виберіть рядок, що містить адресу або номер факсу. У рядку Тема сообщения можна ввести тему повідомлення, що буде вставлена в кожний лист, що відсилається. Крім того, можна включити опцію Отправить документ как вложение, якщо потрібно зберегти формат документа, що розсилається.

Якщо джерело містить багато записів, наприклад більше 100, об'єднувати їх з основним документом треба групами. Виберіть у групі Объединять записи опцію от і введіть діапазон номерів записів. Наприклад, щоб об'єднати записи в групи по 100, зазначте діапазон записів, що об'єднуються від 1 до 100, потім від 101 до 200, далі від 201 до 300 і так доти, поки не будуть перераховані всі записи джерела.

Кнопка Поля Word дозволяє вставити деякі спеціальні кодові поля, що дуже зручно при підготовці основного документа для злиття.

^ ASK - відображає діалогове вікно, у якому користувач повинний увести визначений текст, і зберігає цей фрагмент у закладці.

IF…THEN…ELSE - в залежності від результату порівняння двох виразів, вставляє той чи інший текст.

^ FILLIN - відображає діалогове вікно, у якому користувач повинний увести визначений текст, і зберігає цей текст у документі.

MERGEREC - вставляє в документ номер використовуваної при злитті запису даних.

MERGESEQ - уставляє кількість записів, використовуваних для злиття.

^ NEXT - перехід до слідуючого запису джерела. Ця функція звичайно використовується для створення основного документа типу "каталог".

NEXTIF - перехід до слідуючого запису при виконанні визначеної умови.

^ SET - установлює нове значення закладання.

SKIPIF - якщо умова виконується, пропускає поточний запис. Ця функція дуже зручна для упорядкування запиту.

За допомогою процедури злиття на конвертах можна друкувати адреси. Для друку поштових конвертів клацніть на кнопці ^ Создать й у діалоговому вікні Слияние в якості основного документа виберіть Конверты, потім клацніть на кнопці Получить данные для відкриття джерела даних. Після того, як джерело даних буде відкритий, підготуйте основний документ. Клацніть на кнопці Настройка основного документа, і на екрані з'явиться діалогове вікно Параметры конверта.

У цьому діалоговому вікні виберіть розмір конверта. Клацнувши на закладці ^ Параметры печати, виберіть один із засобів вставки конверта в принтер.

Після цього на екрані з'явиться діалогове вікно Адрес. За допомогою щигля на кнопці Вставить поле слияния в основний документ можна помістити поля злиття. Якщо в один рядок вставляється декілька полів, між ними ставляться прогалини. Для переходу на новий рядок натисніть клавішу <Enter>.

Для самого друку необхідно повернутися в діалогове вікно Слияние і клацнути на кнопці Объединить.

  • Макрос - це послідовність команд Word, що можна відтворити в будь-який момент. Макроси призначені для автоматизації роботи. За допомогою макросів можна створювати свої власні команди Word для часто використовуваних операцій. Їх спочатку записують, а потім використовують.

Макроси можна створювати двома засобами. Перший із них припускає запис усіх ваших дій у своєрідний "протокол", на основі котрого і буде сформований макрос. У цьому випадку використовується умонтований реєстратор макросів, що записує в макрос еквівалентні всім діям команди WordBasic. Інший засіб складається в створенні макросів за допомогою мови програмування Word - WordBasic.

Запис макросу з використанням реєстратора провадиться за допомогою команди ^ Сервис > Макрос > Начать запись або за допомогою кнопки ЗАП у рядку стану (двічі клацнути на ній). З'явиться діалогове вікно Запись макроса.

Після запису макрос варто запустити, щоб перевірити. Якщо під час запису ви припустилися помилки, перезапишіть макрос. Але якщо макрос занадто довгий і вам не хотілося б записувати його знову, можете відредагувати його і спробувати виправити помилку.

Якщо при записі макросу ви зробили помилку, скасуйте запис і почніть усе спочатку. Але можна зробити інакше - завершіть запис макросу, а потім у редакторі виправте помилку. Ви будете редагувати макрос як окремий документ. При цьому можна видалити або модифікувати некоректні команди, вставити нові команди або просто вивчити макрос, щоб спробувати зрозуміти, як він працює.
    1. ^

      Питання, на які треба звернути увагу при виконанні роботи


  • Як документу привласнити ієрархічну структуру?

  • Для чого потрібні покажчики в документі?

  • Які відмінності між автотекстом і автозаміною?

  • Коли використовуються засоби реєстрації виправлень Word?

  • Що таке форма? Яка основна ідея створення і заповнення форм?

  • Коли використовують злиття?

  • Для чого призначені макроси?
^

2.Порядок виконання роботи


    1. Запустіть Word, створіть документ і запам’ятайте його у каталозі STUDENT в своєму підкаталозі під назвою Lab_8.doc.

    2. Створіть зміст з застосуванням умонтованих стилів заголовків на прикладі довідки про макроси з довідкової системи.

Щоб створити зміст з застосуванням умонтованих стилів заголовків необхідно:

  • застосувати їх до заголовків, що варто включити в зміст. У Word є дев'ять умонтованих стилів заголовків: ("Заголовок 1" - "Заголовок 9").

  • виконати команду Вставка > Оглавление и указатели. При цьому активізується діалогове вікно Оглавление и указатели;

  • вибрати закладку Оглавление і необхідний тип змісту за допомогою списку Вид;

  • установити необхідну кількість рівнів ієрархії і тип заповнювача.

З довідкової системи скопіюйте довідку (?> макросы, создание). Введіть назви абзаців. Застосуйте стиль Заголовка 1 до назви довідки, стилем Заголовка 2 зробіть заголовки першого та третього абзаців, а до заголовка другого абзацу застосуйте стиль Заголовка 3. Створіть зміст.

    1. Продемонструйте зміну змісту при вставці нових сторінок.

В створеному тексті застосуйте команду ^ Вставка > Разрыв (новая страница), а потім застосуйте команду Вставка > Оглавление и указатели.

      На прикладі будь-яких абзаців продемонструйте присвоєння їм рівнів.

Наберіть або скопіюйте з довідкової системи декілька абзаців тексту і зробіть такі дії:

  1. Виділіть абзац, якому потрібно привласнити структурний рівень.

  2. У меню Формат виберіть команду Абзац, а потім закладку Отступы и интервалы.

  3. У полі Уровень виберіть потрібний рівень.

    1. Створіть предметний покажчик.

Щоб створити предметний покажчик, необхідно:

  • відкрити документ, у котрому потрібно створити предметний покажчик, вибрати команду Вставка>Оглавление и указатели, клацнути на закладці Указатель, а потім на кнопці Автопометка;

  • вибрати зі списку назву допоміжного файла;

  • установити позицію вводу в те місце, де повинен знаходитися предметний покажчик і виконати команду Вставка> Оглавление и указатели, клацнувши на закладці Указатель;

  • у діалоговому вікні Оглавление и указатели вибрати стиль оформлення предметного покажчика.

Інший спосіб створення предметного покажчика:

  • відкрити документ, у котрому потрібно створити предметний покажчик, вибрати команду ^ Вставка>Оглавление и указатели, клацнути на закладці Указатель, а потім на кнопці Пометить. Відкриється діалогове вікно Определение элемента указателя;

  • у вікні Элемент указателя основной ввести слово з тексту, яке буде розміщене в предметному покажчику;

  • натиснути кнопку Пометить;

  • повторити два попередні пункти стільки разів, скільки буде розміщених слів в предметному покажчику;

  • установити позицію вводу в те місце, де повинен знаходитися предметний покажчик і виконати команду Вставка> Оглавление и указатели, клацнувши на закладці Указатель;

  • у діалоговому вікні Оглавление и указатели вибрати стиль оформлення предметного покажчика.

    1. Покажіть зниження рівнів заголовків (використовуйте відображення документа в режимі структури).

Для приклада використайте текст з заголовками, який створено в п.2.2. Перейдіть в режим структури: виконайте команду ^ Вид > Структура, або натисніть на кнопку Режим структури в лівому нижньому куту вікна. Виділіть заголовок, рівень якого ви хочете знизити, і клацніть на кнопці  панелі інструментів Структура, яка включена, коли документ відображений в режимі структури.

    1. Наберіть абзац англійською мовою. Перевірте орфографію в документі.

Виконайте такі дії:

  1. Виділіть створений абзац.

  2. Виконайте команду Сервис > Язык > Выбрать язык.

  3. В вікні Язык виберіть Английский.

  4. Виконайте команду Сервис > Правописание, або клацніть на кнопці Правописание (F7).

В вікні перевірки виконуйте, якщо це потрібно, такі дії: пропустить, заменить тощо.

    1. Засобом автозаміни в тексті замініть VB на Visual Basic.

Виконайте команду Сервис>Автозамена. У вікні Автозамена в полі заменить введіть VB, а Visual Basic - у полі на.

    1. Продемонструйте засобом автотексту вставку будь-якого абзацу тексту в інше місце.

Необхідні дії:

  1. Виділіть абзац.

  2. Виконайте команду Сервис > Автозамена і закладку Автотекст.

  3. У діалоговому вікні в полі вводу списку Имя элемента введіть ключ (наприклад, абз). Це ж вікно може використовуватися для корекції існуючого елемента автотексту. У цьому випадку ключ вибирається зі списку Имя элемента.

  4. Натисніть кнопку Добавить.

Для виклику збереженого тексту треба просто набрати абз і натиснути <F3> - клавішу автотексту.

    1. Створіть форму для анкетних даних: Ф.І.По б., місце народження, рік народження, стать, відношення до військової служби, володіння іноземними мовами, перебування за кордоном. У формі повинні бути задіяні всі типи полів.

Насамперед потрібно створити новий шаблон. Щоб створити шаблон форми, виконайте таке:

  1. Виберіть команду ^ Файл > Создать. На екрані з'явиться діалогове вікно Создание документа. Для цієї цілі кнопка Создать стандартної панелі інструментів не підходить, тому що, скориставшись нею ви не потрапите в діалогове вікно Создание документа.

  2. Клацніть на опції Шаблон, вказавши Word, що хочете створити не звичайний документ, а шаблон.

  3. Виберіть потрібний шаблон як основу для свого шаблону. Як правило, це шаблон Обычный.

  4. Клацніть на кнопці ОК. На екрані з'явиться вікно документа для нового шаблону.

  5. Створіть структуру форми, уведіть потрібний текст. Якщо ви створюєте форму на основі готового паперового бланка, намагайтеся точніше скопіювати його зовнішній вигляд. Працюйте в режимі розмітки сторінки, щоб бачити, як буде виглядати форма в готовому вигляді.

  6. Вставте поля там, де користувач повинний вводити інформацію (у нас Ф.І.По б., місце народження і т.д.).

Для вставки полів використовують кнопки ^ Флажок, Поле со списком і Текстовое поле на панелі інструментів Формы, що підключається по команді Вид > Панели инструментов > Формы.

Для зміни цих полів варто використовувати кнопку ^ Параметры поля формы на панелі інструментів Формы або підвести покажчик миші до цього поля і, клацнувши правою кнопкою миші, вибрати команду Параметры поля формы (Свойства ) із контекстного меню.

  1. Виберіть команду ^ Сервис > Установить защиту, або клацніть на кнопці Защита формы ("замок"). На екрані з'явиться діалогове вікно Защита документа.

  2. Виберіть варіант Ввода данных в поля форм і клацніть на кнопці ОК. Це необхідно для того, щоб дозволити користувачу вводити інформацію тільки в поля.

  3. Виберіть команду^ Файл > Сохранит і збережіть шаблон. Привласніть шаблону яке-небудь змістовне ім'я.

Якщо шаблон заблокований за допомогою команди Сервис > Установить защиту, для того, щоб внести в нього які-небудь зміни, зніміть захист. Для цього виберіть команду Сервис>Снять захщиту. Після внесення потрібних змін не забудьте знову встановити захист шаблону.

Створивши шаблон форми й встановивши для нього захист, приступайте до заповнення форми:

  1. Виберіть команду Файл>Создать. На екрані з'явиться діалогове вікно Создание документа, у якому будуть перераховані всі наявні шаблони.

  2. З списку шаблонів виберіть потрібний.

  3. Клацніть на кнопці ОК (перемикач повинен бути на Создать документ).

  4. Заповніть поля форми.

  5. Якщо потрібно, збережіть файл, обравши команду Файл > Сохранить або клацнувши на кнопці Сохранить стандартної панелі інструментів.

    1. Процедурою злиття створіть студентський квиток. Продемонструйте додавання записів, використання фільтрів, сортування.

Першим кроком на шляху до злиття документів повинно бути створення основного документа (у нас - бланку студентського квитка). Для цього виконайте такі дії:

  1. Відчкрийте діалогове вікно ^ Слияние за допомогою команди Сервис>Слияние. На екрані з'явиться діалогове вікно Слияние.

  2. Клацніть на кнопці Создать, єдиної в цьому вікні, що активізується при першій появі вікна Слияние. При цьому на екрані з'явиться меню з такими розділами:

  • Документы на бланке

  • Наклейки

  • Конверты

  • Каталог

Виберіть пункт Документы на бланке, щоб створити бланк основного документа. В результаті Word відобразить діалогове вікно.

  1. Клацніть на кнопці Создать основной документ, щоб відкрити нове, порожнє вікно для основного документу. Після цього в діалоговому вікні Слияние стануть доступними ще декілька кнопок.

  2. Клацніть на кнопці Правка. З'явиться меню з одним єдиним пунктом Документ на бланке: Документ (або з іншим номером, привласненим вашому документу). Виберіть цей пункт меню, і Word відкриє основний документ для редагування. Зверніть увагу на додаткову панель інструментів, що з'явилася на екрані.

  3. Наберіть текст основного документа (студентського квитка), залишаючи місце для інформації з джерела даних. Для додавання інформації з джерела даних будуть використовуватись поля слияния.

  4. За допомогою команди Файл>Сохранить збережіть документ на диску.

Створивши основний документ (поки без полів злиття, що будуть додані пізніше), підготуйте джерело даних:

  1. Виберіть команду Сервис>Слияние, щоб знову викликати діалогове вікно Слияние, або клацніть на кнопці Вікно діалогу "Слияние" панелі інструментів Слияние.

  2. Клацніть на кнопці Получить данные. На екрані з'явиться меню з такими пунктами:

  • створити джерело даних;

  • відкрити джерело даних;

  • використовувати адресну книгу; параметри заголовка.

  1. Виберіть Создать источник данных. На екрані з'явиться діалогове вікно.

  2. У стандартному джерелі даних при необхідності можна додати нові поля або видалити непотрібні. Щоб видалити поле, клацніть на ньому і потім на кнопці Удалить поле. Для додавання поля наберіть ім'я поля в області Имя поля і клацніть на кнопці Добавить поле. Щоб змінити порядок розташування полів, клацніть на поле, що хочете перемістити, а потім на кнопках із стрілками.

Довжина імені поля не повинна перевищувати 40 символів. Ім'я поля повинно починатися з букви і складатися тільки з букв, номерів і символів підкреслення.

  1. Закінчивши роботу з полями джерела даних, клацніть на кнопці ОК.

  2. У діалоговому вікні, що відкрилося, Сохранить как введіть ім'я файла списку розсилання і клацніть на кнопці ОК.

Знову створене джерело даних не містить записів. Натисніть кнопку ^ Правка источника данных, щоб додати нові записи в джерело даних або кнопку Правка основного документа, щоб додати поля злиття в основний документ.

  1. Клацнувши на кнопці ^ Правка источника данных, почніть створювати список даних. На екрані з'явиться діалогове вікно Форма данных.

  2. Заповніть поля форми інформацією про одну людину. Для переходу від одного поля до іншого використовуйте клавішу <Таb>.

  3. Заповнивши всі необхідні поля, клацніть на кнопці Добавить, щоб додати цей запис у таблицю даних.

  4. Виконаєте пп. 8 і 9 для всіх осіб, яких ви хочете включити в таблицю.

  5. Закінчивши введення інформації, клацніть на кнопці ОК.

За допомогою кнопок із стрілками в нижній частині діалогового вікна ^ Форма данных можна по черзі переглядати дані списку, завдяки цій можливості при необхідності можна завжди повернутися до попереднього запису і виправити його. Щоб видалити запис, перейдіть на нього за допомогою кнопок із стрілками і натисніть клавішу <Del>.

Завершивши ввід інформації у джерело даних, поверніться в основний документ. Тепер потрібно вставити в основний документ імена полів, щоб визначити, які дані будуть вставлені в те або інше місце документа при злитті. Якщо основний документ відсутній на екрані, виберіть його з меню Окно і виконайте такі дії:

  1. Встановіть позицію вводу в те місце документа, де повинні з'явитися дані з джерела.

  2. Клацніть на кнопці Поля слияния панелі інструментів Слияние. На екрані з'явиться меню зі списком імен усіх полів вашої таблиці.

  3. Клацніть на назві поля, яке ви хочете вставити в документ.

  4. Повторіть пп. 1-3 для кожного поля, яке вставляється. Пам'ятайте, що самі по собі поля не містять прогалин і знаків пунктуації, тому необхідні прогалини і знаки пунктуації повинні бути розставлені перед тим, як будуть вставлені поля.

  5. Закінчивши вставку полів в основний документ, збережіть його за допомогою команди Файл>Сохранить.

Для того, щоб перевірити, чи правильно в документ вставлені поля злиття, використовуйте кнопку Поля/данные панелі інструментів Слияние. При цьому поля злиття будуть замінені даними з першого запису джерела даних. Перегляньте основний документ і переконайтеся, що всі поля вставлені правильно.

Для сортування джерела даних, перед тим, як клацнути на кнопці Объединить діалогового вікна Объединить, клацніть на кнопці Отбор записей. На екрані з'явиться діалогове вікно Отбор записей. Клацніть на закладці Сортировка записей, щоб відкрити сторінку з параметрами сортування.

Записи можна відсортувати по будь-якому полю, обравши його в списку ^ Сортувати по полю. Якщо ви хочете додатково відсортувати записи джерела даних по інших полях, виберіть їх у списку Затем по полю і Затем по полю.

Якщо записи повинні бути відсортовані в оберненому порядку, включіть відповідну опцію ^ По убыванию.

Для позначення процесу добору записів при злитті використовується термін фільтрація.

Щоб при злитті використовувати фільтр, клацніть на кнопці ^ Отбор записей діалогового вікна Слияние перед тим, як почати об'єднання. Клацнувши на закладці Фильтрация записей (Отбор записей), ви побачите перелік параметрів. Зазначте параметри фільтрації записів, встановив відповідні значення в групах Поле, Оператор і Значение для кожного критерію.

Клацнувши на кнопці Правка в групі ^ Источник данных діалогового вікна Слияние, ви можете редагувати дані за допомогою форми даних. Таким чином, легко і зручно добавляти і редагувати адреси й імена в списку розсилання. При необхідності, клацнувши на кнопці Источник діалогового вікна Форма данных, можна уявити джерело даних у звичайному документі Word.

У цьому випадку дані будуть подані у вигляді таблиці. Кожне поле подане окремим стовпчиком, кожний запис - окремим рядком. У першому рядку записані імена полів. Дані можна редагувати прямо в таблиці.

Для того, щоб додати або видалити поля ( стовпчики ) таблиці, клацніть на кнопці ^ Поле базы данных (Управление полями). На екрані з'явиться діалогове вікно Управление полями. Для додавання в таблицю поля введіть ім'я поля в область Имя поля і клацніть на кнопці Добавить. Щоб видалити поле, виведіть його назву в списку Имена полей в заголовке і клацніть на кнопці Удалить.

    1. Записати макрос, що перетворює параметри абзацу на такі: Уровень 1, інтервал після - 12 пт, міжрядковий інтервал - полуторний, вирівнювання по лівому краю, розмір шрифту -14, полужирний курсив. Продемонструйте на двох абзацах.

Запис макросу з використанням реєстратора провадиться в такий спосіб:

  1. Виконайте команду Сервис > Макрос Начать запись або клацніть двічі на кнопці ЗАП у рядку стану. З'явиться діалогове вікно Запись макроса.

  2. У полі Имя макроса наберіть ім'я макроса.

  3. Якщо ви хочете призначити макросу комбінацію клавіш, винести його на панель інструментів, клацніть на відповідній кнопці в області Назначить макрос діалогового вікна. З'явиться діалогове вікно Настройка, у якому ви зможете вибрати кнопку панелі інструментів або комбінацію клавіш. Якщо ж ви не призначите макросу комбінацію клавіш і не включите його в панель інструментів, то зможете запускати його за допомогою команди Сервис > Макрос.

  4. Щоб почати запис макросу, клацніть на кнопці ОК. У результаті діалогове вікно ^ Запись макроса зникне, слово "ЗАП" у рядку стану буде виділено, і на екрані з'явиться плаваюча панель інструментів Запись макроса.

  5. Наберіть послідовність комбінацій і команд, що ви хочете занести в макрос. Для запису команд Word використовуйте комбінації клавіш, кнопки панелей інструментів і пункти меню. У макрос будуть занесені всі клавіші, що натискаються, включаючи клавіші переміщення курсору, наприклад стрілки,
    ,
    і клавіші редагування, наприклад і . (В нашому випадку при записі макросу виконайте команду ^ Формат > Абзац, виберіть потрібні установки, потім установіть розмір і накреслення шрифта).

  6. Щоб призупинити запис макросу, клацніть на кнопці Пауза панелі інструментів Запись макроса. Ця можливість придасться для виконання деяких операцій Word, що не повинні бути включені в макрос. Наприклад, якщо ви забули, як користуватися функцією, що хочете включити в макрос, клацніть на кнопці Пауза і викликайте довідку. Коли ви будете готові продовжити запис макросу, знову клацніть на кнопці Пауза.

  7. По закінченні клацніть на кнопці Стоп або знову двічі клацніть на слові "ЗАП" у рядку стану.

Запустіть макрос для перевірки. Якщо ви включили макрос у панель інструментів або призначили йому комбінацію клавіш, то запустіть його, клацнувши на кнопці панелі інструментів або натиснувши відповідну комбінацію клавіш. Макрос можна запустити і декілька інакше:

  1. Виберіть команду ^ Сервис >Макрос для виклику діалогового вікна Макрос.

  2. З списку макросів, що з'явилися в діалоговому вікні, виберіть потрібний. Якщо ж у цьому списку немає потрібного вам макроса, перевірте параметр Макросы из. Макрос може знаходитися в іншому шаблоні.

  3. Клацніть на кнопці Выполнить.

Якщо при записі макросу ви зробили помилку, скасуйте запис і почніть усе спочатку. Але можна зробити інакше - завершіть запис макросу, а потім у редакторі виправте помилку.

Процедура редагування макроса:

  1. Виберіть команду ^ Сервис > Макрос, щоб викликати діалогове вікно Макрос.

  2. Виберіть макрос, що потрібно відредагувати, і клацніть на кнопці Изменить. Макрос з'явиться у своєму власному вікні разом із спеціальною панеллю інструментів.

  3. Внесіть у макрос необхідні зміни. Виправте помилки, видалите непотрібні команди і додайте додаткові команди.

  4. Збережіть зміни і закрийте вікно макроса.

    1. На прикладі будь-якого тексту продемонструйте застосування виправлень (Сервис> Исправления).

Для цього виконайте такі дії:

  1. Виконайте команду Сервис>Исправления>Выделить исправления..

  2. В діалоговому вікні Исправления включіть флажок Записывать исправления.

  3. Виберіть потрібні настроювання для видаленого та вставленого тексту за допомогою команди Параметры діалогового вікна Исправления.
^

3.Контрольні запитання


  1. Як за допомогою змісту швидко перейти до будь-якого заголовка документа?

  2. Як понизити рівень будь-якого заголовка до звичайного тексту?

  3. Якими засобами документу можна привласнити ієрархічну структуру?

  4. Коли використовують структурні рівні?

  5. Як у документі зробити автоматичну перевірку орфографії?

  6. Що потрібно зробити, щоб замість абревіатури університету в необхідних місцях тексту записувалося його повне найменування?

  7. Коли Word реєструє виправлення? Як виконувати порівняння документів?

  8. Як виконати автоматичну позначку елементів предметного покажчика?

  9. Які поля можуть бути вставлені в форму?

  10. Як надрукувати заповнену форму на стандартному бланку?

  11. Наведіть приклад задач, де використовують злиття.

  12. Що таке основний документ?

  13. Що таке джерело даних?

  14. Що таке запис?

  15. Що таке поле в текстовому документу?

  16. Які є два типи полів?

  17. Наведіть приклади полів Word.

  18. Які етапи процесу злиття?

  19. Як створити основний документ на бланку?

  20. Як редагувати джерело даних у звичайному документі Word?

  21. Як відсортувати записи при злитті?

  22. Як відфільтрувати записи при злитті?

  23. Що означає виконати злиття документів?

  24. Як на конвертах друкувати адреси?

  25. Як підготувати 100 запрошень?

  26. Як записати макрос?

  27. Як призначити макросу комбінацію клавіш?

  28. Як виконати макрос?

  29. Як під час запису макроса користуватися довідкою?

  30. Як зупинити макрос?
^

4.Варіанти індивідуальних завдань для удоскона­лення матеріалу


Варіант 1.

  1. Створіть форму табеля успішності учня по чвертях. У формі повинні бути задіяні всі типи полів.

  2. Процедурою злиття створіть паспорт. Продемонструйте додавання записів, використання фільтрів, сортування.

  3. Запишіть макрос, що встановлює розрив сторінки, альбомну орієнтацію, вставляє таблицю розміром 5х4 і обрамляє її лінією з товщиною 1 пт.


Варіант 2.

  1. Створіть форму оголошення про прийом студентів у ВУЗи. У формі повинні бути задіяні всі типи полів.

  2. Процедурою злиття створіть свідоцтво про народження. Продемонструйте додавання записів, використання фільтрів, сортування.

  3. Запишіть макрос вставки у верхній колонтитул справа номера сторінки, у нижній колонтитул зліва - дати і часу.


Варіант 3 .

  1. Створіть форму гастрольної афіші. У формі повинні бути задіяні всі типи полів.

  2. Процедурою злиття створіть диплом. Продемонструйте додавання записів, використання фільтрів, сортування.

  3. Запишіть макрос, що знаходить у тексті всі підкреслені слова зі звичайним шрифтом і заміняє їх словами з полужирним курсивом розміром 14. Призначте макрос комбінації клавіш Alt+A.


Варіант 4.

  1. Створіть форму поштове повідомлення для посилки. У формі повинні бути задіяні всі типи полів.

  2. Процедурою злиття створіть запрошення. Продемонструйте додавання записів, використання фільтрів, сортування.

  3. Запишіть макрос, що заміняє дві прогалини в тексті на одну, а потім прогалину і символи (точка, кома, двокрапка, точка з комою) на ці ж символи без прогалин.



5.Рекомендована література


  1. Руденко В.Д. та ін. Практичний курс інформатики. – К.: Фенікс, 1997.

  2. Дуг Лоу. Секреты Word для Windows 95. – К.: Диалектика, 1996.

  3. Рейзнер Т. Самоучитель Word 97. – СПб.: Питер, 1999.

  4. Каммингс С. и Коварт Р. Секреты Office 97. – К.: Диалектика, 1997.








МСУ, Факультет комп’ютерних наук

Схожі:

Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №8: " Автоматизація розробки документів у ms word "
Мета роботи: Навчитися ефективно використовувати засоби ms word І застосовувати макроси для автоматизації рутинної роботи
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №6: " Текстовий процесор ms word "
Мета роботи: Вивчення базових можливостей текстового процесора Microsoft Word, придбання початкових навичок роботи в Word
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №64: " Текстовий процесор ms word "
Мета роботи: Вивчення базових можливостей текстового процесора Microsoft Word, `набуття початкових навичок роботи в Word
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №10
...
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconТема: Злиття документів у Microsoft Word
Мета: Набути практичних навичок у використанні можливостей для автоматизації підготовки документів текстового редактора Microsoft...
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconДокументи
1. /ЛАБОРАТОРНА РОБОТА ь1.doc
2. /ЛАБОРАТОРНА...

Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconДокументи
1. /Лабораторн_ роботи гр. 721/Вх_дний контрол з ЛАБ. РОБ. Ф_ЗИКА.doc
2. /Лабораторн_...

Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №10: " Автоматизація розрахунків та аналізу даних за допомогою Microsoft Excel"
Мета роботи: Навчитися налагоджувати та використовувати ms excel при розв’язанні задач та розробляти системи для обробки даних на...
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconЛабораторна робота №10: " Автоматизація розрахунків та аналізу даних за допомогою Microsoft Excel"
Мета роботи: Навчитися налагоджувати та використовувати ms excel при розв’язанні задач та розробляти системи для обробки даних на...
Лабораторна робота №6: \" Автоматизація розробки документів засобами ms word \" iconДокументи
1. /Лабораторн_ роботи гр. 721/Вх_дний контрол з ЛАБ. РОБ. Ф_ЗИКА.doc
2. /Лабораторн_...

Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи