Створення тестових питань у редакторі Word icon

Створення тестових питань у редакторі Word




НазваСтворення тестових питань у редакторі Word
Дата28.07.2012
Розмір84.8 Kb.
ТипДокументи

Створення тестових питань у редакторі Word


Використання редактора Word суттєво пришвидшує створення тестових питань, особливо якщо йдеться про велику кількість подібних чи однотипних питань, бо у Word 'і ви можете легко копіювати питання в буфер обміну, потім декілька раз вставляти їх, вносячи потрібні виправлення.

Перевагою Word є також і те, що він здійснює перевірку орфографії, питання можна готувати на комп'ютері, не підключеному до Інтернету, до того ж більшість наших користувачів знають краще Word, ніж Moodle.

Щоб скористатися цим способом створення питань треба:

  1. Створити файл Word на основі спеціального шаблону.

  2. Створити в цьому файлі тестові питання й експортувати їх у формат GIFT.

  3. Імпортувати у ваш курс питання з файлу в форматі GIFT.

За допомогою запропонованого шаблону можна створювати тестові питання, які містять тільки текст (спрощена форма експорту), а також питання, до складу яких входять формули математичного редактора і (або) графічні малюнки (більш складна форма експорту).
^

Як встановити файл шаблону


Краще файл шаблону Moodle_Test_Universal.dot зберігати там, де зберігаються всі шаблони Word (зазвичай на вашому комп'ютері ця папка має назву
c:\Documents and Settings\Ім'я користувача\Application Data\Microsoft\Шаблоны). В такому випадку ви зможете створювати файли на основі цього шаблону, вибравши в меню Файл > Создать > Шаблоны на моем компьютере > Moodle_Test_Universal.dot. Якщо ж ви запишете шаблон до іншої папки, то відкриватимете його як будь-який інший файл.

Однак, куди б ви не записали файл шаблону, перш ніж його відкрити, треба обов'язково пересвідчитись, що у Word не встановлений надто високий рівень безпеки, інакше макроси цього шаблону будуть відключені й шаблон не виконуватиме своїх функцій.

Отже, вам треба вибрати в мерю: Сервис > Макрос > Безопасность > Средняя > ОК:



Середній рівень безпеки означає, що при відкритті файла, що містить макроси, користувачеві виводиться відповідне попередження, бо макроси – це програми, а серед них можуть бути і віруси. Якщо користувач не впевнений, він має змогу відключити макроси, але в файлі нашого шаблона макроси корисні, і відкриваючи цей файл, вам треба натиснути кнопку Не отключать макросы.



Файл з тестовими питаннями, створений на основі шаблону, міститиме тільки посилання на макроси, які розташовані в шаблоні. Це означає, що макроси в цьому файлі, відкритому на іншому комп'ютері, швидше за все, працювати не будуть. Текст самих питань і відповідей ви бачити будете, але додати нові питання або виконати операцію експорту ви не зможете. Тому, якщо ви плануєте передавати або використовувати підготовлені питання в doc-форматі на інших комп'ютерах, слід їх передавати разом з шаблоном. Найпростіше це зробити, якщо організувати, наприклад, в папці Мои документы підпапку Тести, в яку помістити шаблон Moodle_Test_Universal.dot, а потім там же створювати і зберігати всі файли з підготовленими тестовими питаннями на основі цього шаблону. На інший комп'ютер слід передавати всю папку Тести. При відкритті файлу з питаннями на іншому комп'ютері шаблон буде знайдений в цій же папці, і все працюватиме нормально. Якщо ж основна робота з підготовки тестів планується тільки на особистому персональному комп’ютері, а для передачі плануються тільки експортовані файли у форматі Gift, тоді краще розмістити шаблон у штатній папці c:\Documents and Settings\Ім'я користувача\Application Data\Microsoft\Шаблоны, як це було рекомендовано вище.
^

Як вводити питання, користуючись шаблоном


Відкривши файл шаблону Moodle_Test_Universal.dot, ви побачите зразки тестових питань. Вони приведені тут лише для того, щоб показати вам, як виглядають питання у цьому шаблоні. Ознайомившись зі зразками, вилучіть їх і переходьте до створення власних питань.

Щоб ввести нове питання, розкрийте список меню Питання і виберіть у ньому один з наступних шести типів питань:



  1. ^ Твердження (Так/Ні). Тут ви можете ввести твердження, яке студенти мають розпізнати як правильне або неправильне, давши відповідь типу Так/Ні. Для вашої зручності, правильні твердження тут та в розглянутих нижче інших елементах питань відображаються зеленим кольором, хибні – червоним.

  2. ^ На відповідність. Після введення самого питання, вам треба сформувати два списки: лівий і правий (наприклад, список країн зліва і список їхніх столиць справа). Лівий список підсвічується синім кольором, правий – жовтим. Студенти мають встановити правильну відповідність між елементами двох списків. Списки повинні містити не менше трьох елементів. При введенні списку перехід від одного елементу до іншого здійснюється натисканням клавіші Enter.

  3. ^ Коротка відповідь. Ввівши текст питання, натисніть Enter і введіть відповідь. Якщо відповідей декілька, то кожна з них вводиться окремим рядком. Відповіді можуть бути як правильні, так і хибні. Зміна статусу відповіді з правильної на хибну і навпаки здійснюється за допомогою кнопки Правильна/Неправильна відповідь.

  4. ^ Числове питання. Ввівши текст питання, натисніть Enter і введіть відповідь у формі числа. Цілу частину числа від десяткового дробу слід відділяти КРАПКОЮ, а не комою.

  5. ^ Множинний вибір. Це питання може допускати як одну, так і декілька правильних відповідей. Отже, вам треба ввести спочатку текст питання, потім відповіді на нього. Зміна статусу відповіді з правильної на хибну і навпаки здійснюється за допомогою кнопки Правильна/Неправильна відповідь. Якщо правильних відповідей декілька, то ви повинні задати вагові коефіцієнти: додатні для кожної правильної і від'ємні для кожної неправильної відповіді. Для введення коефіцієнтів, встановіть курсор у рядок з текстом запитання і натисніть кнопку Вказати вагу. Вам буде запропоновано набір числових значень, які ви можете скоригувати, однак при цьому додатні коефіцієнти в сумі завжди повинні складати 100%, бо оцінка студента обчислюється шляхом додавання коефіцієнтів всіх обраних ним відповідей. Якщо сума виявиться від'ємною, вона обнуляється. Якщо ж ви бажаєте вилучити вагові коефіцієнти, скористайтесь кнопкою Прибрати вагу. При цьому частки оцінки для одного питання при імпорті питань в Moodle розподіляються рівномірно (+100%/n для кожної правильної відповіді та –100%/m для кожної неправильної відповіді). Оскільки множинний вибір є найбільш вживаним типом тестових питань, в головне меню окремим пунктом винесено команду для більш швидкого створення цього виду питань.

  6. ^ З пропущеним словом – це варіант питання з короткою відповіддю. Викладачу треба вести якусь фразу, потім виділити в ній одне слово і вибрати в меню Питання опцію Пропуск. В результаті замість даного слова студенти побачать на екрані символи підкреслення і їхнє завдання полягатиме в тому, щоб правильно ввести це пропущене у фразі слово.

В питаннях типів 3, 4 і 5 до кожного варіанту відповіді викладач має змогу ввести свій коментар (репліку), що може видаватися студенту при виборі ним цього варіанту відповіді. Щоб ввести коментар, встановіть курсор в рядок потрібної відповіді й натисніть кнопку Коментар.

Як вводити питання з використанням цього шаблону, показано у флеш-фільмі Д.Пупиніна (для російськомовної версії шаблону). Сам шаблон для створення питань у текстовому процесорі Word розробив Mikko Rusama, українською мовою переклав А.Мазарчук. Модифікацію шаблону для роботи як з текстовими питаннями, так і з питаннями, що містять математичні формули і малюнки, виконано А.Мазарчуком. Шаблон коректно працює у редакторах Word з версії XP (2002) і вище. Питання коректно імпортуються у Moodle версій 1.6.x (для кодування Unicode). Перевірку для інших версій Word і Moodle вам доведеться виконати самостійно. Код макросів шаблону відкритий, тому ви зможете при необхідності зробити всі потрібні зміни.
^

Як імпортувати в Moodle створені у Word питання


Перед експортом питань бажано ще раз перевірити правильність їх введення, зокрема: чи є кружечок перед кожним варіантом відповіді, чи правильним кольором відображені відповідні елементи питання: правильні й неправильні відповіді, коментарі викладача, списки відповідності тощо. Для цього може бути корисним і відображення стилів, застосованих у питанні. Щоб побачити ці стилі, виберіть в меню Сервис > Параметры > Вид і встановіть у полі ширина полосы стилей значення, відмінне від нуля, наприклад 2 см.

Завершивши перевірку, збережіть створений вами файл (може вам ще доведеться вносити до нього якісь виправлення), а потім виберіть у меню Питання опцію Експортувати. В результаті буде створено файл, що містить опис цих питань в форматі GIFT. Шаблон дозволяє виконувати експорт питань у двох режимах:

  1. ^ Питання і варіанти відповідей містять тільки текст. В результаті експорту у папці з початковим документом у форматі .doc з’являється текстовий файл (.txt) з цими ж питаннями у форматі Gift. Імпорт у Moodle здійснюється максимально просто. Вам необхідно увійти на головну сторінку курсу в системі Moodle, за допомогою меню Керування перейти до Питань, створити або перейти до категорії питань, де буде виконуватися імпорт, і клацнути по посиланню Імпорт питань з файлу. За допомогою кнопки Обзор необхідно вибрати на локальному комп’ютері створений файл з питаннями у форматі Gift і виконати імпорт. Всі питання з локального файлу будуть завантажені на сервер системи Moodle.

  2. ^ Питання містять хоча б один малюнок або формулу математичного редактора. В результаті експорту у папці з початковим документом у форматі .doc з’являється файл zip-архіву, який містить текстовий файл з питаннями у форматі Gift і папку з малюнками. Оскільки посилання на малюнки у текстовому файлі прив’язуються до коду курсу, в який імпортуються питання, вам треба до початку експорту визначити цей код. Для цього увійдіть на головну сторінку курсу. В адресному рядку браузера ви побачите приблизно наступне: http(s)://.../course/view.php?id=215. Для цього прикладу код курсу є 215. Імпорт питань виконується дещо інакше. Спочатку треба завантажити файл zip-архіву у файли курсу на сервер (Головна сторінка курсу > Меню Керування > Файли), розпакувати його у кореневій папці файлів курсу (посилання Розпакувати zip-архів напроти файлу архіву). В результаті у файлах курсу з’явиться текстовий файл з питаннями у форматі Gift і папка з малюнками. Після цього файл zip-архіву можна видалити. Для виконання імпорту необхідно увійти на головну сторінку курсу, за допомогою меню Керування перейти до Питань, створити або перейти до категорії питань, де буде виконуватися імпорт, і клацнути по посиланню Імпорт питань з файлу. Далі імпорт здійснюється не з файлу на локальному комп’ютері (як в першому випадку), а з файлу, який знаходиться у файлах курсу, тобто на сервері Moodle (у секції Імпорт з файлу вже існує у файлах курсу натисніть Виберіть файл, у вікні файлів курсу напроти файлу з питаннями у форматі Gift натисніть Вибрати, натисніть кнопку Імпорт з цього файлу). Зверніть увагу, що всі папки з малюнками для питань повинні знаходитися у корені папки файлів курсу. Інакше малюнки не будуть відображатися або вам доведеться коригувати посилання на малюнки вручну. Для цього режиму експорту вам необхідно мати додаткову програму архівації pkzipc.exe у папці C:\Windows (C:\Windows\pkzipc.exe), або в іншій папці, шлях до якої вказаний у списку пошуку програм Windows.

Рекомендується для уникнення проблем з завантаженням файлів, імена яких складаються з російських або українських літер, визначати імена документів з тестовими питаннями тільки латинськими літерами, цифрами і знаками підкреслення. Якщо ж вам все-таки зручніше мати початковий doc-файл з іменем, визначеним рідною мовою, то при експорті проста функція Translit автоматично перетворить це ім’я для експортованих файлів, використовуючи латинські літери і символи підкреслення.

Можливо, після імпорту питань вам ще доведеться внести в них певні виправлення, наприклад, діапазони правильних відповідей для числових питань.

Щоб таблиця категорії питань виглядала компактніше, можна також скоротити чи змінити назви деяких питань, бо під час імпорту до назви переписується весь текст питання, що задається студенту.

На завершення відзначимо, що описаним тут способом можна ввести не всі наявні в Moodle типи питань.

Схожі:

Створення тестових питань у редакторі Word iconВимоги до оформлення статті
Структура статті повинна відповідати вимогам вак україни. Текст має бути набраний у редакторі ms word шрифтом Times New Roman розміром...
Створення тестових питань у редакторі Word iconПравила оформлення матеріалів Текст доповіді має бути набраний у редакторі Microsoft Word (версії 2003 р або 2007 р.) з такими параметрами форматування
Текст доповіді має бути набраний у редакторі Microsoft Word (версії 2003 р або 2007 р.) з такими параметрами форматування
Створення тестових питань у редакторі Word iconПравила оформлення матеріалів Текст доповіді має бути набраний у редакторі Microsoft Word (версії 2003 р або 2007 р.) з такими параметрами форматування
Текст доповіді має бути набраний у редакторі Microsoft Word (версії 2003 р або 2007 р.) з такими параметрами форматування
Створення тестових питань у редакторі Word iconВимоги до оформлення статей
Стаття виконується в текстовому редакторі Microsoft Word 2003 (більш нові версії не допускаються)
Створення тестових питань у редакторі Word iconВимоги до оформлення статей
Стаття виконується в текстовому редакторі Microsoft Word 2003 (більш нові версії не допускаються)
Створення тестових питань у редакторі Word iconЗавдання для контрольних робіт
Як у редакторі Word за допомогою клавіатури швидко переміститися до початку наступної сторінки, до кінця документа?
Створення тестових питань у редакторі Word iconВимоги до оформлення матеріалів
Доклади та доповіді надсилати у форматі А4 набрані в редакторі Word (інтервал 1,5; поля: зверху, знизу, справа 1,5 см., зліва – 2,5...
Створення тестових питань у редакторі Word iconДо оформлення тез доповідей
Приймаються до друку тези обсягом до 3 сторінок формату а-4, надруковані в текстовому редакторі Microsoft Word та оформлені відповідно...
Створення тестових питань у редакторі Word iconДо оформлення тез доповідей
Приймаються до друку тези обсягом 3–4 сторінки формату а-4, надруковані в текстовому редакторі Microsoft Word та оформлені відповідно...
Створення тестових питань у редакторі Word iconВимоги до оформлення тез доповідей
Приймаються до друку тези обсягом до 4 сторінок формату а-4, надруковані в текстовому редакторі Microsoft Word та оформлені відповідно...
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи