Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 icon

Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201




НазваМетодичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201
Сторінка3/3
Дата14.09.2012
Розмір0.83 Mb.
ТипМетодичні вказівки
1   2   3
^

Модифікація області діаграми


Щоб покращити зовнішній вид діаграми, можна додати рамку навколо неї, змінити фон області, на якій вона розташовується, і т. п. Щоб змінити вид області, на якій розміщена діаграма, виконайте наступне:

  1. Виділіть елемент, область якого необхідно змінити, або виберіть його в списку ^ Элементы диаграммы, розташованому на панелі інструментів діаграми. Так, щоб змінити фон області діаграми або його межі, натисніть на області діаграми. Для модифікації фона або межі області побудови діаграми виберіть Область построения диаграммы.

  2. Натисніть на кнопці Формат області побудови на панелі діаграми.

  3. Виберіть вкладку Вид.

  4. Щоб змінити вид межі виділеної області, встановіть відповідні опції і області вікна Рамка. Таким чином ви можете змінювати тип, колір і товщину лінії меж. В області вікна Образец відобразяться лінії меж, відповідні зробленим вами установкам.

  5. Якщо вимагається змінити фон виділеної області, виберіть відповідний колір і засіб заливки. Наприклад, натисніть на кнопці ^ Способы заливки і виберіть потрібний тип заливки (Градієнтна, Текстура, Візерунок або Малюнок). В якості фона можна також використати графік, що імпортувався. Виконавши всі необхідні установки, натисніть на кнопці ОК.



^ Додаткові засоби форматування діаграм


Модифікація сітки

За замовчанням на діаграмах зображаються тільки горизонтальні лінії сітки. Ви можете змінити це і відобразити тільки вертикальні лінії чи одночасно вертикальні і горизонтальні. Крім того, ви можете змінювати значення межі розташування ліній сітки на аркуші і відстань між основними її лініями, а також додавати проміжні.

^ Основні і проміжні лінії сітки. Орієнтуючись по основних лініях сітки, можна дізнатися приблизні значення даних, виведених на діаграму. Проміжні лінії дадуть можливість більш точно оцінити їх значення. Вони розміщуються між основними.

^ Модифікація виду сітки. Якщо необхідно змінити вид вертикальних або горизонтальних ліній сітки (або тільки будь-яких одних) або відобразити проміжні, зробіть наступне:

  1. Натисніть на діаграмі. Відкрийте меню Диаграммы і виберіть в ньому пункт Параметры диаграммы. З‘явиться відповідне діалогове вікно.

  2. Натисніть на корінці вкладки Линии сетки.

  3. Виберіть ті лінії сітки, які бажаєте вивести. Приклад діаграми, відповідний вашим установкам, з’явиться в правій частині вікна.

  4. Натисніть на кнопці ОК.


^ Модифікація шкали значень

Ви можете змінити початкове і кінцеве значення шкали вісі значень (звичайно це Y- вісь), а також відстань між сусідніми лініями сітки, якщо вам необхідно більш чітко поділити на діаграмі різноманітні ряди даних. Для цього виконайте наступне:

  1. В списку панелі інструментів Элементы диаграммы виділіть пункт Ось значений.

  2. Натисніть на кнопці панелі Формат оси.

  3. Виберіть вкладку Шкала.

  4. Вкажіть у відповідних полях максимальне і мінімальне значення даних, що виводяться. Наприклад, якщо встановлено максимальне значення 12000, а максимальне значення даних складає тільки 9800, то для покращення зовнішнього виду діаграми встановіть максимальне значення, що виводиться, яке дорівнює 10000.

  5. Інтервал між сусідніми лініями сітки вказує в поле Цена основных делений. Якщо ви відображаєте і проміжні лінії, то вкажіть в полі ціну проміжних поділок – відстань між проміжними лініями.

  6. Крім того, встановіть точку, в якій вісь Х буде перетинатися з віссю Y. Для цього введіть відповідне значення в поле ось Х пересекается в значении____. Якщо необхідно, щоб вісь Х перетинала вісь Y в максимальному її значенні, тоді встановіть прапорець опції Перетин з віссю Х(категорій) в максимальному значенні.

  7. Щоб вивести діаграму з логарифмічною шкалою, встановіть прапорець опції ^ Логарифмическая шкала.

Від‘ємні значення. Якщо на діаграмі відображаються і від‘ємні значення, то опцією Логарифмическая шкала користуватися не можна.

  1. Щоб змінити напрямок вісі значень на протилежний, виберіть зворотний порядок значень.

  2. Після вибору всіх установок натисніть на кнопці ОК.


^ Модифікація шкали категорій


Ви також можете змінити параметри шкали категорій (вісі Х). Наприклад, треба збільшити відстань між стовпчиками на лінійній діаграмі і т.п. Для цього потрібно виконати наступне:

  1. В списку Элементы диаграммы виберіть пункт Ось категорій.

  2. Натисніть на кнопці Формат оси.

  3. В діалоговому вікні, що з‘явилось, виберіть вкладку Шкала.

  4. Ви можете змінити точку перетину осей Х і Y, вказавши відповідне число в полі Пересечение с осью Y(значень) в категорії номер _____.

  5. Щоб відобразити на діаграмі кожну другу категорію, в поле Число категорій між підписами поділок введіть 2, щоб відображалась тільки кожна третя категорія, вкажіть в ньому 3 і т.д.

  6. Щоб між підписами поділок відображалося декілька категорій, введіть їх число в поле ^ Число категорий между делениями.

  7. Якщо прапорець опції Пересечение с осью Y(значень) між категоріями не встановлений, то на діаграмі не буде додаткового місця між першою і останньою категоріями і вертикальними лініями меж області побудови діаграми.

  8. Щоб змінити порядок виводу категорій на протилежний, встановіть прапорець ^ Обратный порядок категорий.

  9. Якщо необхідно, щоб шкала значень розташовувалася в правій частині діаграми, а не в лівій, як звичайно, то треба встановити прапорець опцій Пересечение с осью Y(значень) в максимальній категорії.

  10. Встановивши всі ці параметри, натисніть на кнопці ОК.


^ Модифікація тривимірних діаграм


На відміну від двовимірних діаграм, тривимірні дадуть об‘ємне подання. Щоб відобразити на екрані такі діаграми більш вдало, вам треба змінювати кут їх нахилу або обертати їх. Для цього виконайте наступне:

  1. В списку Элементы диаграммы виберіть пункт Углы.

  2. Натисніть на нижньому правому куті.

  3. Щоб повернути діаграму, просто перемістіть кут в потрібну сторону. Замість діаграми з‘явиться прямокутний паралелепіпед, що при переміщенні його куту буде змінювати своє положення.

  4. Вибравши необхідне положення діаграми, відпустіть кнопку миші. Знову з‘явиться вже змінена діаграма.


^ Модифікація параметрів діапазону дани


Кожному типу діаграм відповідають певні параметри, змінюючи які можна виділити окремі дані на діаграмі. Наприклад, на гістограмі змінюється відстань між категоріями і розмір перекриття (відстань, на які стовпчики різноманітних рядів перекриваються). Слід помітити, що якщо в гістограмі відображається тільки один діапазон даних, то всі стовпчики (за замовчанням) заливаються одним кольором. При необхідності різноманітні стовпчики заливаються різними кольорами. На графіку можна водночас відобразити декілька діапазонів даних різноманітними лініями або використати маркери ліній, а також формат ліній самих графіків для того, щоб розрізняти серію даних. Щоб змінити параметри відображення діапазону даних на діаграмі, виконайте наступне:

  1. В списку ^ Элементы диаграммы натисніть на ряд «Х».

Який ряд необхідно вибрати? Якщо на діаграмі відображається декілька рядів даних, то виберіть в списку необхідний. В деяких випадках не має значення, який ряд ви вибрали, оскільки більшість параметрів однакові для всіх рядів.

  1. Натисніть на кнопці ^ Формат рядов данных.


Приклад виконання роботи представлено в додатку 1.


Хід роботи: По відповідному варіанту задач, що були виконані в першій частині лабораторної роботи 4 побудувати діаграми трьох типів. Виконати зміни в діаграмах та відмітити зміни в таблицях задач.

Додаток 1.


Проаналізуємо табличну інформацію.


Для прогнозу роботи підприємств зручно працювати з графічними даними планового та фактичного обсягу продажу, тому першою діаграмою буде графік планового та фактичного обсягу продажу для заявлених підприємств. Створимо діаграму для вибраного діапазону даних.


2.1. Виділимо діапазон А2:D8.

2.2. За допомогою піктограми Мастер диаграмм почнемо побудову діаграми. (Рис. Приклад 1)




Рис. Приклад 1


2.3. В діалоговому вікні вибираємо потрібний графік та натискаємо кнопку Далее>.

2.4. В другому вікні контролюємо вибраний діапазон та ряди діаграми.

2.5. В третьому вікні вводимо назву діаграми та вісей, можемо змінити формат осей, лінію сітки та легенду. (Рис. Приклад 2)





Рис. Приклад 2


2.6. В четвертому вікні вибираємо місце розташування діаграми – на окремому листі чи в поточному та натискаємо на кнопці Готово. Одержуємо побудовану діаграму. (Рис. Приклад 3)

3. Аналогічно вибираємо діапазон даних для інших типів діаграм та виконуємо дії по створенню діаграми. (Рис. Приклад 4)

4. На прикладі свого варіанту виконуємо зміни в легенді, форматі діаграм, діапазоні даних по алгоритмам, що представлені в теоретичній частині.


Обсяг продажу за грудень 1998 року

№з.п.

Підприємство

план

факт

тис.грн

тис.грн

1

Універмаг

500

800

2

Маг.Олена

1000

200

3

Маг.Світлана

2000

1500

4

У Коробкіна

500

300

5

Швидко

600

600





Рис. Приклад 3


Обсяг продажу за грудень 1998 року

№з.п.

Підприємство

план

факт

перевищення

недовиконання

тис.грн

тис.грн

1

Універмаг

500

800

300

0

2

Маг.Олена

1000

200

0

800

3

Маг.Світлана

2000

1500

0

500

4

У Коробкіна

500

300

0

200

5

Швидко

600

600

0

0










Рис. Приклад 4

Лабораторна робота №5

^ ЗНАХОДЖЕННЯ КОРЕНІВ НЕЛІНІЙНОГО РІВНЯННЯ.


Мета роботи – придбати навички знаходження коренів нелінійного рівняння засобів Excel.


Короткі теоретичні вiдoмocmi
^

1. Підбір параметра


Коли потрібний результат обчислень по формулі відомий, але невідомі значення, необхідні для отримання цього результату, можна скористатися засобом Подбор параметра, вибравши команду Подбор параметра в меню Сервис. При підборі параметра Excel змінює значення в одній конкретній комірці до тих пір, поки обчислення по формулі, що посилається на цю комірку, не дадуть потрібного результату.

Візьмемо для прикладу квадратне рівняння х2-5х+6=0. Для знаходження коренів рівняння виконаємо наступні дії:

  • В комірку С3 (рис. 1) введемо формулу для обчислення значення функції, що стоїть в рівнянні зліва від знаку рівності. Як аргумент використовуємо посилання на комірку С2, тобто =С2^2-5*C2+6.



    Рис. 1. Вікно діалогу Подбор параметра

  • У вікні діалогу Подбор параметра (рис. 1) в полі Установить в ячейке введемо посилання на комірку з формулою, в полі Значение - бажаний результат, в полі Изменяя значения ячейки – посилання на комірку, в якій зберігатиметься значення параметра, що підбирається (вміст цієї комірки не може бути формулою).

  • Після натиснення на кнопку ^ Ok Excel виведе вікно діалогу Результат подбора параметра. Якщо підібране значення необхідно зберегти, то натисніть на Оk, і результат буде збережений в комірці, заданій раніше в полі Изменяя значения ячейки. Для відновлення значення, яке було в комірці С2 до використання команди Подбор параметра, натисніть кнопку Отмена.

При підборі параметра Excel використовує ітераційний (циклічний) процес. Кількість ітерацій і точність встановлюються в меню Сервис/Параметры/вкладка Вычисления. Якщо Excel виконує складну задачу підбору параметра, можна натиснути кнопку Пауза у вікні діалогу Результат подбора параметра і зупинити обчислення, а потім натиснути кнопку Шаг, щоб виконати чергову ітерацію і проглянути результат. При розв’язанні задачі в покроковому режимі з'являється кнопка Продолжить - для повернення в звичайний режим підбору параметра.

Повернемось до прикладу. Знову виникає питання: як одержати другий корінь? Як і у попередньому випадку необхідно задати початкове наближення. Це можна зробити таким чином (рис. 2,а):







б


Рис. 2. Пошук другого кореня







  • В комірку Х (С2) вводимо початкове наближення.

  • В комірку Хi (С3) вводимо формулу для обчислення чергового наближення до кореня, тобто
    =X-(X^2-5*X+6)/(2*X-5).

  • В комірку С4 помістимо формулу, яка задаватиме обчислення значення функції, що стоїть в лівій частині початкового рівняння, в точці Хi.

  • Після цього вибираємо команду Подбор параметра, де в якості комірки, що змінюється, приймаємо комірку С2. Результат обчислень зображений на рис. 2,б (в комірці С2 - кінцеве значення, а в комірці С3 - попереднє).

Проте все це можна зробити і дещо простіше. Для того, щоб знайти другий корінь, достатньо як початкове наближення в комірку C2 внести константу 5 і після цього запустити процес Подбор параметра.
^

2. Пошук розв’язку


Команда Подбор параметра є зручною для вирішення задач пошуку певного цільового значення, залежного від одного невідомого параметра. Для складніших задач потрібно використовувати команду Поиск решения (Решатель), доступ до якої реалізований через пункт меню Сервис/Поиск решения.

Задачі, які можна вирішувати за допомогою ^ Поиска решения, в загальній постановці формулюються так:

Знайти: х1, х2, …, хn.

такі, що: F(х1, х2, …, хn)> {Max; Min; = Value}

при обмеженнях: G(х1, х2, …, хn)> { Value; Value; = Value}

Шукані змінні – комірки робочого листу Excel – називаються регульованими комірками. Цільова функція F(х1, х2, …, хn), іноді називається просто ціллю, повинна задаватися у вигляді формули в комірці робочого листа. Ця формула може містити функції, визначені користувачем, і повинна залежати (посилатися) від регульованих комірок. У момент постановки задачі визначається, що робити з цільовою функцією. Можливий вибір одного з варіантів:

  • знайти максимум цільової функції F(х1, х2, …, хn);

  • знайти мінімум цільової функції F(х1, х2, …, хn);

  • досягти того, щоб цільова функція F(х1, х2, …, хn) мала фіксоване значення: F(х1, х2, …, хn)= а.

Функції G(х1, х2, …, хn) називаються обмеженнями. Їх можна задати як у вигляді рівності, так і нерівностей. На регульовані комірки можна накласти додаткові обмеження: невід’ємності і/або цілочисельності, тоді шуканий розв’язок шукається в області невід’ємних і/або цілих чисел.

Під цю постановку потрапляє найширше коло задач оптимізації, зокрема розв’язання різних рівнянь і систем рівнянь, задачі лінійного і нелінійного програмування. Такі задачі звичайно простіше сформулювати, ніж розв’язувати. І тоді для вирішення конкретної оптимізаційної задачі потрібен спеціально для неї сконструйований метод. Решатель має в своєму арсеналі потужні засоби розв’язання подібних задач: метод узагальненого градієнта, симплекс-метод, метод гілок і границь.

Розглянемо, як скористатися ^ Поиском решения на прикладі того ж квадратного рівняння.



^ Рис. 3. Вікно діалогу Поиск решения


Після відкриття діалогу Поиск решения (рис. 3) необхідно виконати наступні дії:

  1. У поле Установить целевую ячейку ввести адресу комірки, що містить формулу для обчислення значень функції, що оптимізується, в нашому прикладі цільова комірка – це С4, а формула в ній має вигляд: =C3^2- 5*C3 + 6;

  2. Для максимізації значення цільової комірки, встановити перемикач максимальному значению в положення , для мінімізації використовується перемикач минимальному значению, в нашому випадку встановлюємо перемикач в положення значенню і вводимо значення 0;

  3. У полі ^ Изменяя ячейки ввести адреси змінних комірок, тобто аргументів цільової функції (С3), розділяючи їх знаком ";" (або клацаючи мишкою при натиснутій клавіші Сtrl на відповідних комірках), для автоматичного пошуку всіх впливаючих на розв’язання комірок використовується кнопка Предположить;

  4. У полі Обмеження за допомогою кнопки Добавить ввести всі обмеження, яким повинен відповідати результат пошуку: для нашого прикладу обмежень задавати не потрібно;

  5. Для запуску процесу пошуку розв’язку натиснути кнопку Выполнить.



Для збереження одержаного розв’язку необхідно використати перемикач Сохранить найденное решение у вікні діалогу, що відкрилося, Результаты поиска решения. Після чого робочий лист прийме вигляд, представлений на рис. 4.





^ Рис. 4. Результати пошуку



Завдання.


Знайти корінь нелінійного рівняння f1(x)=f2(x) на заданому відрізку [a,b] засобами Excel за допомогою опції ^ Подбор параметра і використовуючи можливості Поиск решения при обмеженнях корінь a і корінь b.

Варіанти завдань наведені в таблиці.


^ ВАРІАНТИ ЗАВДАНЬ



п/п

Рівняння

А

В



tg(x) = 1/х

0

π/2



x - x3 + 1 =0

1

2



x + 3 = x3

1

2



x + x3 - 5 =0

1

2



2x + x5 - 1 =0

0

1



1 + x = x3

0

2



1 - 3 x + x5=0

0

1



1 - 5 x + x4=0

0

1


Лабораторна poбoтa №6

^ РОБОТА З БАЗАМИ ДАНИХ В ТАБЛИЧНОМУ NPOЦECOPI EXCEL


Мета роботи- придбати навички створення та роботи з базами даних в MS Excel.


1. Основні положення

З електронними таблицями Excel можна виконувати цілий ряд дій, характерних для робіт з базами даних (БД). При виконанні цих дій стовпці таблиці будемо називати, як це прийнято в БД, полями, а рядка — записами. Основні роботи , виконувані із БД, що випливають:

  • сортування;

  • пошук записів за прийнятим критерієм;

  • дії із записами, що задовольняють прийнятому критерію.

Почнемо із сортування, під яким розуміють упорядкування записів по зростанню або по

спаданню прийнятої ознаки в призначеному стовпці. Процес виконання сортування

покажемо на прикладі впорядкування результатів оптирисьного розподілу ресурсів в

часі, які отримані в главі 8 і наведені там же на рис. 8.4.3 (у даній главі рис.

1).

Алгоритм 1. Сортування елементів стовпців

  1. Викликати на екран БД, наведену на рис. 1, для виконання сортування.




Рис. 1

2.Курсор у будь-який осередок БД.

3.Дані, Сортування...

На екрані: діалогове вікно Сортування діапазону (рис. 2).

4.Увести імена полів і напрямок сортування, які
відображаються в діалоговому вікні.

5.ОК.

На екрані: результат сортування (рис. 3).




Рис. 2.



Рис. 3

Алгоритм 2. Сортування елементів рядків


1. Викликати БД для сортування рядків(рис. 4).



Рис. 4

2.Виділити сортируемую частина БД: комірці C2:F4.

3.Дані, Сортування...

4.Параметри...

5.Сортувати: стовпці (!) діапазону.

6.ОК.

7.Увести:

  • номер рядка електронної таблиці Excel (а не порядковий номер рядка в БД);

  • напрямок сортування.




Рис. 5

8. ОК.

На екрані: результат сортування (рис. 5).


Алгоритм 3. Сортування за допомогою кнопок панелі інструментов

За допомогою кнопок можна виконати сортування по елементах тільки одного стовпця.

1.Курсор в комірку стовпця, по якому виконується сортування.

2.Курсор на кнопку По зростанню або По спаданню.
4. М1.

На екрані: результат сортування.

Розглянутий алгоритм сортування забезпечує впорядкування даних як по стовпцях, так і по рядках. Інший важливою, якщо не основною, задачою БД є пошук записів, що задовольняють призначеному критерію. Однак пошук виконується тільки по полях, тобто по стовпцях електронної таблиці.

Якщо ж необхідно виконати пошук по записах, тобто по рядках електронної таблиці, то попередньо електронну таблицю треба транспонувати, у результаті чого рядки

таблиці стануть стовпцями , і таким чином таблиця буде готова для виконання необхідного пошуку.

Алгоритм 4. Транспонування бази даних

1.Викликати на екран БД (рис. 6).

2.Виділити всю БД, тобто B4:F9.

3.Виправлення, Копіювати...



Рис. 6

4.Курсор у лівий верхній кут де розташована транспонуюча БД, в В13.

5. Виправлення, Спеціальна вставка...

6.Транспонувати.

7.ОК.

На екрані: в осередках B13;G 17 перебуває транспонована БД, у якій рядки вихідної БД (B4:F9) стали стовпцями, а стовпці - рядками. При необхідності в транспонування БД можна змінити ширину стовпців, після чого транспонована БД буде готова до пошуку потрібної інформації.


2. Пошук

Під пошуком, що часто називають фільтрацією, будемо розуміти знаходження в БД таких записів, які задовольняють вимогам, що вводять для полів. Ці вимоги називаються критерієм пошуку (фільтрації). В Excel передбачено 2 види пошуку:

  • автофильтром;

  • розширеним фільтром.


Алгоритм 5. Пошук автофильтром

1.Викликати на екрані БД (рис. 2.Э.1).

2.Курсор у будь-який осередок БД.

3.Дані, Фільтр, Автофильтр.

На екрані: у кожному імені поля з'явилася стрілка.

4.Курсор на стрілку того поля, по якому хочемо зробити пошук (у прикладі:
Вартість).

5.М1.

На екрані: перелік значень всіх записів у цьому полі.

5.Увести значення, по якому потрібно виконати пошук.

На екрані: всі записи, що задовольняють уведеному значенню. Але це ще не все.

6.Якщо потрібно виконати пошук за таким значенням, якого немає в жодному записі, то
необхідно:

7.Условие...

На екрані: діалогове вікно Користувальницький автофильтр.

8.Увести необхідний критерій пошуку. Як приклад виберемо
критерій:


200 ≤ Вартість ≤ 400 (рис. 7)



Рис. 7

9. ОК.

На екрані: результат пошуку (рис. 8).



Рис. 8

Такий пошук можна послідовно виконувати по декількох полях.

Алгоритм 6, Відновлення вихідної бази даних

1. Дані, Фільтр, показати всі.

На екрані; БД зі стрілками.

2. Дані, Фільтр, Автофильтр.

На екрані: вихідна БД.

Крім розглянутого пошуку Автофильтром в Excel є режим пошуку Розширеним фільтром, що дозволяє робити наступні дії:

  • одночасний пошук по декількох полях;

  • пошук за вычисляемому критерієм.

Уведення умов при формуванні критерію пошуку виробляється за правилами, показаним на рис. 9.



Рис. 9


Алгоритм 7. Пошук розширеним фільтром


1. Викликати БД (рис. 1) в осередки B3:J8 (рис. 10).




Рис. 10

2.Сформувати критерій пошуку.

3.Визначити координати осередків, у яких сформований критерій (у прикладі: DILE13).

4.Визначити комірці в БД для подання результатів пошуку; приймаємо B16:J22.

5.Курсор у будь-який осередок БД.

6.Дані, Фільтр, Розширений фільтр.

На екрані: діалогове вікно Розширений фільтр (рис. 11).

7.Увести необхідні дані, як показано на рис 11.

8.ОК.

На екрані: результат пошуку в осередках B16:J20 (рис. 10).

З результатів пошуку видно, що записів, що задовольняють критерію, виявилося менше, ніж було для них виділено осередків.



Рис. 11


Крім критеріїв, розглянутих вище, можна робити пошук ще по одному дуже потужному типі критеріїв, що називається обчислюючим.

Критерій, обчислює, що вводить як звичайний критерій при роботі з розширеним фільтром, може включати формули, у яких аргументами є поля БД. Формули, що вводять, можуть бути двох видів:

  • формули, складені користувачем;

  • формули, що включають функції Excel.

Робота з обчислюють критериями, що, проілюстрована на рис. 12:

  • у С4 :К9 уведена вихідна база даних;

  • в F12- ім'я критерію, що обчислює, при обчисленні формули. (Це ім'я може бути будь-яким, але не повинне повторювати імені поля у вихідної БД.)

  • в F13- уведена формула, що є критерієм пошуку.

Як видно з формули (рис. 12), у неї вводяться залежності для першого рядка БД, що містять конкретні значення. При цьому, якщо вводять условия, що, для першого рядка справедливі, в комірці уведення F13 з'являється ІСТИНА, у противному випадку - НЕПРАВДА.



Рис. 12

Пошук проводиться по описаному вище алг. 7. Результати пошуку наведені в осередках С16:К17. Далі в осередках виробляється пошук за вычисляемому критерієм, що включає функцію Excel. Як приклад функції Excel прийнята функція СЬОГОДНІ(), що використовує системну дату.

В F21 уведене значення критерію, за допомогою якого перебувають роботи, що кінчаються після сьогоднішнього дня. Помітимо, що текст в осередки D21:E21 уведений тільки для илюстрачії і до пошуку відносини не має.

Очевидно, що пошук за таким критерієм має винятково важливе значення на практиці при контролі за ходом виконання запланованих робіт.

Автор сподівається, що наведені приклади показали, що пошук є потужним

засобами аналізу інформації наявної бази даних.


^ 3. Функції бази даних


Як ми з'ясували, при пошуку розширеним фільтром перебувають записи, що задовольняють

уведеному критерію, причому, як і у вихідної БД, в отриманих записах ряд полів містить числа. В Excel є можливість відразу ж у процесі пошуку робити дії над цими числами. Для цього використаються функції бази даних, які забезпечують із записами, що задовольняють уведеному критерію, що випливають основні дії:

  • арифметичні, що включають додавання й множення величин, що перебувають в осередках відфільтрованих записів;

  • статистичний аналіз величин, що перебувають в осередках відфільтрованих записів. При цьому в ході такого аналізу визначаються як мінірисьні, так і максирисьні зна-чения, а також середні значення й дисперсії тих величин, які перебувають у відфільтрованих записах. Ознайомлення зі списком функцій бази даних виробляється в такий спосіб.


Алгоритм 8. Виклик списку функцій бази даних

1.Курсор на кнопку Майстер Функцій.

2.Ml.

3.Курсор на Роботу з базою даних.
3. М1.

На екрані: список функцій, що входять у цю категорію.

5. Курсор на функцію, що цікавить.

6.М1.

На екрані: унизу діалогового вікна показане призначення виділеної функції. Розглянемо дії з деякими функціями бази даних.


Алгоритм 9. Обчислення за допомогою функцій бази даних

1. Викликати на екран вихідну БД, визначити її координати: З4:ДО9 (рис. 13).





Рис. 13

2.Курсор в FI2.

3.Увести критерії відбору записів для обчислення призначеної функції.

Критерії вводяться по тимі ж правилам, що й при роботі з розширеним фільтром. Як критерій приймаємо роботи, виконувані виконавцем Орловым.

4.Оприділити координати вводурітерія(для нашого випадку: F12:F13).

5.Курсор в осередок, де повинен бути результат, - F15

6.Майстер функцій, Робота з базою даних, БДСУММ.

7.Далі.

На екрані: діалогове вікно БДСУММ (рис. 14).

8.Увести необхідні дані, як показано на рис. 14. При цьому у вікно Поле
вводиться ім'я поля, для значень, у яких виконується призначувана дія, у даному



Рис. 14

випадку, підсумовування. У нашому прикладі таким полем є D4 - Вартість.


9. Готово.


На екрані: в комірці F15 перебуває сумарна вартість робіт 280, виконуваних Орловым, тобто F15 = 280.

Аналогічно виконуються роботи з усіма функціями бази даних, які є зручним засобом аналізу інформації, що втримується в БД.

Лабораторна робота №7

РОЗРОБКА СТАТИСТИЧНИХ ЗВІТІВ В СЕРЕДІ EXCEL


Мета: Набуття навичок розробки статистичних звітів.
^

Порядок виконання роботи





  1. Використовуючи набуті навички роботи з Excel, створити звіт у вигляді наступної таблиці





2) Побудувати діаграму, з інформацією про товар, який отримано, продано, залишився на кінець місяця.

3) Використати автоформат для оформлення звіту.

■ '


Контрольні питання:

  1. Що таке масив-інтервал та формула масиву

  2. Як необхідно закінчувати введення формул масива?

  3. Як обчислити суму ряда?

  4. Типи посилань на комірку?

Рекомендована література


  1. Зайден М. Excel 2000 наглядно, понятно, быстро. - М.: ЛБЗ, 1999.

  2. Ковальски М. Excel 2000 без проблем. - М.: Бином, 1999.

  3. Excel 2000: Справочник (наиболее полное руководство). - СПб.: Питер, 1999.

  4. Microsoft Office Excel – електронний ресурс. Режим доступу http://office.microsoft.com/ru-ru/excel/default.aspx







1   2   3

Схожі:

Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки щодо виконання лабораторних робіт з навчальної дисципліни "інформаційні системи І технології у фінансах" для студентів денної та заочної форм навчання
Методичні вказівки щодо виконання лабораторних робіт з навчальної дисципліни “ Інформаційні системи І технології у фінансах” для...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМіністерство освіти І науки україни харківська національна академія міського господарства методичні вказівки до виконання практичних робіт з дисципліни „Стратегічний менеджмент”
Методичні вказівки до виконання практичних робіт з дисципліни „Стратегічний менеджмент” (для студентів спеціальності 050 201 „Менеджмент...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки до виконання лабораторних робіт з дисципліни «Електротехнічні матеріали» для студентів спеціальності 090603
Методичні вказівки містять теоретичні відомості для підготовки до виконання лабораторних робіт, порядок виконання робіт, зміст звіту...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки до виконання лабораторних робіт з дисципліни «Електротехнічні матеріали» для студентів спеціальності 090603
Методичні вказівки містять теоретичні відомості для підготовки до виконання лабораторних робіт, порядок виконання робіт, зміст звіту...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки
Методичні вказівки до проведення лабораторних робіт з дисципліни (Інформаційні комп'ютерні технології ” (для студентів 5 курсу спеціальності...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки для виконання лабораторних робіт з дисципліни «Інформаційні технології при експлуатації інженерних мереж» для студентів 5 курсу денної І 5,
«Інформаційні технології при експлуатації інженерних мереж» (для студентів 5 курсу денної І 5, 6 курсів заочної форм навчання, спеціальності...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки до виконання лабораторних робіт з дисципліни «Інформаційно-управляючі системи в менеджменті та бізнесі» для студентів спеціальності 091400
Лабораторна робота №7. Проектування іус для підтримки менеджменту торгівельно-збутовою діяльністю 20
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconН. В. Гарбуз методичні вказівки до виконання лабораторних робіт з дисципліни
Методичні вказівки до виконання лабораторних робіт з дисципліни «Метали І зварювання в будівництві» (для студентів 3 курсу денної...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки до виконання лабораторних робіт з дисципліни " Системи управління базами даних" для студентів спеціальності 091400
При підготовці до лабораторних робіт студенти вивчають методичні вказівки до їх виконання, рекомендовану літературу, а також виконують...
Методичні вказівки до виконання лабораторних робіт з дисципліни «Вступ в інформаційні технології в менеджменті» Частина 1 для студентів спеціальності 050. 201 iconМетодичні вказівки до виконання лабораторних робіт з дисципліни «Системи управління в комплексних розгалужених системах» для студентів спеціальності 091400
При підготовці до лабораторних робіт студенти вивчають методичні вказівки до їх виконання, рекомендовану літературу, а також виконують...
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи