Практикум по фотограмметрии и дистанционному зондированию icon

Практикум по фотограмметрии и дистанционному зондированию




НазваПрактикум по фотограмметрии и дистанционному зондированию
Сторінка1/9
Дата22.06.2012
Розмір1.53 Mb.
ТипПрактикум
  1   2   3   4   5   6   7   8   9


МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ УКРАИНЫ


Харьковская национальная академия городского хозяйства.





ПРАКТИКУМ


ПО

ФОТОГРАММЕТРИИ И ДИСТАНЦИОННОМУ ЗОНДИРОВАНИЮ


для студентов 4 курса дневной формы обучения

спец. 7.070908

«Геоинформационные системы и технологии»


Харьков – ХНАГХ, 2006

Практикум по фотограмметрии и дистанционному зондированию (для студентов 4 курса дневной формы обучения спец. 7.070908 «Геоинформационные системы и технологии»). Сост. Лисицин В.Э. - Харьков: ХНАГХ, 2006. – 200 с.


Составитель В.Э. Лисицин


Рецензент: профессор, канд. техн. наук В.Д. Шипулин.


Данный практикум подготовлен на базе материалов, предоставленных в электронном виде фирмами Leica Geosystems и ECOMM. Лабораторные работы «Кадровая камера», «Цифровая камера» и «Сенсор с поперечной разверткой SPOT» составлены на основе материалов, приведенных в пособии «Сборник упражнений по работе с ERDAS IMAGINE» компании Data+. Представляемые материалы являются первой частью курса фотограмметрии и дистанционного зондирования, читаемого автором в Харьковской национальной академии городского хозяйства.

Описаны основы цифровой обработки снимков и растровых изображений в пакете Erdas Imagine 8.7, включающей такие вопросы, как - радиометрические и пространственные улучшающие преобразования снимков, распознавание снимков и классификация объектов, работа с цифровыми моделями местности и анализ местности по изображению, орто- и геометрическое трансформирование снимков, создание мозаик изображения и начала работы с трехмерными сценами.


Рекомендовано кафедрой геоинформационных систем и геодезии


протокол N 4 от 02.12.2005 г.


Содержание


НАЧАЛО РАБОТЫ В ПАКЕТЕ ERDAS IMAGINE 8.7….…… ……. 6

Старт. Пользовательские настройки. Особенности пакета.………..… 6

Организация файлов при помощи каталога изображений (Image Catalog.)……………………………………………………….…………...9

Визуализатор (Viewer). Основные приемы работы……..….………....11

Работа с векторными слоями в ERDAS IMAGINE………….……..….25

Изучение структуры DEM посредством пакета ERDAS IMAGINE.....39

Создание поверхностей (Surface Generation) с использованием ASCII-файла……………………………………………………………...42

Контрольные вопросы…………..……………………………………… 46

Трехмерное наложение снимка на рельеф местности (Image Drаре)...46

Контрольные вопросы………………………………..………………….49

Создание мозаики изображений (Mosaic Images)……………………...49

Контрольные вопросы……………………………..…………………….52

КАДРОВАЯ КАМЕРА……………………………………………..…....53

Подготовка файла блока……………………………………….……......53

Ввод опорных и контрольных точек…………………………….….......64

Выполнение автоматического сбора связующих точек………….…....77

Выполнение аэротриангуляции………………………….……….….....79

Ортотрансформирование снимков……………………………..…….…82

Контрольные вопросы…………………………………….……….…… 85

ЦИФРОВАЯ КАМЕРА………………………………………….….……86

Подготовка файла блока………………………………….…….….….. ..86

Выполнение автоматического сбора связующих точек……….…… ...96

Проверка точности связующих точек………..………………………. ..98

Выполнение аэротриангуляции………………..………………………..99

Ортотрансформирование снимков…………………..………………..103

СЕНСОР С ПОПЕРЕЧНОЙ РАЗВЕРТКОЙ SPOT……………..…….106

Подготовка файла блока……………………………..…………………106

Задание модели съемочной камеры…………………………….……...110

Запуск инструмента измерения точек……………………..…………..111

Сбор опорных точек…………………………………..……………..….113

Установка функции автоматического слежения (х, у)……………….116

Определение последних двух опорных точек………………..……….121

Определение источника вертикальных данных…………………..…..124

Задание специального типа и варианта использования опорных точек……………………………………………………………………..125

Добавление второго снимка в блок……………………………………126

Определение модели сенсора…………………………………………..127

Запуск инструмента измерения точек…………………………………127

Сбор наземных опорных точек………………………………………...128

Выполнение автоматического сбора связующих точек……………...131

Проверка точности связующих точек…………………………………132

Выполнение триангуляции…………………………………………….132

Ортотрансформирование снимков…………………………………….134

АВТОМАТИЧЕСКОЕ ИЗВЛЕЧЕНИЕ ЦММ ПРИ ПОМОЩИ ПАКЕТА LEICA PHOTOGRAMMETRY SUITE……….……….…..137

Подготовка съемочного блока…………………………………………138

Установление опций автоматического извлечения DTM……………140

Создание новых регионов……………………………………………....141

Задание точности автоматического извлечения DTM………………..146

Задание дополнительных точек………………………………………..147

Извлечение и просмотр DEM…………………………………………..149

Открытие сгенерированных файлов в обычном Визуализаторе…….150

Генерация отчета……………………………..…………………….…...152

^ КООРДИНАТНАЯ ПРИВЯЗКА И ГЕОМЕТРИЧЕСКОЕ

ТРАНСФОРМИРОВАНИЕ СНИМКОВ……………………………...153

Контрольные вопросы………………………………………………….161

АВТОНОМНАЯ КЛАССИФИКАЦИЯ……………………………….162

Выполнение автономной классификации…………………………….162

Оценка результатов автономной классификации……………………163

Контрольные вопросы…………………………………………………167

УПРАВЛЯЕМАЯ КЛАССИФИКАЦИЯ……………………………...167

Подготовка параметрических обучающих выборок…………………167

Создание непараметрических обучающих выборок…………………171

Оценка качества обучающих выборок…………………….………….177

Выполнение управляемой классификации………………………..….180

Контрольные вопросы………………………………………………....182

СЛИЯНИЕ ПРИ ПОМОЩИ ВЭЙВЛЕТОВ. ОБРАБОТКА ДВУХ СНИМКОВ С РАЗЛИЧНЫМИ СПЕКТРАЛЬНОЙ И ПРОСТРАН-СТВЕННОЙ РАЗРЕШАЮЩИМИ СПОСОБНОСТЯМИ…………...183

ПРЕОБРАЗОВАНИЯ ФУРЬЕ……………………………….………....187

Создание fft-слоя……………………………………………………......187

Применение фильтра низких частот………………………………..…190

Применение к изображению фильтра с другими параметрами………….............................................................................191

Применение обратного преобразования Фурье для полученного

изображения………………………………………………………….....192

Применение к изображению дополнительных фильтров с другими

параметрами………………………………………………..…………...192

Применение маски круглой формы…………………………………...195

Применение прямоугольной маски……………………………..…….197

Применение клиновидной маски……………………..……………….198

СПИСОК ЛИТЕРАТУРЫ………………………………..….………....200

Начало работы в пакете ^ ERDAS IMAGINE 8.7


Старт. Пользовательские настройки. Особенности пакета


Для запуска пакета выберите из меню «Пуск» опцию ERDAS IMAGINE 8.7. Главная инструментальная панель пакета возникнет в верхней части экрана.


При первом знакомстве с главной инструментальной панелью ERDAS IMAGINE, можно отметить, что пользовательский интерфейс сильно отличается от GUI – стандартов Windows приложений. Дело в том, что изначально пакет разрабатывался под семейство ОС UNIX и Windows-вариант, сохранил преемственность многих модулей и интерфейса. Набор кнопок быстрого доступа главной инструментальной панели, дублирует список модулей и задач опции Main главного меню:


  • Start Imagine Viewer;

  • Import/Export;

  • Data Preparation;

  • Map Composer;

  • Image Interpreter;

  • Image Catalog;

  • Image Classification;

  • Spatial Modeler;

  • Vector;

  • Radar;

  • Virtual GIS;

  • OrthoBase;

  • Stereo Analyst;


В зависимости от того, в какой поставке был приобретен данный пакет, список модулей в меню Main может отличаться от приведенного выше.

В
се пользовательские настройки текущего сеанса устанавливаются при помощи опции Session главного меню. Например, при первом запуске ERDAS IMAGINE, кнопки быстрого доступа инструментальной панели отображаются в виде больших иконок, что при некоторых разрешениях экрана снижает наглядность. Кроме того, над кнопками отсутствуют всплывающие подсказки. При помощи настроек устраним эти недостатки.


  1. Из меню Session выбрать подпункт Preferences (Предпочтения). Откроется диалоговое окно позволяющее производить всевозможные настройки пакета.

  2. В списке Category выбрать пункт User Interface & Session, регулирующий настройки пользовательского интерфейса и текущего сеанса.

  3. Для изменения размера иконок на панели справа находим опцию Icon Panel Display Options и, в соответствующем ей списке, выбираем пункт Small Icons.

  4. Для включения всплывающих подсказок , на той же панели находим опцию Use Flat Look For Tools и устанавливаем соответствующую ей кнопку-переключатель.


Имеется две возможности сохранить настройки заданные при помощи данного диалогового окна.


  1. При сохранении изменения коснуться только данного пользователя, определяемого именем и паролем при входе в Windows. Для этого по завершению настройки следует нажать кнопку User Save.

  2. При сохранении изменения коснуться всех пользователей Windows на данном компьютере. Для этого по завершению настройки следует нажать кнопку Global Save.


Так или иначе, после сохранения настроек, диалоговое окно следует закрыть (кнопка Close). Изменения вступят в силу после повторного запуска ERDAS IMAGINE.

Еще одна настройка, которая будет полезна пользователям на начальном этапе работы. Оконный интерфейс выявляет еще одну особенность данного пакета. Вместо SDI и MDI – организации принятой в Windows в ERDAS IMAGINE каждый модуль запускается в виде автономного окна. А широкое использование немодальные диалоговых окон, с одной стороны облегчает процесс обмена данными между модулями, но с другой стороны затрудняет доступ к пространству рабочего стола при запуске нескольких задач одновременно.

Обычно, при запуске задач на выполнение (расчеты, длительная обработка, конвертирование) ERDAS IMAGINE отображает окно состояния процесса – процент выполнения задачи. По завершению задачи следует нажать кнопку OK окна состояния для его закрытия.





Но зачастую, это окно бывает перекрыто другими окнами. Установим, чтобы по завершению процесса окно состояния закрывалось автоматически.


  1. В списке Category диалогового окна Preferences, выбрать пункт User Interface & Session.

  2. На правой панели диалогового окна найти опцию Keep Job Status Box и сбросить соответствующую ей кнопку-переключатель.



^ Организация файлов при помощи каталога изображений (Image Catalog.)


ERDAS IMAGINE поставляется с большим набором демонстрационных изображений. В целях обеспечения целостности данных каждому пользователю рекомендуется создавать отдельную копию рабочих данных в своем рабочем каталоге. Для управления наборами изображений в пользовательских каталогах применяется модуль Image Catalog (каталог изображений), запускаемый из основного меню ERDAS IMAGINE.

Запустить его можно, выбрав из меню Main подпункт Image Catalog. При этом открывается оболочка для работы с текущим каталогом изображений. Параметры текущего каталога изображений (список файлов, их тип, характеристики) записываются в файле настроек с расширением *.ict.





Рассмотрим несколько типичных приемов работы с Image Catalog.


Создадим новый файл настроек каталога изображений. Для этого в Image Catalog из меню File выберем подпункт New. В диалоговом окне зададим имя создаваемого файла настроек каталога изображений и путь к нему, (например, c:\students\stud3.ict). Файл настроек создан.

При первом запуске Image Catalog начинает работу с изображениями, заданными в файле настроек default.ict и размещаемыми в каталоге $HOME \Examples. Изменив установки по умолчанию, организуем доступ к пользовательскому каталогу изображений.


  1. В ERDAS IMAGINE из основного меню Session выбрать подпункт Preferences (Предпочтения). Откроется диалоговое окно позволяющее производить всевозможные настройки пакета.

  2. В списке Category диалогового окна Preferences, выбрать пункт Image Catalog.

  3. На правой панели диалогового окна найти опции Catalog Directory (директория пользовательского каталога изображений) и Default Catalog (имя файла настроек каталога изображений, выбираемое по умолчанию). Задать соответствующие строковые параметры, указывающие на файл stud3.ict, созданный Вами ранее.

  4. Нажать кнопку User Save. Теперь, после перезапуска Image Catalog будет осуществлять выборку изображений из файла настроек в установленной Вами директории.


Чтобы добавить изображение в файл настроек Image Catalog, в меню Edit выберите пункт Catalog Image. Чтобы удалить изображение из файла настроек Image Catalog, мышкой выделите в поле Record таблицы изображений те записи, которые следует удалить, а затем в меню Edit выберите пункт Delete Image. Для выделения нескольких записей одновременно, используйте клавишу Shift. Чтобы получить развернутую информацию по изображению, выделите соответствующую запись и в меню View и выберите пункт Image Info.

Удобным приемом при выборе изображений в Image Catalog является применение инструментария графических запросов. Он позволяет для файлов изображений, содержащих географическую привязку, осуществлять их выбор с учетом границ растров в рамках векторной карты.



  1. В меню View модуля Image Catalog выберите пункт Graphical Query Viewer. Векторная карта мира появиться в диалоговом окне.








  1. При помощи инструментальной кнопки (Select an area for zooming) мышкой выберите интересующую Вас область.




3. При помощи инструментальной кнопки (Query all images within current boundaries) запустите графический запрос.


4. Файлы, географически относящиеся к выделенной области, будут выделены в таблицы изображений Image Catalog.




  1. При помощи инструментальной кнопки (Display selected image in Single Imagine Viewer) запустите просмотр выделенных изображений в Визуализаторе.


^ Визуализатор (Viewer). Основные приемы работы


Мы уже научились запускать Визуализатор из Image Catalog. Однако, чаще нам придется выполнять его запуск из основного меню ERDAS IMAGINE. Для этого существует две возможности:


- в ERDAS IMAGINE из основного меню Main выбрать подпункт Start IMAGINE Viewer;


- воспользоваться кнопкой быстрого доступа (Viewer) из главной инструментальной панели ERDAS IMAGINE;


На экране появится основное окно Визуализатора. Это главный рабочий инструмент при работе с растровыми и векторными слоями ERDAS IMAGINE.




Рассмотрим выполнение основных операций в Визуализаторе.


^ Загрузка изображений в Визуализатор.


  1. В основном меню Визуализатора выбираем File | Open | Raster Layer. Откроется диалоговое окно выбора файла.





  1. Выбираем файл lanier.img.

  2. Переходим на вкладку Raster Options в диалоговом окне открытия файла.

  3. На панели Layers to Colors установим следующую модель отображения диапазонов в каналы цветности :Red – 4, Green -5, Blue-3. Установим переключатель Fit to Frame.

  4. Нажимаем OK.

  5. В окне визуализатора откроется файл lanier.img. При перемещении курсора над клиентской областью окна Визуализатора, внизу, на информационной панели отображается информация о системе координат и используемой проекции.

  6. Используйте линейки прокрутки клиентского окна визуализатора, либо кнопку (Roam/Rotate Image) главной инструментальной панели для прокрутки изображения.

  7. Используйте кнопки (Zoom In / Zoom Out) главной инструментальной панели для увеличения и уменьшения масштаба отображения растра. Используйте опции меню Визуализатора View | Zoom для задания фиксированного масштаба увеличения и уменьшения растра.

^ Функции запросов Визуализатора.


Вы можете получать подробную информацию по каждому пикселю отображаемого растра. Для этого используйте функции запросов.


  1. Изображение lanier.img должно быть уже открыто в Визуализаторе. Из меню Визуализатора выберите Utility | Inquire Cursor. Откроется диалоговое окно курсора запроса.





  1. Над изображением в Визуализаторе появится перекрестие позиционирования курсора. Вы можете захватить перекрестие и переместить мышью в новое положение. Информация о точке, находящейся в данный момент под перекрестием, отобразится в диалоговом окне запроса с использованием курсора. Можно выполнить обратное действие, - в диалоговом окне задать требуемые координаты в полях ввода X и Y. Тогда перекрестие переместиться в заданную точку изображения. Перемещение выполнится автоматически, если установлен переключатель Auto Apply. В противном случае, перемещение перекрестия будет выполнено только после нажатия кнопки Apply (Применить).


В диалоговом окне запроса с использованием курсора представлена следующая информация по текущему пикселю:


- число (каналов) диапазонов изображения;

- модели отображения диапазонов в каналы цветности;

- значения интенсивности цвета пикселей по каждому диапазону, хранимые в файле;

- значения из таблицы перекодировки цвета для каждого диапазона;


  1. Нажмите кнопку Close. Диалоговое окно курсора запроса закроется.

  2. Из меню Визуализатора выберите Utility | Inquire Box. Откроется диалоговое окно запроса с использованием прямоугольной области. Над изображением в Визуализаторе появится прямоугольник. Вы можете захватить его мышью, переместить в новое положение или изменить размеры. Информация о левой верхней точке прямоугольника, а так же его размерах, отобразится в диалоговом окне запроса с использованием прямоугольной области. Выбирая опции из списка Type, можно задавать размерность в единицах измерения карты или в пикселях. Режим запроса с использованием прямоугольной области будет нами активно использоваться в дальнейшем.





  1. Нажмите кнопку Close. Диалоговое окно запроса с использованием прямоугольной области закроется.



^ Выполнение измерений.


Панель измерительных инструментов Визуализатора позволяет оценить расстояние между точками, линейные размеры и площади, отрезки линий и полигонов, параметры прямоугольников и эллипсов.


  1. Из меню Визуализатора выберите Utility | Measure. Откроется окно измерительных инструментов.





  1. Нажмите кнопку (Measure positions) инструментальной панели диалогового окна. В этом режиме, после щелчка мышью в клиентской области окна Визуализатора, в поле Measurement Description отображаются координаты текущей точки.

  2. Нажмите кнопку (Measure Lengts and Angles) инструментальной панели диалогового окна. В этом режиме, после определения в Визуализаторе полилинии, в поле Measurement Description отображается длина заданной полилинии.

  3. Нажмите кнопку Close для закрытия диалогового окна измерительных инструментов.


^ Открытие и просмотр нескольких изображений в едином Визуализаторе.


  1. Изображение lanier.img остается открытым в Визуализаторе. В основном меню Визуализатора выбираем File | Open | Raster Layer. В открывшемся диалоговом окне выбираем файл lnsoils.img.

  2. Переходим на вкладку Raster Options. Сбрасываем переключатель Clear Display. Нажимаем ОК. Теперь в Визуализаторе одновременно отрыты два файла lanier.img и lnsoils.img. Эти файлы отображаются виде двух непрозрачных растровых слоев. Поэтому, верхний слой слой (lnsoils.img) полностью закрывает нижний (lanier.img).

  3. Изменим порядок отображения слоев. В основном меню Визуализатора выбираем View | Arrange Layers. Откроется диалоговое окно задания порядка отображения слоев.





  1. В диалоговом окне мышкой переместите слой lnsoils.img в конец списка и нажмите клавишу Apply. Теперь слой lanier.img перемещается наверх и полностью перекрывает слой lnsoils.img.

  2. Закройте диалоговое окно задания порядка отображения слоев, нажав кнопку Close.

  3. В основном меню Визуализатора выбираем Utility | Swipe. Откроется диалоговое окно перекрывающихся отображений двух слоев находящихся на вершине списка (утилита Шторка).





  1. Выбор радиопереключателей Vertical или Horizontal группирующей панели Direction позволяет задать вертикальное или горизонтальное направление перекрытия при просмотре пары изображений. Ползунковый переключатель групповой панели Swipe Position регулирует величину области перекрытия пары изображений. Переключатель Auto Mode запускает сканирование области перекрытия в автоматическом режиме.





  1. Нажав кнопку Cancel, закройте диалоговое окно перекрывающихся областей.

  2. В основном меню Визуализатора выбираем Utility | Flicker. Откроется диалоговое окно поочередного отображения двух слоев находящихся на вершине списка.





  1. Установкой переключателя Auto Mode групповой панели Automatic Flicker, задайте автоматический режим переключения между отображаемыми слоями. После этого, два слоя, находящихся на вершине списка, будут поочередно отображаться в Визуализаторе.

  2. Закройте диалоговое окно поочередного отображения слоев.

  3. Закройте все слои, представленные в Визуализаторе, используя опцию основного меню File | Clear. Чтобы закрыть, только слой, находящийся на вершине списка, используйте кнопку (Close Top Layer).


^ Создание связи при просмотре в двух Визуализаторах.


Можно создать географическую или спектральную связь, при просмотре изображений в двух Визуализаторах. В случае географической связи, при выполнении скроллинга изображения в одном Визуализаторе, изображение во втором Визуализаторе будет перемещаться синхронно с первым изображением. Поэтому, в обоих Визуализаторах будет отображаться одна и та же область. В случае спектральной связи, трансформирование, применяемое к изображению в первом Визуализаторе, будет выполнено и во втором Визуализаторе, в том случае, если в последнем открыто то же самое изображение.


  1. В Визуализаторе откройте файл lanier.img. В основном меню выберите пункт View | Zoom | In By 2. Изображение будет отображаться с двойным увеличением

  2. В ERDAS IMAGINE из основного меню выберите пункт Main | Start IMAGINE Viewer и запустите второй Визуализатор.

  3. В основном меню первого Визуализатора выберите пункт View | Tile Viewers. Оба Визуализатора позиционируются на экране монитора так, чтобы не перекрывать друг – друга.

  4. Во втором Визуализаторе откройте файл lnsoils.img. В основном меню второго Визуализатора выберите пункт View | Scale | Image To Window. Изображение будет отображаться так, чтобы полностью вписаться в габариты клиентской области окна второго Визуализатора.

  5. В меню первого Визуализатора выберите пункт View | Link/Unlink Viewers | Geographical. Появиться окно установления географической связи.

  6. Переместите курсор мыши на изображение во втором Визуализаторе и щелкните внутри клиентской области окна. Географическая связь изображений в двух визуализаторах будет установлена. Поверх изображения во втором Визуализаторе появится прямоугольник, задающий размеры связанных областей изображений.

  7. Мышью переместите внутри второго Визуализатора ограничивающий прямоугольник. Обратите внимание, как при этом синхронно меняется область отображения в окне первого Визуализатора. Мышью измените габариты ограничивающего прямоугольника внутри второго Визуализатора. Отметьте, как изменилась область просмотра в первом Визуализаторе.

  8. Скроллируйте изображение в первом Визуализаторе. Ограничивающий прямоугольник внутри второго Визуализатора синхронно переместится в новое положение.

  9. В меню первого Визуализатора снова выберите пункт View | Link/Unlink Viewers | Geographical. Переместите курсор мыши на изображение во втором Визуализаторе и щелкните внутри клиентской области окна. Географическая связь будет удалена.

  10. Закройте второй Визуализатор.



^ Область интересов.


Часто приходиться производить операции не над всем изображением в целом, а над отдельной его частью. В этом случае, на изображении следует выделить область интересов (Area Of Interest) – геометрическую область, очерчивающую интересующий нас регион.


  1. В Визуализаторе откройте файл lanier.img. В основном меню выберите пункт AOI | Tools. Откроется панель инструментов построения областей интересов (AOI).





  1. Построения областей выполняется при помощи мыши. В пределах изображения можно задавать несколько AOI. Для задания AOI в виде прямоугольника, эллипса или полигона используйте, соответственно, инструментальные кнопки панели. Замыкание полигональной области выполняется двойным щелчком мыши. Созданные области, отображаются в Визуализаторе штриховыми линиями. Для выбора на изображении одной из нескольких AOI, используйте инструментальную кнопку (Reset Window Tools). Выделив на изображении область интересов, Вы можете мышью перемещать ее в другое место на изображении, либо изменять размеры AOI. Для удаления неправильно построенной области, выделите ее мышкой и выберите в меню Визуализатора AOI | Cut.




  1. В качестве упражнения создайте несколько областей интересов изображения lanier.img, используя различные типы AOI.





  1. В меню Визуализатора выберите пункт AOI | Seed Properties. Появится диалоговое окно свойств разрастания регионов, позволяющее автоматически строить и перестраивать области интересов в соответствии с заданными критериями.




  1. Установите переключатель Area. В соответствующем ему поле ввода задайте значение 400. Из списка выберите в качестве единиц измерения опцию # pixels. Сбросьте переключатель Distance. В поле Spectral Euclidean Distance задайте значение 20.00.

  2. Нажмите кнопку Options и в диалоговом окне установите переключатель Include Island Polygons. Данная опция задает правило включения внутренних областей в интегральную область разрастания. При сброшенном переключателе, области, не проходящие по спектральному критерию, не будут включены в интегральную область разрастания. А при установленном переключателе, такое включение будет осуществлено. Ниже показаны одна исходная и две результирующие AOI для этих двух случаев.





  1. В панели инструментов построения AOI, нажмите кнопку .(Region Grow AOI) Курсор примет форму перекрестия. В Визуализаторе выберите одну из областей темно-синего цвета и щелкните внутри нее мышью. Область интересов вокруг заданной зоны будет построена автоматически, в соответствии с параметрами, установленными в диалоговом окне Seed Properties.





  1. В окне Seed Properties установите значение 26.00 в поле Spectral Euclidean Distance, а в поле ввода для Area, задайте значение 800. Нажмите кнопку Redo. Размеры области интересов изменятся.

  2. Закройте инструментальную панель построения AOI, нажав кнопку Close.

  3. В меню Визуализатора выберите View | Arrange Layers. В окне задания порядка отображения слоев видно, что появился слой AOI, содержащий созданные области интересов.





  1. В Визуализаторе выберите пункт меню File | Save | AOI Layer As. Введите имя файла, под которым будет сохранен AOI-слой. Нажмите OK.

  2. В окне задания порядка отображения слоев выделите AOI-слой, затем из контекстного меню выберите пункт Delete Layer. Слой, содержащий области интересов будет удален из визуализатора. Поскольку он был предварительно сохранен, мы всегда можем восстановить его. Для этого, из меню Визуализатора следует выбрать пункт File | Open | AOI Layer и указать тот файл, в котором были сохранены AOI.



^ Редактирование атрибутивной информации тематических слоев.


  1. Откройте в Визуализаторе файл lanier.img, представляющий собой непрерывный слой.

  2. Используя вкладку Raster Options, не закрывая lanier.img, поверх него, в том же Визуализаторе откройте файл lnsoils.img, представляющий тематические слои растра. Непрозрачное изображение lnsoils.img полностью перекроет lanier.img.

  3. В меню Визуализатора выберите пункт Raster | Attributes. Откроется редактор атрибутов растра lnsoils.img.





  1. Охарактеризуем некоторые, наиболее важные атрибуты редактируемой таблицы. В столбце Class Names представлено название класса, в столбце Color – цвет, которым представлен данный класс на изображении, в столбце Opacity – признак прозрачности области заполнения данного класса.

  2. Редактирование полей для всех столбцов, кроме Color осуществляется простым вводом в соответствующей ячейке нового значения. Поля столбца Color редактируются путем установки курсора мыши в соответствующей ячейке, щелчка правой клавиши мыши и выбора соответствующего цвета из контекстного меню.

  3. Можно менять порядок следования полей, а также создавать новые атрибутивные поля редактируемой таблицы. Для этого в главном меню окна редактора выбираем Edit | Column Properties. Откроется окно свойств табличных столбцов.





  1. Выделяя в списке Columns интересующий нас атрибут, при помощи кнопок Up, Down, Top, Bottom , меняем порядок следования данного атрибута при отображении в таблице. Устанавливая переключатель Editable, включаем возможность редактирования свойств данного атрибута. Посредством кнопки Delete, удаляем данный атрибут из списка свойств класса. А кнопка New позволяет создать новый атрибут. Формат нового атрибута задается при помощи кнопки Format.

  2. Закроем окно Column Properties.

  3. Класс, представленный в таблице редактирования под номером 24 имеет имя «MADISON SNDY CLAY LOAM,6-10%,E». В Визуализаторе области, относящиеся к этому классу, отображаются оранжевым цветом. Исправим для этого класса значение прозрачности (opacity) с 1 на 0. После этого области представляемые этим классом станут прозрачными и под ними «проступит» изображение слоя lanier.img.


^ Редактирование цвета пикселей тематического растрового слоя.


  1. На вершине списка слоев должен находиться тематический слой lnsoils.img. В меню Визуализатора выберем пункт Raster | Inquire Cursor. В диалоговом окне запроса с использованием курсора, введите координаты позиционирования курсора X=237808.691674, Y=3799436.646722. Курсор позиционируется в указанную точку тематического слоя

  2. В таблице атрибутов диалогового окна запроса с использованием курсора, для текущего пикселя поле Class Names содержит название “WATERS”, а из цветовых составляющих только BLUE-компонента имеет ненулевое значение (135.000) . Данный пиксель соответствует классу объектов типа “Водные ресурсы”, а значение для данного класса содержится в поле Pixel Value=34. Пиксель окрашен в синий цвет. Изменим окраску текущего пикселя.

  3. В основном меню выберите пункт AOI | Tools. В панели инструментов AOI выберите инструментальную кнопку построения точечной области интересов .(Create Point AOI) Мышкой установите точечную AOI на изображении по координатам, соответствующим редактируемому пикселу.

  4. В меню Визуализатора выберем пункт Raster | Fill. Откроется диалоговое окно редактирования цвета пикселей растрового слоя.





  1. Установим в поле Fill Width диалогового окна значение 25.000, соответствующее классу MADISON SNDY CLAY и меняющее цвет пикселя на серый. Нажмем кнопку Apply. Цвет текущего пикселя изменится.

  2. Чтобы отменить закраску пикселя, в меню Визуализатора выберем пункт Raster | Undo.

  3. Зададим полигональную область интересов внутри класса объектов “WATERS”, используя кнопку (Place a Simple Closed Polygon). Снова нажмем кнопку Apply диалогового окна редактирования цвета пикселей. Цвет пикселей в рамках AOI изменится на серый.

  4. Отменим закраску пикселей растра, выбрав пункт Raster | Undo. Закроем диалоговое окно.


  1   2   3   4   5   6   7   8   9

Схожі:

Практикум по фотограмметрии и дистанционному зондированию iconМетодические указания
Методические указания к выполнению курсовой работы по фотограмметрии и дистанционному зондированию (для студентов 4 курса дневной...
Практикум по фотограмметрии и дистанционному зондированию iconРеспублика Беларусь Гродненский государственный университет им. Янки Купалы Презентация курсов по интерактивному дистанционному обучению в сфере туризма
Целевые группы модуля по интерактивному дистанционному обучению «Культурный туризм»
Практикум по фотограмметрии и дистанционному зондированию iconДокументи
1. /Крим_нальний процес Украхни - практикум/Загальна частина/1-понят, суть завд.doc
Практикум по фотограмметрии и дистанционному зондированию iconДокументи
1. /Крим_нальний процес Украхни - практикум/Загальна частина/1-понят, суть завд.doc
Практикум по фотограмметрии и дистанционному зондированию iconДокументи
1. /ЭЭ Практикум РИО Одна книга/000_ Вступ.doc
2. /ЭЭ...

Практикум по фотограмметрии и дистанционному зондированию iconДокументи
1. /ЭЭ Практикум РИО Одна книга/000_ Вступ.doc
2. /ЭЭ...

Практикум по фотограмметрии и дистанционному зондированию iconПрактикум з дисципліни "Валеологія" для навчання за кредитно-модульною системою
Ключове слово для тематичного покажчика. Комп’ютеризований практикум з валеології
Практикум по фотограмметрии и дистанционному зондированию iconПрактикум з філософії
Практикум з філософії: Методичний посібник для викладачів та студентів внз (під редакцією В. Л. Петрушенка). – К.: “Каравела”; Львів:...
Практикум по фотограмметрии и дистанционному зондированию iconДокументи
1. /Практикум з конструювання швейних вироб_в/Практикум з конструювання та моделювання одягу...
Практикум по фотограмметрии и дистанционному зондированию iconПрактикум. Назва розробки
Назва розробки. Практикум валеологічного досліду нейрофізіологічних показників студентів сну ім. В. Даля в умовах навчання
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи