Конспект лекций по дисциплинам «Информатика и компьютерная техника» icon

Конспект лекций по дисциплинам «Информатика и компьютерная техника»




НазваКонспект лекций по дисциплинам «Информатика и компьютерная техника»
Сторінка1/5
Дата08.06.2012
Розмір0.64 Mb.
ТипКонспект
  1   2   3   4   5


МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ УКРАИНЫ

ХАРЬКОВСКАЯ НАЦИОНАЛЬНАЯ АКАДЕМИЯ ГОРОДСКОГО ХОЗЯЙСТВА


Конспект лекций по дисциплинам


«Информатика и компьютерная техника»,


«Вычислительная техника и программирование»


Раздел «Электронная таблица Microsoft Excel»


( для студентов 1 курса дневной формы обучения специальностей

6.050200 «Менеджмент организаций», 6.092200 - «Электротранспорт»,

6.092200 - «Охрана труда на электротранспорте» )


Харьков - ХНАГХ - 2007


Конспект лекций по дисциплинам «Информатика и компьютерная техника», «Вычислительная техника и программирование». Раздел «Электронная таблица Microsoft Excel» ( для студентов 1 курса дневной формы обучения специальностей 6.050200 - «Менеджмент организаций», 6.092200 - «Электротранспорт», 6.092200 - «Охрана труда на электротранспорте» ) / Сост.: Замалеев Ю.С., Гавриленко И.А. - Харьков: ХНАГХ, 2007. - 92 с.


Составители: Ю.С. Замалеев,

И.А. Гавриленко


Рецензент: проф. Н.Я. Какурин ( Харьковский национальный университет радиоэлектроники )


Рекомендовано кафедрой ПМ и ИТ, протокол № 1 от 29.08.07 г.




ЛЕКЦИЯ 1


Электронная таблица Microsoft Excel. Диалоговое окно приложения. Основные понятия. Создание, сохранение, открытие файлов


1. Об электронных таблицах


Для представления данных в упорядоченном, удобном для работы виде, используют таблицы. В работе с таблицами, содержащими данные, применяют программные средства (приложения) называемые электронными таблицами или табличными процессорами.

Электронные таблицы (ЭТ) являются приложениями, которые представляют таблицы в электронной форме и обеспечивают их автоматическую обработку и отображение данных. Здесь нет необходимости в программировании вычислительных процессов. ЭТ используют в экономических, бухгалтерских, технических расчётах и научных исследованиях.

В недавнем прошлом наиболее популярными ЭТ являлось семейство табличных процессоров ^ SuperCalc (SC). Самыми эффективными версиями этого семейства, были SC4 и SC5.

ЭТ Microsoft Excel является приложением, предназначенным для работы с табличными, преимущественно числовыми, данными. При формировании таблицы выполняют ввод, редактирование, форматирование текстовых и числовых данных и формул. В настоящее время Microsoft Excel представляет собой самое мощное и производительное приложение обработки ЭТ. Наряду с простыми задачами (например, подготовка различных бланков, создание деловой графики), Excel позволяет решать очень сложные задачи и проблемы. Например, на предприятиях посредством данного приложения значительно облегчается обработка заказов и планирование производства, расчет налогов и заработной платы, учет кадров и затрат, управление сбытом и т.д. Область применения Excel не ограничивается сферой деловой жизни. Мощные математические и инженерные функции Excel позволяют решать множество задач в области естественных и технических наук.


^ 2. Запуск приложения Microsoft Excel


Приложение Microsoft Excel может запускаться одним из следующих способов:

  • Двойным щелчком на значке или ярлыке Microsoft Excel.

  • Щелчком на значке или ярлыке Microsoft Excel, размещенных на панели быстрого запуска.

  • Из меню кнопки Пуск (Пуск > Программы > Microsoft Offic > Microsoft Excel).

После загрузки программы открывается Основное диалоговое окно приложения Excel.


^ 3. Основное диалоговое окно приложения Excel


Основные элементы окна диалога Excel, перечисленные сверху вниз, следующие:

  • Строка заголовка. Отображает название документа и содержит кнопки вызова системного меню (слева) и кнопки управления окном (справа).

  • ^ Строка меню. Содержит такие пункты меню, как Файл, Правка, Вид, Вставка, Формат, Сервис, Данные, Окно, Справка. Со строкой меню можно обращаться, как и с панелями инструментов: перемещать, располагать в любом месте экрана, вставлять и удалять ее элементы.

  • ^ Панель инструментов Стандартная. Содержит кнопки, управляющие файловыми операциями, экранным отображением, поиском данных, сортировкой данных, вычислением автосуммы и функций рабочего листа, работой с диаграммами, рисованием.

  • ^ Панель инструментов Форматирование. Содержит кнопки, управляющие форматированием документа.

  • Строка ( панель ) формул. . Находится под панелями инструментов и предназначена для обработки содержимого ячеек. Строка формул разделена на три части.

^ Правая часть. Отображает содержимое текущей ячейки, которое можно редактировать кнопками, расположенными в центре строки формул.

Средняя часть. Содержит кнопки для обработки содержимого ячейки.

Кнопка Ч Отмена используется для отмены последнего действия и соответствует клавише Esc.

Кнопка ? Ввод служит для подтверждения ввода данных и соответствует клавише Enter.

Кнопка ѓ активизирует панель формул, с помощью которой вводятся и редактируются формулы.

^ Левая часть. Содержит поле имён, где указывается адрес активной ячейки или размер выделенного диапазона. Например, запись 2Rx3C, говорит о том, что выделенный диапазон состоит из 2 строк и 3 столбцов.

Если для некоторых диапазонов заданы имена, то они отображаются в поле списка под полем имени и могут использоваться для быстрого перехода к нужному диапазону.

  • Окно рабочей книги. Содержит рабочую книгу, состоящую по умолчанию из трех листов. Книга открывается при загрузке приложения и имеет временное имя Книга1.

  • Полосы прокрутки. Поскольку рабочий лист содержит более 16 миллионов ячеек и все они не могут одновременно отображаться на экране, то горизонтальная или (и) вертикальная полосы прокрутки позволяют сделать видимыми те области рабочего листа, которые в данный момент не видны на экране. Для смещения на одну строку вверх или вниз следует щелкнуть на соответствующей кнопке со стрелкой на вертикальной полосе прокрутки. Для смещения на один экран вверх или вниз, надо щелкнуть непосредственно на полосе прокрутки. Бегунки полос прокрутки обозначают позицию активной ячейки или диапазона в таблице и используются для быстрого перемещения по таблице.

  • ^ Строка состояния. В этой строке слева отображаются различные сообщения, например о выбранной команде. Эта строка информирует также о том, можно ли вводить данные или выбирать команду. В этом случае в ней отображается слово Готово. При открытии созданной ранее книги здесь графически демонстрируется степень завершенности процесса. В правой части строки состояния расположены индикаторы режимов работы. Например, индикатор ВДЛ сигнализирует о том, что включен режим выделения (нажатием клавиши F8), индикатор CAPS сигнализирует о включенном верхнем регистре клавиатуры.




^ 4. Основные понятия


Документ Excel называют рабочей книгой. Книга в Excel представляет собой файл, который имеет расширение .xls. Книга открывается при запуске приложения Excel и имеет временное имя Книга1 . При создании новой книги, ей присваивается имя Книга2. Переход с книги в книгу выполняется командами меню Окно. Здесь в ниспадающем меню нужно щелкнуть на имени нужной книги. Книга содержит набор рабочих листов. Окно Excel содержит рабочую книгу, состоящую по умолчанию из трёх листов. Можно вставить дополнительные рабочие листы (до 255). Новый рабочий лист создаётся командой:

^ Вставка > Лист.


Переход с листа на лист выполняется кнопками прокрутки ярлычков листа.

Рабочий лист имеет табличную структуру и может содержать одну или несколько таблиц. В окне документа отображается только текущий рабочий лист. Рабочий лист состоит из строк и столбцов. Столбцы озаглавлены прописными латинскими буквами и, далее, двухбуквенными комбинациями. Рабочий лист содержит 256 столбцов. Строки нумеруются арабскими цифрами. Рабочий лист содержит 65536 строк.

Каждый рабочий лист имеет название, которое отображается на ярлыке листа. Ярлычок находится в нижней части листа. Например, Лист1, Лист2. Используя ярлыки (щелкая на них), можно переходить на другие рабочие листы, которые входят в текущую рабочую книгу. Рабочий лист можно переименовать. Для этого нужно:

  • Дважды щёлкнуть левой кнопкой мышки на ярлычке.

  • Нажать клавишу Delete.

  • Напечатать нужное имя.

  • Щелкнуть левой кнопкой мыши на рабочем листе для выхода из режима переименования.

Также можно задать цвет для ярлычка:

  • Навести указатель мыши на ярлычок.

  • Нажать правую кнопку мыши.

Откроется контекстное меню.

  • Выбрать элемент Цвет ярлычка.

  • В палитре выбрать желаемый цвет.

  • Нажать кнопку OK.

Ячейки – это минимальные элементы для хранения данных. Ячейки расположены на пересечении столбцов и строк. Примеры обозначения ячеек: А1, F20, H70, DE234.

Одна ячейка всегда активна и выделяется рамкой, выполняющей роль курсора (рамка активной ячейки). Операции ввода и редактирования данных, всегда выполняются в активной ячейке. Рамка перемещается указателем мыши и клавишами управления курсором.

^ Диапазон ячеек представляет собой группу ячеек. Обычно используют прямоугольные диапазоны, которые образуются на пересечении группы последовательных столбцов. Диапазон обозначают, указывая через двоеточие, номера ячеек, расположенных в противоположных углах прямоугольника, например, A1:C15.


^ 5. Создание, сохранение, открытие файлов


Для создания новой рабочей книги (файла) надо предварительно выполнить навигацию в нужную папку, где будет храниться созданный файл. Далее реализовать команду:

^ Файл > Создать.

Также можно на стандартной панели инструментов нажать кнопку Создать.



Чтобы сохранить рабочую книгу после внесенных изменений нужно выполнить команду:

^ Файл > Сохранить.

Для сохранения уже существующей рабочей книги под другим именем необходимо выбрать команду:

Файл > Сохранить как … .

Откроется окно диалога Сохранение документа, в котором выполнить навигацию в нужную папку, затем в текстовом поле ^ Имя файла: напечатать новое имя рабочей книги и нажать кнопку OK.



Открыть рабочую книгу можно посредством команды:

^ Файл > Открыть,




либо, нажав на стандартной панели инструментов кнопку Открыть.

Откроется диалоговое окно Открытие документа, где требуется (если необходимо выполнить навигацию) и выбрать нужный файл, затем нажать кнопку Открыть.


ЛЕКЦИЯ 2

^ ТИПЫ И ВВОД ДАННЫХ. РЕДАКТИРОВАНИЕ И ФОРМАТИРОВАНИЕ ДАННЫХ. ВЫЧИСЛЕНИЯ ПО ФОРМУЛАМ


1. Выделение объектов


Для выполнения каких-либо операций с данными на рабочем листе, эти данные необходимо выделить. Выделенные данные называют объектом.

Для выделения ячейки надо указатель мыши навести на нужную ячейку и щёлкнуть левой кнопкой мыши.

Для выделения диапазона ячеек нужно указатель мыши навести на левый верхний угол диапазона, и при нажатий левой кнопке мыши, переместить указатель мыши в правый нижний угол диапазона и отпустить кнопку.

Чтобы выделить строку или столбец надо щёлкнуть по номеру строки или имени столбца.

Чтобы выделить весь рабочий лист, необходимо щёлкнуть по пустой кнопке в левом верхнем углу рабочего листа.

Для выделения несмежных диапазонов нужно выделить первый диапазон, и при нажатой клавише Ctrl, выделить остальные диапазоны.

Для отмены выделения надо щёлкнуть левой кнопкой по любой ячейке вне объекта.


^ 2. Типы данных


В отличии от предыдущих табличных процессоров, например семейства SC, Excel определяет автоматически тип вводимых данных. Данные, подготовленные для ввода в ячейку, могут быть трёх типов:

  • текстовые;

  • числовые;

  • формульные.


3. Ввод данных


Ввод текста и чисел производится в текущую ячейку или в строку формул. Место ввода отмечается текстовым курсором. При вводе алфавитного - цифровыми клавишами, данные текущей ячейки заменяются вводимым текстом. Если щёлкнуть на строке формул или дважды – на текущей ячейке, то прежнее значение не удалится, но его можно редактировать.

Вводимые данные отображаются одновременно в ячейке и в строке формул.

Ввод формул всегда начинается со знака равенства.

Ввод данных заканчивается нажатие кнопки ^ Ввод или нажатием клавиши Enter.

При отказе от сохранения данных и восстановления прежнего значения, надо нажать кнопку Отмена или клавишу Esc.

Для очистки текущей ячейки или выделенного диапазона, нужно нажать клавишу Delete.


^ 7. Редактирование данных


Редактирование выполняют в строке формул или в ячейке. Для перехода в режим редактирования надо нажать клавишу F2 или щёлкнуть в правой части строки формул. Для установки режима редактирования в ячейке, надо дважды щёлкнуть на нужной ячейке. Последняя станет активной и в ней появится курсор ввода. Далее можно редактировать содержимое ячейки.


^ 8. Форматирование данных


По умолчанию текстовые данные выравниваются по левому краю ячейки, а числа – по правому. Для изменения формата отображаемых данных в текущей ячейке или в выделенном диапазоне, используют команды:


^ Формат > Ячейки.



Далее, реализуя множество пунктов меню, можно сформировать нужный формат данных. Кроме команды ^ Формат форматирование документов в Excеl также производится с помощью панели инструментов форматирования, содержащей множество кнопок (инструментов). Эти инструменты позволяют, например, выполнять следующие операции:

  • выбирать тип и размер шрифта;

  • изменять начертание текста (полужирное, курсив, подчёркнутое);

  • выравнивать данные по левому краю, центру, правому краю ячеек;

  • центрировать текст в столбцах;

  • устанавливать денежный и процентный формат чисел;

  • увеличивать и уменьшать разрядность чисел;

  • выбирать тип рамки для обозначения ячейки или диапазона;

  • выбирать цвет фона и шрифта.


Форматирование также можно выполнять с помощью мыши. Например, изменим ширину столбца или высоту строки, используя мышь. Для этого нужно:

  1. Навести указатель мыши на линию между столбцами или строками так, чтобы он преобразовался в двунаправленную стрелку.

  2. Нажать и держать левую кнопку мыши, перемещая указатель в направлении, указанном стрелкой.

Также для изменения ширины столбца или высоты строки используют команды

^ Формат > Столбец > Ширина,

Формат > Строка > Высота.


Вставка и удаление столбцов и строк. Когда в таблицу надо вставить данные, без замены находящихся в ней значений, то путём вставки ячеек можно создать область для новых данных.

При вставке столбца, следующие за ним столбцы сдвигаются на одну позицию вправо. При вставке строки, следующие за ней строки сдвигаются на одну позицию вниз. Чтобы вставить в таблицу столбцы, следует:

  1. С помощью заголовков столбцов выделить столько столбцов, сколько нужно их вставить.

  2. Открыть контекстное меню.

  3. Выполнить команду Добавить ячейки.

Удалить вставленные столбцы позволяет команда Удалить из контекстного меню.

Вставка и удаление строк выполняются аналогично, этими же командами.

При удалении целых столбцов, следующие за ними столбцы, сдвигаются влево. При удалении целых строк, следующие за ними строки, сдвигаются вверх.


^ 9. Вычисления по формулам


Для вычисления по формулам необходимо:

  1. Выделить ячейку, в которой нужно получить результат вычисления, и напечатать в ней знак = .

  2. Напечатать формулу. При этом, величины, входящие в формулу, могут иметь вид либо числовых значений, либо ссылок на ячейки, в которых содержатся эти значения. Например: = 6/С4+10*D6; = (A4+B4)/E8. Чтобы сделать ссылку на ячейку, следует навести указатель мыши на эту ячейку и щёлкнуть левой кнопкой.

  3. Для получения результата вычисления нужно, нажать клавишу Enter, либо отменить выделение ячейки, в которой находится формула.


ЛЕКЦИЯ 3

^ ССЫЛКИ НА ЯЧЕЙКИ. МЕТОД АВТОЗАПОЛНЕНИЯ. АВТОСУММИРОВАНИЕ. ПЕРЕМЕЩЕНИЕ И КОПИРОВАНИЕ ДАННЫХ. УДАЛЕНИЕ ДАННЫХ


    1. Ссылка на ячейки


Формула может содержать ссылки на ячейки, которые представляют собой адреса ячеек, содержимое которых используется в вычислениях, при этом, результат вычисления формулы зависит от числа, находящегося в другой ячейке. Ячейка, содержащая формулу, называется зависимой. Когда меняется значение ячейки, на которую указывает ссылка, то происходит пересчёт значения в ячейке с формулой.

При работе с формулами надо отличать абсолютную ссылку от относительной.


    1. ^ Относительные ссылки


По умолчанию Excel создаёт относительные ссылки. Это значит, что при копировании формулы адреса в ссылках автоматически меняются в соответствии с относительным расположением исходной ячейки в создаваемой копии.

^ 1.2. Абсолютные ссылки


На практике часто возникают ситуации, когда ссылка на ячейку не должна изменяться в формуле при её копировании. Такие ссылки называют абсолютными.

Для создания абсолютной ссылки на ячейку, надо перед именем столбца и строки поставить знак $. Например $D$7 – это абсолютная ссылка на ячейку D7. Для ускорения ввода абсолютной ссылки в формулу нужно:

  • Выделить в формуле ссылку на ячейку или диапазон.

  • Нажать клавишу F4. Знаки $ будут добавлены в формулу автоматически.

  • Нажать клавишу Enter.

Кроме абсолютной ссылки на ячейку, существует ещё два типа абсолютных ссылок, которые применяются редко.

  • Абсолютная ссылка на строку. Здесь знак $ размещается только перед номером строки. Например, B$3 – это абсолютная ссылка на третью строку.

  • Абсолютная ссылка на столбец. В этом случае знак $ размещается только перед именем столбца. Например, $B3 – это абсолютная ссылка на столбец B.

Такие типы ссылок могут применяться, например, для построения таблицы умножения.


^ 3. Метод автозаполнения


Для построения таблицы может понадобится, например ввести заголовки столбцов, которыми являются названия месяцев. Пусть это будет диапазон B3:G3 (второе полугодие). Названия месяцев можно ввести непосредственно. Но существует более удобный способ, ускоряющий ввод и исключающий ошибки ввода. Это метод автозаполнения. При его реализации для ввода названий всех месяцев, достаточно указать только одно из них:

  • Активизировать ячейку B3.

  • Ввести название первого месяца второго полугодия:

Июль

  • Установить указатель, мыши на маркере заполнения (чёрный квадрат в правом нижнем углу ячейки B3), вследствие чего указатель приобретёт вид чёрного креста.

  • Удерживая левую кнопку мыши нажатой, переместить указатель в ячейку G3. Диапазон ячеек B3:G3 будет выделен рамкой. В ячейки диапазона будут автоматически вставлены значения (август, сентябрь, октябрь, ноябрь, декабрь).

  • Отменить выделение (щёлкнуть левой кнопкой мыши на свободном месте рабочего листа).

Функцию автозаполнения можно использовать и для заполнения ячеек, содержащих одинаковые числа. Так, например, в отчёте о доходах и расходах предприятия, за второе полугодие, имеется графа «Заработная плата», которая имеет одинаковые числовые значения за каждый месяц.

Рассмотрим автозаполнение более детально.

Автозаполнение одинаковыми числами:

  • В ячейке С10 напечатать число 7 и выделить её.

  • Указатель мыши поместить на маркер заполнения. Указатель преобразуется в чёрный крест +.

  • Нажав и удерживая левую кнопку мыши, протянуть вниз, выделив диапазон С10:С20. Ячейки последнего заполнятся числом 7.

Автозаполнение с возрастанием:

  • В ячейке А20 напечатать число 2. В ячейке А21 напечатать число 3.

  • Выделить диапазон А20:А21.

  • Указатель мыши поместить на маркер заполнения. Указатель преобразуется в черный крест +.

  • Нажав и удерживая левую кнопку, протянуть мышью по ячейкам. В диапазоне А20:А30 будут напечатаны возрастающие числа от 2 до 12 с шагом 1.

Автозаполнение с использованием контекстного меню:

  • В ячейке D2 напечатать число 2.

  • Выделить ячейку D2. Указатель поместить на маркер заполнения. Указатель примет вид черного креста +.

  • Нажав и удерживая правую кнопку мыши, протянуть вниз, выделить диапазон D2:D30. Откроется контекстное меню.

  • Выбрать элемент Прогрессия… Откроется диалоговое окно Прогрессия.

  • В области Расположение выбрать опцию по столбцам. В области Тип выбрать опцию арифметическая. В поле Шаг напечатать 1. Нажать кнопку ОК.



Диапазоны D2:D30 заполнится возрастающими числами от 2 до 12 с шагом 1.

Автозаполнение названиями месяцев:

  • В ячейке А2 напечатать слово Январь.

  • Выделить последнюю.

  • Указатель навести на маркер заполнения и протянуть мышью вправо, заполнив диапазон А2:F2 возрастающими названиями месяцев.

Автозаполнение названиями месяцев с помощью контекстного меню:

  • В ячейке А8 напечатать слово Январь.

  • Указатель навести на маркер заполнения.

  • Нажав и удерживая правую кнопку мыши, протянуть вправо, заполнив диапазон А8:F8.

  • Отпустить правую кнопку. Откроется контекстное меню.

  • Выбрать элемент Заполнить. Диапазон А8:F8 будет заполнен возрастающими названиями месяцев.




  1. Автосуммирование


Автосуммирование применяют для быстрого вычисления суммы числовых значений в смежных ячейках. Последние могут быть диапазоном столбца или строки. При это, используют кнопку ? Автосумма на стандартной панели инструментов. Существует два способа автосуммирования.

Первый способ:


  1. Выделить диапазон суммируемых данных.

  2. Нажать кнопку Автосумма на стандартной панели инструментов.


Второй способ:


  1. Выделить ячейку под или над суммируемым диапазоном, если это столбец, и справа или слева от него, если это строка.

  2. Нажать кнопку ? Автосумма.

  3. Нажать клавишу Enter.


^ 5. Перемещения и копирование данных


В Excel содержимое каждой ячейки может быть перемещено или скопировано, но ячейки, в которые производится перемещение или копирование, должны быть пустые, иначе их содержимое автоматически будет удалено.


^ 5.1. Перемещение данных


Для перемещения данных, их необходимо выделить. Перемещения данных производится следующими способами.

Посредством меню Правка

  • В меню Правка выполнить команду Вырезать.

  • Выделить левую верхнюю ячейку диапазона, куда надо переместить данные.

  • В меню Правка выполнить команду Вставить.

С помощью контекстного меню

  • Навести указатель мыши на объект и нажать правую кнопку мыши. Откроется контекстное меню.

  • Выполнить команду Вырезать.

  • Выделить ячейку, в которую перемещаются данные.

  • Вызвать контекстное меню. Выполнить команду Вставить.


Посредством кнопок Вырезать и Вставить на стандартной панели инструментов

  • Нажать кнопку Вырезать.

  • Выделить объект, в который нужно переместить данные.

  • Нажать кнопку Вставить.

Реализуя перетаскивание мышью

  • Подвести указатель мыши к границе объекта, так чтобы он принял вид наклонной стрелки.

  • Нажать левую кнопку мыши, и удерживая её, переместить мышь в нужном направлении.



^ 5.2. Копирование данных

Копирование производится аналогично перемещению данных, только вместо команды Вырезать следует выполнить команду Копировать.

Копирование посредством перетаскивания мышью производится при нажатой клавише Ctrl.


^ 6. Удаление данных


Для удаления данных их нужно выделить. Затем реализовать один из следующих способов.

С помощью меню Правка

В меню Правка выбрать команду Очистить.

Посредством контекстное меню:

  • Навести указатель мыши на выделенный объект (ячейку или диапазон) и нажать правую кнопку мыши. Откроется контекстное меню.

  • Выполнить команду Очистить.

Используя клавиатуру

Нажать клавишу Delete.


ЛЕКЦИЯ 4

^ ОПЕРАЦИИ С ИМЕНАМИ ЯЧЕЕК И ДИАПАЗОНАМИ ЯЧЕЕК. СТАТИСТИЧЕСКИЕ ФУНКЦИИ.


1. Присвоение имён ячейкам и диапазонам ячеек


Использование имён ячеек и диапазонов ячеек позволяет:

  • Уменьшить вероятность появления ошибок в формулах.

  • При переопределении имён, автоматически модифицировать все использующие их формулы.

  • Легко читать формулы.

  • Легко ссылаться на один и тот же набор имён во всей рабочей книге.

Предварительно отметим следующее.

  • У левого края строки формул, в поле имён, отображается ссылка на активную ячейку. Если ячейка или выделенный диапазон, имеют имя, то в поле имён отображается это имя.

При создании имени надо помнить, что оно должно начинаться с буквы или знака подчёркивания. В именах нельзя использовать пробелы и точки. Хотя имена могут содержать до 255 символов, их очень желательно создавать, как можно короче.

Для присвоения имени ячейке или диапазону ячеек необходимо:

  • Выделить ячейку или диапазон.

  • Выполнить команду

Вставка > Имя > Присвоить

Откроется окно диалога Присвоение имени.

  • В списке поля Имя: можно выбрать предлагаемое имя или ввести нужное имя. Excel часто предлагает имена для выделенных ячеек. Excel ищет текстовое значение в строке слева от ячейки или столбце сверху над ячейкой. Если в тексте есть пробелы, то Excel заменяет их знаками подчёркивания.

  • Нажать кнопку ОК.




^ 2. Изменение или удаление имени ячейки и диапазона ячеек

Для изменения или удаления имени ячейки или диапазона ячеек необходимо:

  • Выделить ячейку или диапазон.

  • Реализовать команду:

Вставка > Имя > Присвоить

Откроется диалоговое окно Присвоение имени.

  • В списке поля Имя: отметить имя, которое требуется изменить.

  • Перейти в поле Имя: и отредактировать имя.

  • Для удаления имени нажать кнопку Удалить.

  • Нажать кнопку ОК.


^ 3. Применение имени ячейки и диапазона ячеек

Если на рабочем листе формулы были напечатаны раньше, чем созданы имена ячеек или диапазонов ячеек, то при создании имён, они автоматически не заменяют соответствующие ссылки в формулах. Чтобы это произошло, имена надо применить. Для этого требуется выполнить следующее.

  • Выбрать ячейку или диапазон ячеек, для которых нужно применить имя.

  • Реализовать команду:

Вставка > Имя > Применить

Откроется окно диалога Применение имён со списком всех имён.

  • Выбрать требуемое имя.

  • Нажать кнопку ОК.



После этого все ссылки на ячейку или диапазон в формулах рабочего листа заменятся соответствующим именем.


  1. ^ Статистические функции


Excel содержит множество специальных функций, называемых функциями рабочего листа. Эти функции сгруппированы по категориям. К одной из категорий относят статистические функции, использование которых, облегчает статистический анализ данных. Также рассмотрим функцию СУММ для итоговых вычислений. Приведенные ниже функции, вычисляют:

СУММ – сумму всех чисел, входящих в список аргументов.

^ СРЗНАЧ – среднее значение (среднее арифметическое) аргументов.

МИН – наименьшее значение в списке аргументов.

МАКС – наибольшее значение в списке аргументов.

^ СЧЁТ – количество чисел в списке аргументов.

Также, в работе полезны функции МОДА и МЕДИАНА, которые являются мерой взаимного расположения значений:

^ МОДА – является наиболее часто встречающемся значением в интервале данных.

МЕДИАНА – число, которое является серединой множества чисел. При этом, половина чисел больше, чем медиана, а половина чисел меньше, чем медиана.

В Excel имеется программа ^ Мастер функций, реализующая процедуру задания функций. Инициировать эту программу можно следующими способами.

  • Нажать кнопку Вставка функции на стандартной панели инструментов. Такая кнопка имеется в версиях Excel 2000 и Excel 97.

  • В версии Excel 2002, нужно на стандартной панели инструментов раскрыть список кнопки Автосумма, где выбрать нужный элемент.

  • Выполнить команду:

Вставка > Функция…

  • Использовать панель формул, которая кроме других операций, позволяет работать с функциями. Запуск панели формул происходит после щелчка на кнопке со знаком равенства в строке формул. В левой части строки формул откроется список для выбора функций. Этот список содержит имена десяти функций, которые использовались последними. Если нужной функции в списке нет, то надо выбрать элемент Другие функции… .

После реализации любого из указанных способов, откроется окно диалога ^ Мастер функций – шаг 1 из 2. В списке Категория: выбрать пункт Статистические. В списке Функция: выбрать нужную нам функцию. В нижней части диалогового окна будет приведен синтаксис и описание выделенной функции. Нажать кнопку ОК.



Откроется следующее окно диалога, которое называют ^ Панель (Палитра) функций (формул). Здесь для ввода каждого аргумента функции предусмотрено отдельное поле. Количество аргументов функции не должно быть более 30. Изначально таких полей два. Но по мере ввода аргументов, количества полей увеличивается. В качестве аргумента можно задать числовое значение, адрес ячейки, адрес или имя диапазона. После ввода аргумента, справа от поля ввода, отображается, значение из указанной ячейки.

Если палитра формул закрывает рабочую область, то следует щёлкнуть на кнопке минимизации. Палитра уменьшится до размера поля ввода и тогда можно будет выделить нужный диапазон ячеек. Адреса первой и последней ячеек диапазона автоматически напечатаются в поле ввода аргумента. Повторный щёлчок на кнопке минимизации восстанавливает прежние, размеры палитры.

Когда палитра формул закрывает нужные для работы ячейки, то её можно также переместить в другое место экрана. Для этого указатель мыши подвести к правому нижнему углу палитры, нажать и держать левую кнопку мыши и отбуксировать палитру в другое место экрана. Также палитру можно переместить в другое место экрана, захватив её мышью за строку заголовка. Тот или иной способ (или все здесь рассмотренные) открытия рабочей области используется в зависимости от версии Excel в которой работает пользователь.

После ввода первого аргумента в нижней части палитры отображается предварительный результат вычисления. Закончив ввод аргументов, надо нажать кнопку ОК. Окончательный результат отобразится в нужной ячейке.

В качестве примера вычислим среднее арифметическое числовых значений диапазона А2:А16, в который введены результаты измерений погрешности вычисления.

Пусть предварительно была вычислена сумма этих значений и результат занесён в ячейку А17. Рассмотрим вычисление среднего значения.

1. Сделать текущей следующую свободную ячейку в столбце А (А18).

2. Выполнить команду:

Вставка > Функция…

Откроется окно диалога Мастер функций – шаг 1 из 2.

3. В списке Категория: выбрать пункт Статистические.

4. В списке Функция: выбрать функцию СРЗНАЧ.

5. Нажать копку ОК. Откроется палитра формул, которую нужно перетащить в другое место экрана, чтобы открыть рабочую область.

6. Выделить диапазон А2:А16 методом протягивания.

7. Нажать кнопку ОК.



В ячейке A18 напечатается результат вычисления среднего значения.

ЛЕКЦИЯ 5

^ ГРАФИЧЕСКОЕ ПРЕДСТАВЛЕНИЕ ДАННЫХ. О ГРАФИЧЕСКИХ ФОРМАХ. ПОСТРОЕНИЕ ЭКСПЕРИМЕНТАЛЬНОГО ГРАФИКА. ПОСТРОЕНИЕ ДИАГРАММ.


    1. О графических формах


Для повышения эффективности анализа данных, Excel содержит графические средства. Последние позволяют значительно повысить наглядность представления данных и отобразить динамику изменения показателей. Графическими формами представления числовых данных являются графики и диаграммы. Для создания графиков и диаграмм можно использовать программу Мастер диаграмм или панель инструментов Диаграммы. Программа Мастер диаграмм содержит большой набор типов графиков и диаграмм и вызывается нажатием кнопки Мастер диаграмм на стандартной панели инструментов.


    1. ^ Построение экспериментального графика


Процесс построения графика функции состоит в создания таблицы значений независимой переменной и функции и построения графика функции.

Предположим, что получены некоторые экспериментальные данные независимой переменной и функции.

Для построения графика надо открыть свою рабочую книгу, создать новый рабочий лист, реализуя команду:

^ Вставка > Лист.

Присвоить рабочему листу имя, например, Обработка эксперемента.

Далее, в столбце А напечатать значения независимой переменой, а в столбце B – значения функции.

Методом протягивания, выделить все заполненные ячейки столбцов А и B.

На стандартной панели инструментов нажать кнопку ^ Мастер диаграмм. Откроется окно диалога Мастер диаграмм (шаг 1 из 4): тип диаграммы, в котором выполнить следующее:

  1. В списке Тип: выбрать пункт Точечная (отображает график, заданный парами значений). В палитре Вид: выбрать средний вариант в первом столбце (маркеры, соединенные гладкими кривыми). Нажать кнопку Далее.



  1. На вкладке Ряд в поле Имя: указать: Результаты измерений. Нажать кнопку Далее.



  1. Выбрать вкладку Заголовки. Здесь заданное название ряда данных (Результаты измерений) автоматически использовано, как заголовок диаграммы. Заменить его, напечатав в поле Название диаграммы заголовок Экспериментальные точки.

Нажать кнопку Далее.



  1. Установить переключатель отдельном. Задать имя добавляемого рабочего листа, например Экспериментальный график.

Нажать кнопку Готово.



  1. Для выделения ряда данных, щёлкнуть на построенной кривой.

  2. Выполнить команду: Формат > Выделенный ряд

Откроется окно диалога Формат ряда данных.

  1. Открыть вкладку Вид. В области Линия открыть палитру цвет: и выбрать, например красный цвет. В списке тип линии: выбрать пунктирную линию.

  2. В области Маркер в списке тип маркера: выбрать треугольный маркер. В палитрах цвет: и фон: выбрать зелёный цвет.

  3. Нажать кнопку ОK. Отменить выделение ряда данных. Сохранить рабочую книгу.




  1. Построение диаграмм


Рассмотрим две таблицы, данные из которых будем использовать для построения диаграмм.
  1   2   3   4   5

Схожі:

Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconМетодические указания для выполнения лабораторных, самостоятельных и контрольных работ по курсу «Информатика и компьютерная техника»
«Информатика и компьютерная техника» (для студентов 1-го и 2-го курсов заочной формы обучения образовательно-квалификационного уровня...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconКонспект лекций по курсу «электроника и микросхемотехника» Раздел «цифровая техника» для студентов и аспирантов
Данный конспект лекций «Цифровая техника» соответствует рабочей программе по дисциплине «Электроника и микросхемотехника», представляет...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconКонспект лекций для студентов заочной формы обучения направления 080201 (Информатика) Сумы, 2007 Содержание
Предлагаемый конспект лекций представляет собой пособие по предмету “Теория информации”, который читается в Сумском государственном...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconДокументи
...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» icon1. Архитектура компьютера
Целью дисциплины "Информатика и компьютерная техника" является предоставление студентам знаний в области современных технологий переработки...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconУчебные пособия по дисциплинам «Информатика в Украине» и«Математика»
В этом году у вас появилась возможность стать первыми студентами факультета компьютерных наук и технологий Доннту по направлению...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconТ. П. Демиденко конспект лекций инженерная и компьютерная графика (для студентов 2 курса дневной формы обучения бакалавров по направлению 030504 «Экономика предприятий») Харьков-хнагх-2010 Конспект
Конспект лекций «Инженерная и компьютерная графика» для студентов 2 курса дневной формы обучения бакалавров по направлению 030504...
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconТ. Н. Колесник конспект лекций
Статистика: Конспект лекций для студентов всех форм обучения специальности 050100 «Экономика и предпринимательство»
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconКонспект лекций
Политология. Конспект лекций/ Шестопалов Г. Г., Побочий И. А., Заболотный М. Б., Поливец Н. С. Под ред профессора Г. Г. Шестопалова....
Конспект лекций по дисциплинам «Информатика и компьютерная техника» iconА. А. Радченко конспект лекций компьютерная графика для студентов 2 курса дневной формы обучения бакалавров направления 060101 «Строительство»
«Строительство», специальности «Промышленное и гражданское строительство», специализации «Охрана труда в строительстве»
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи