Методичні вказівки до виконання лабораторної роботи icon

Методичні вказівки до виконання лабораторної роботи




Скачати 444.48 Kb.
НазваМетодичні вказівки до виконання лабораторної роботи
Сторінка1/4
Дата26.05.2013
Розмір444.48 Kb.
ТипМетодичні вказівки
  1   2   3   4


Міністерство освіти і науки, молоді та спорту України

Сумський державний університет


2973 МЕТОДИЧНІ ВКАЗІВКИ

до виконання лабораторної роботи

«ОПТИМІЗАЦІЯ ЗАСОБІВ ТЕХНОЛОГІЧНОГО ОСНАЩЕННЯ МЕТАЛОРІЗАЛЬНИХ ВЕРСТАТІВ МЕТОДАМИ ПАРАМЕТРИЧНОГО ПРОГРАМУВАННЯ»


для студентів спеціальностей 6.090202, 6.090203, 6.090204

усіх форм навчання





Суми

Сумський державний університет

2011

Методичні вказівки до виконання лабораторної роботи «Оптимізація засобів технологічного оснащення металорізальних верстатів методами параметричного програмування» » з курсу «Математичне моделювання технологічних процесів і оснащення» / укладач О.М. Алексєєв. – Суми: СумДУ, 2011. – 18 с.


Кафедра технології машинобудування, верстатів та інструментів


^






З
С.

4

4

4

7

14

14


міст



Мета роботи………………………………………………………..

Загальні положення………………………………………………

Методика виконання роботи……………………………………….

Приклад виконання роботи………………………………………..

Вимоги до змісту звіту…………………………………………….

Варіанти завдань……………………………………………………


^ Мета роботи

Вивчення методики параметричного програмування стосовно оптимізації засобів технологічного оснащення металорізальних верстатів.

^ Загальні положення

Метод параметричного програмування вигідно відрізняється від інших методів математичного програмування можливістю варіювати в широких межах параметрами функції, яка оптимізується, що особливо важливо при проведенні проектних робіт, коли багато характеристик новостворюваних засобів технологічного оснащення можуть бути визначені приблизно і в достатньо широких межах.

Завдання параметричного програмування в загальному вигляді формулюється таким чином: для всіх значень параметра , де q, s - довільні дійсні числа, знайти такі значення , які перетворюють в мінімум лінійну цільову функцію





за умов
















^ Методика виконання роботи

Завдання параметричного програмування вирішується в такій послідовності.

- Складається початкова симплекс - таблиця (за правилами лінійного програмування) при конкретному значенні параметра L (зазвичай беруть L=q);

2. Початкова симплекс - таблиця доповнюється двома стовпцями для коефіцієнтів аi, bi, як показано в таблиці 1.

Таблиця 1

N

Б

З

П

С1

С2




Сi




Сn

Сn-1




Сn+k




Сn+k+r

а

B

X1

X2




Xi




Xn

Xn-1




Xn+k




Xn+k+r

1

Xn-1

0

В1

Р1,1

Р1,2




Р1,i




Р1,n

Р1,n-1




Р1,n+k




Р1,n+k+r

a1

b1

2

Xn+2

0

В2

Р2,1

Р2,2




Р2,i




Р2,n

Р2,n+1




Р2,n+k




Р2,n+k+r

a2

b2




















































j

Xn-j

0

Вj

Рj,1

Рj,2




Рj,i




Рj,n

Рj,n+1




Рj,n+k




Рj,n+k+r

аj

bj




















































t

Xn-t

0

Вt

Рt,1

Рt,2




Рt,i




Рt,n

Рt,n-1




Рt,n-k




Рt,n+k+r

аt

bt

t+1 (L=q)

A’0

- С1

- С2




- Сi




- Сn

- Cn-1




- Сn+k




- Сn+k+r





t+2 (L=q)

W0

W1

W2




Wi




Wn

0




0




0

аw

bw

Отримана таблиця перетворюється за правилами лінійного програмування (симплекс - методом) до отримання оптимального плану. При цьому останні два стовпці таблиці зазначають за загальним правилом:

1. У випадку, якщо оптимальний план не може бути отриманий, то робиться висновок про необмеженість цільової функції на даній безлічі планів і розв’язання задачі припиняється.

2. Якщо оптимальний план досягнутий, про що свідчить відсутність позитивних елементів у (t+1) -му рядку, то аналізується діапазон можливих значень L, для яких отриманий план залишається оптимальним.

3. Якщо всі елементи стовпця b в останній з таблиць ненегативні, то отриманий план буде оптимальний для всіх значень L від до .

4. Якщо у стовпці b є негативні елементи, то проводяться додаткові ітерації. При цьому як роздільний рядок вибирається рядок, що містить найбільший за абсолютною величиною негативний елемент, що стоїть у стовпці b. Роздільний стовпець визначається за найменшому по абсолютною величиною відношенням елементів (t +1) рядка до негативних елементів роздільного рядка. Решта всіх розрахунків виконується за алгоритмом звичайного симплекс - методу.

Діапазон можливих значень L, для яких отриманий на останній ітерації план залишатиметься оптимальним, лежить в межах від до, де береться таким, що дорівнює , отриманому на передостанній ітерації, а дорівнює останньому розрахунковому значенню . Величина на кожній з ітерацій визначається з формули

при bi < 0.

Ітераційний процес припиняється і після того, як буде досліджений весь діапазон , а значення і не будуть визначені (оптимальний розв’язок не отриманий, проте значення після чергової ітерації перевищують верхнє граничне значення s) або у стовпці b ще є негативні елементи, а у роздільному рядку негативних елементів немає.

^ Приклад виконання роботи

Типове завдання оптимізації технологічної системи на базі методу параметричного програмування може бути сформульоване таким чином. Проектується технологічна система, в яку потрібно включити різальний інструмент, допоміжний інструмент, пристосування або інші засоби технологічного оснащення декількох видів, частина яких є нормалізованою і їх характеристики відомі. Останні ж проектуються знов і за ними відомі тільки вимоги, що ставляться технологами і конструкторами, а також зразкова вартість виготовлення. Необхідно в цих умовах розробити спосіб технологічного оснащення металорізального верстата так, щоб сумарна вартість складових компонентів технологічної системи була мінімальною.

Приклад використання типового завдання для умов оптимізації допоміжного інструмента, наведеного в таблиці 2, викладається нижче.


Таблиця 2 – Параметри допоміжного інструмента

1

2

3

4

Характеристика допоміжного інструмента

Нормалізо-ваний

допоміжний інструмент

Проект. інструмент

Обмеження

на систему

допоміжного

інструмента

П

Б

Витрати на експлуатацію,

тис. грн

12.5

16

16,5

Ліміт витрат на експлуатацію

120 -150 тис. грн

Продовження таблиці 2

1

2

3

4

Матеріало-ємність, кг

13.5

30

3

Ліміт матеріалів по групі

інструментів

90 -130 кг

Кількість робочих місць, шт.

1

0.5

3

Загальна кількість робочих місць

5 -25 шт.

Собівартість виготовлення, грн

160

240

200

Мінімальні

витрати на

виготовлення


Запишемо завдання у формулах лінійного програмування:













Задамося граничними значеннями q і s (беремо такими, що дорівнюють найменшим граничним значенням q = 5, s = 25) і після нескладних перетворень, пов'язаних з обчисленням коефіцієнтів


,

,


де Bmax, Bmin – граничні значення обмежень


і зведенням обмежень нерівностей, до обмежень - рівності, складемо канонічний запис завдання параметричної оптимізації











Складаємо початкову симплекс-таблицю:





Таблиця 3 - Початкова симплекс – таблиця




Оптимізація здійснюється в декілька ітерацій.

На першій ітерації:

- знаходимо найбільше позитивне число в рядку «t+1». Як роздільний стовпець беремо F;

- відповідний елемент стовпця «П» ділимо на позитивні елементи роздільного стовпця. Найменше відношення в рядку 8.

=ЕСЛИ(F7>0;D7/F7;" -")

7,5




=ЕСЛИ(F8>0;D8/F8;" -")

3

Роздільний рядок 8.

=ЕСЛИ(F9>0;D9/F9;" -")

10








Для переходу до наступної симплекс – таблиці: а) елементам роздільного рядка, що стоять у стовпцях «Б» і «З» присвоюємо відповідні їм елементи з роздільного стовпця; б) перераховуємо елементи, що стоять у стовпцях «Xi» у всіх рядках початкової симплекс – таблиці.


Розраховуємо елементи новою симплекс-таблиці.








Таблиця 4 - Перша ітерація




Ітерація 2

Найбільший елемент «t+1» рядка знаходиться у стовпці F. Беремо його як роздільний.

Знаходимо роздільний рядок.

=ЕСЛИ(G14>0;D14/G14;" -")

4,83




=ЕСЛИ(G15>0;D15/G15;" -")

30




=ЕСЛИ(G16>0;D16/G16;" -")

1,19

Роздільний рядок 16.





Розраховуємо елементи новою симплекс-таблиці









Таблиця 5 - Друга ітерація




Ітерація 3

У стовпці b є негативні елементи і, отже, отриманий план не буде оптимальний у всьому діапазоні . Беремо як роздільний рядок рядок, що містить у стовпці b негативний елемент, і, як роздільний стовпець, стовпець, що містить найменше за абсолютною величиною відношення елемента (t+1) -го рядка до негативного елемента роздільного рядка.

Знаходимо роздільний стовпець.

=ЕСЛИ(E21<0;ABS(E24/E21);" -")

-




=ЕСЛИ(F21<0;ABS(F24/F21);" -")

-




=ЕСЛИ(G21<0;ABS(G24/G21);" -")

-




=ЕСЛИ(H21<0;ABS(H24/H21);" -")

-




=ЕСЛИ(I21<0;ABS(I24/I21);" -")

15,6




=ЕСЛИ(J21<0;ABS(J24/J21);" -")

11,8

Роздільний стовпець J




Розраховуємо елементи новою симплекс-таблиці.








Таблиця 6 - Третя ітерація




У стовпці b немає негативних елементів і, отже, верхнє граничне значення параметра .

Нижнє граничне значення визначається за таблицею 5 як найменше відношення негативного елемента стовпця b до відповідного елемента стовпця b. Оскільки у стовпці b тільки один негативний елемент, то .

Розв’язання задачі дозволяє зробити висновок, що отриманий оптимальний план відповідає:


при .

або

X2 = 3,23…3,7, X3 = 5,21…5,44.

  1   2   3   4

Схожі:

Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи
Методичні вказівки до виконання лабораторної роботи «Оцінка анормальності результатів вимірювань при контролі потужності приводу...
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи
Методичні вказівки до виконання лабораторної роботи «Розрахунок параметрів фактичного розподілу і оцінка достовірності впливу ремонту...
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи
Методичні вказівки до виконання лабораторної роботи «Визначення оцінок І довірчих меж для параметрів нормального розподілу при вимірюванні...
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи на тему "ливарне виробництво"
Методичні вказівки до виконання лабораторної роботи на тему "Ливарне виробництво" з курсу "Технологія конструкційних матеріалів і...
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи з курсу «Фізика»
Методичні вказівки до виконання лабораторної роботи з курсу «Фізика» на тему «Вимірювання кутів і пірамідальності призм»
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи «дослідження процесу хонінгування отворів»
Методичні вказівки до виконання лабораторної роботи «Дослідження процесу хонінгування отворів» / Укладачі: В.І. Савчук, А. В. Євтухов....
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки до виконання лабораторної роботи з теми "Випробування двоступеневого поршневого компресора"
Методичні вказівки до виконання лабораторної роботи з теми “Випробування двоступеневого поршневого компресора” з дисципліни “Об’ємні...
Методичні вказівки до виконання лабораторної роботи iconМетодичні вказівки щодо виконання лабораторної роботи з навчальної дисципліни " фізика " " визначення роботи виходу електрона"
Методичні вказівки щодо виконання лабораторної роботи з навчальної дисципліни “Фізика” “Визначення роботи виходу електрона” ( розділ...
Методичні вказівки до виконання лабораторної роботи iconМетодичні рекомендації до виконання лабораторної роботи Прочитайте лекцію 12. Порядок виконання роботи
Створити директорію Lab7, в якій будуть розміщуватися проекти цієї лабораторної роботи
Методичні вказівки до виконання лабораторної роботи iconМетодичні рекомендації до виконання лабораторної роботи Прочитайте лекцію 13. Порядок виконання роботи
Створити директорію Lab8, в якій будуть розміщуватися проекти цієї лабораторної роботи
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи