Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине icon

Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине




НазваМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
Сторінка2/3
Дата26.06.2012
Розмір0.54 Mb.
ТипМетодические указания
1   2   3

^ ЛАБОРАТОРНАЯ РАБОТА 3


MS ACCESS: корректировка баз данных


Задачи:


  1. Закрепить практические навыки в создании и корректировке связей между таблицами базы данных

  2. Закрепить практические навыки в изменении форм ввода данных

  3. Приобрести практические навыки в создании маски ввода данных


Порядок выполнения работы:


  1. Скопировать в папку своей группы базу данных ЛР №4.




  1. Загрузить скопированную базу данных ЛР №4.




  1. Откройте таблицу Фильмотека в режиме Конструктора.




  1. Исправьте тип поля Код фильма на Текстовый. Вы получите сообщение



Это сообщение возникает, так как поле Код фильма в таблице Фильмотека связано с полем Код фильма в таблице Прокатчики. Необходимо предварительно удалить эту связь. Для этого:

    1. Закрыть конструктор таблицы Фильмотека без подтверждения сохранения изменений.

    2. Меню Сервис\Схема данных

    3. Выделить удаляемую связь

    4. Контекстное меню Удалить.

    5. Подтвердить удаление.

    6. Закройте окно Схема данных




  1. Повторите Задание 4. Установите Размер поля 4. Закройте Конструктор с сохранением изменений.




  1. Восстановите связь таблиц Фильмотека и Прокатчики по полю Код фильма (эта операция описана в Лабораторной работе №3). При попытке создания связи Вы получите сообщение



и связь создана не будет. Это произошло потому, что поля сейчас имеют разный тип данных (в таблице Фильмотека – текстовый, а в таблице Прокатчики – числовой.). Нажмите Отмена и закройте окно Схема данных.


  1. Измените поле Код фильма в таблице Прокатчики аналогично одноименному полю в таблице Фильмотека и восстановите связь таблиц Фильмотека и Прокатчики по полю Код фильма (выполняется самостоятельно).




  1. Добавить в таблицу Фильмотека поле Количество копий (выполняется самостоятельно). Подумайте, каким должно быть Значение по умолчанию.




  1. Измените форму Фильмотека, добавив в нее возможность ввода Количества копий. Для этого:

    1. Откройте форму в режиме Конструктора.

    2. Меню Вид\Список полей

    3. В открывшемся окне списка полей таблицы Фильмотека выберите поле Количество копий и перетяните его в Конструктор на поле формы.

    4. Разместите ниже Названия фильма в соответствии с образцом. Для этого предварительно увеличьте размеры рабочей области формы.




  1. Создайте заголовок формы. Для этого:

    1. Увеличьте размер Области Заголовка формы, перетянув ограничитель Область данных вниз (примерно до отметки 2).

    2. На Панели элементов выберите инструмент Надпись. Если Панель элементов отсутствует, то подключите ее (меню Вид\Панели инструментов\Панель элементов).

    3. Создайте в области Заголовок формы поле для ввода текста.

    4. Введите текст Ввод данных о новом фильме.

    5. Отформатируйте надпись следующим образом: текст Arial 16 синий, полужирный, по центру, фон – желтый. Оформление с тенью.Закройте Конструктор, подтвердив сохранение изменений.




  1. Откройте форму Фильмотека. Исправьте код фильма Кик боксер. Для этого найдите нужную запись, последовательно перемещайтесь по записям с помощью кнопки внизу формы. Введите в поле Код фильма 0241. Вернитесь на первую запись с помощью кнопки .




  1. Заполните с помощью формы для всех записей поле Количество копий в соответствии с приведенным ниже образцом.




^ Код фильма

Название фильма



Количество копий

2236

А зори здесь тихие



2

1922

Москва слезам не верит



3

0241

Кик боксер



1

2112

Чужой



1

9966

Как украсть миллион



1

1431

Кошмар на улице вязов



4

2001

Муха-2



2




  1. Переименовать таблицу Прокатчики в таблицу Прокат. Для этого:

    1. Перейти на вкладку Таблицы

    2. Выделить таблицу Прокатчики.

    3. Контекстное меню Переименовать.




  1. Создать таблицу Прокатчики, содержащую следующие поля (реквизиты полей определите самостоятельно):



Для полей Телефон и Банковские реквизиты задайте Маску ввода. Для поля Телефон Маска ввода имеет вид: (000) 000-0000, а для поля Банковские реквизиты: Расч. счет 00000000000000 МФО 000000. (О масках ввода см. СР3). Самостоятельно задайте ключевое поле.


  1. Самостоятельно создайте форму для заполнения таблицы Прокатчики и введите одну запись в соответствии с приведенным ниже образцом.




  1. Свяжите таблицу Прокатчики с таблицей Прокат. Самостоятельно определите поля для связи.


^ ЛАБОРАТОРНАЯ РАБОТА 4


MS ACCESS: создание сложных форм


Задачи:


  1. Закрепить практические навыки в создании форм для ввода данных

  2. Приобрести практические навыки в создании сложных форм


Порядок выполнения работы:


Нами создана база данных организации, которая выдает в прокат фильмы. Она состоит из основной таблицы Прокат, которая содержит данные о выдаваемых фильмах и связанные с ней вспомогательные таблицы: Прокатчики – таблица содержит данные о клиентах-прокатчиках, которые пользуются услугами нашей организации; Фильмотека – таблица содержит данные о имеющейся у нашей организации фильмах, которые она может предоставить прокатчикам; Жанры – вспомогательная таблица, содержащая базовый тариф за прокат фильма в зависимости от жанра.


  1. Скопировать в папку своей группы базу данных ЛР №5.




  1. Загрузить скопированную базу данных ЛР №5.




  1. (Выполняется самостоятельно).

а) Измените структуру таблицы ^ Прокат таким образом, чтобы поле Название фирмы можно было заполнять с помощью выпадающего списка, содержащего наименования фирм-прокатчиков из таблицы Прокатчики.

б) Измените название поля Дата получения на Дата выдачи.


  1. (Выполняется самостоятельно). Создайте форму для заполнения таблицы Прокат в соответствии с образцом.



  1. Заполните с помощью формы таблицу Прокат в соответствии с приведенными ниже данными. При попытке введения первой записи Вы получите сообщение



Это связано с тем, что код 241 отсутствует в таблице Фильмотека и, следовательно, является ошибочным. Эта проверка осуществляется благодаря связи между таблицами Фильмотека и Прокат. Нажмите ОК и введите вместо несуществующего кода 241 существующий код 0241.



^ Название фирмы

Код фильма

Количество

Дата выдачи

Дата возврата

Иллюзион

241

1

15.02.07

25.02.07

Иллюзион

0241

1

15.02.07

25.02.07

Туманный фонарь

2001

1

21.02.07




Степь

2112

1

26.02.07




Украинский голливуд

9966

1

15.01.07

19.01.07

Иллюзион

9966

1

10.02.07

20.02.07




  1. Создайте с помощью Мастера форму для просмотра фильмотеки по названием Информация о фильмах в соответствии с приведенным ниже образцом.




  1. Удалите фильм запись о фильме ^ Кошмар на улице вязов. Для этого:

а) подведите установите с помощью мыши маркер напротив записи

б) Нажмите на панели инструментов ^ Режим формы кнопку Удалить запись

в) Подтвердите удаление записи.


  1. Создайте сложную форму для просмотра выдачи фильмов. Для этого:

а) Перейдите на закладку ^ Формы и откройте Мастер создания форм

б) В выпадающем списке Таблицы и запросы выберите Таблица: Фильмотека.

в) Перенесите в правое окошко поле Название фильма.

г) В выпадающем списке Таблицы и запросы выберите Таблица: Прокат.

д) Перенесите в правое окошко все поля, кроме поля ^ Код фильма. Нажмите Далее.

е) В следующем диалоговом окне оставьте все без изменений и нажмите Далее

ж) Выберите внешний вид – ленточный и нажмите Далее

з) Выберите оформление по своему усмотрению и нажмите ^ Далее

и) Назовите форму Выдача фильмов. Название подчиненной формы оставьте без изменений. Нажмите Готово.


Перемещаясь по названиям фильмов просмотрите информацию о выдаче фильмов.





  1. Измените форму Выдача фильмов таким образом, чтобы можно было найти информацию по конкретному фильму. Для этого:

а) Откройте форму в режиме Конструктора

б) Выделите и удалите с формы поле Название фильма вместе с названием поля.

в) Нажмите на ^ Панели элементов кнопку Мастера

г) Нажмите кнопку элемента Поле со списком.

д) С помощью появившегося курсора в виде крестика обведите на форме область для ввода поля (на месте удаленного поля ^ Название фильма)

е) В появившемся окне мастера Создание полей со списком выберите Поиск в записи в форме на основе значения, которое содержит поле со списком. Нажмите далее.

ж) Перенесите в выбранные поля Название фильма. Нажмите далее.

з) Руководствуясь находящимися в окне ^ Мастера рекомендациями, измените ширину столбца. Нажмите Далее.

и) Нажмите Готово.

к) Закройте Мастер форм с сохранением изменений.


  1. Откройте форму ^ Выдача фильмов. В выпадающем списке Название фильма выберите Как украсть миллион. Проверьте, что результат соответствует приведенному ниже.





^ ЛАБОРАТОРНАЯ РАБОТА 5


MS ACCESS: элементы управления,

создание простых запросов


Задачи:


  1. Приобрести практические навыки в работе с элементами управления

  2. Приобрести практические навыки в создании простых запросов


Порядок выполнения работы:


  1. Скопировать в папку своей группы базу данных ЛР №6.




  1. Загрузить скопированную базу данных ЛР №.6




  1. Добавить на форму элементы управления.

    1. Перейти на закладку Формы.

    2. Открыть форму Прокат в режиме Конструктора.

    3. При отсутствии Панели элементов подключить ее через меню Вид.

    4. Растянуть рабочее поле Конструктора форм на область Примечание формы.

    5. Убедитесь, что кнопка Мастера на Панели элементов нажата (активна). Если нет, то нажмите ее.

    6. Выберите на Панели элементов элемент управления Кнопка и переместите ее на область Примечание формы.

    7. В появившемся Мастере создания кнопок в окне Категории выберите Работа с формой, а в окне Действия выберите Открыть форму. Нажмите Далее.

    8. Вы берите в качестве формы для открытия Фильмотека и нажмите Далее.

    9. Следующее окно оставьте без изменений и нажмите Далее.

    10. Разместить на кнопке – текст Фильмотека. Нажмите Далее.

    11. Нажмите Готово.

    12. Закройте Конструктор с сохранением изменений.

    13. Откройте в Конструкторе форму Фильмотека. Повторите пункты d-f этого задания.

    14. Выберите КатегорииРабота с формой, ДействияЗакрыть форму. Далее.

    15. Разместить на кнопке рисунок Выход. Далее.

    16. Готово.

    17. Закройте Конструктор с сохранением изменений.




  1. Убедитесь в работоспособности сделанных изменений. Для этого:

    1. Откройте форму Прокат.

    2. Нажмите кнопку Фильмотека. Должна открыться форма Фильмотека.

    3. Нажмите на форме Фильмотека кнопку Выход. Вы должны вернуться в форму Прокат.




  1. Скройте форму Фильмотека. Для этого:

    1. Выделите форму Фильмотека

    2. В контекстном меню выберите Свойства

    3. Установите флажок Скрытый и нажмите ОК.

    4. Повторите Задание 4 и убедитесь, что форма Фильмотека по-прежнему доступна через кнопку Фильмотека формы Прокат.




  1. (выполняется самостоятельно).

    1. Создайте форму ^ Жанры для таблицы Жанры. Обратите внимание: На форму выносятся только те поля, которые должны быть доступны пользователю для заполнения или изменения. Так как поле Код заполняется автоматически, то выносить его на форму не надо.

    2. Добавьте на форму Прокат кнопки для вызова форм Прокатчики, Информация о фильмах и Жанры. На формы Прокатчики, Информация о фильмах и Жанры добавьте кнопки для закрытия этих форм.

    3. Убедитесь в работоспособности внесенных изменений.

    4. Скройте формы Прокатчики, Информация о фильмах и Жанры.




  1. С помощью кнопки Жанры формы Прокат вызовите форму Жанры и внесите тарифы в соответствии с образцом.




  1. Создание Ведомости выдачи фильмов. Необходимо создать ведомость, в которой бы содержалась информация о названии фильма, фирме, которой он выдан с указанием банковских реквизитов фирмы, количества выданных копий, дат выдачи и возврата фильма. Так как эти поля содержаться в разных таблицах, то для формирования ведомости необходимо создать запрос, объединяющий данные из нескольких таблиц. Для этого:

    1. Перейти на закладку Запросы

    2. Выбрать Создание запроса в режиме конструктора.

    3. В окне Добавление таблицы перейти (если необходимо) на закладку Таблицы.

    4. Последовательно добавить таблицы Прокат, Прокатчики и Фильмотека.

    5. Изменить размер окон таблиц и их расположение, чтобы были видны все поля и связи.



    1. Перенести в первый столбец Конструктора в строку Поле из таблицы Фильмотека поле Название фильма.

    2. Отсортируйте по алфавиту. Для этого в строке Сортировка выберите По возрастанию.

    3. Заполните строку Поле Конструктора для последующих столбцов полями:

      1. Наименование из таблицы Прокатчики

      2. Банковские реквизиты из таблицы Прокатчики

      3. Банк из таблицы Прокатчики

      4. Дата выдачи из таблицы Прокат

      5. Дата возврата из таблицы Прокат

      6. Закройте окно Конструктора

      7. Сохраните запрос под именем Ведомость проката




  1. Создайте форму для просмотра результатов запроса Ведомость проката. Для этого:

    1. Перейдите на закладку Формы

    2. Выберите Создание формы с помощью мастера.

    3. В выпадающем списке Таблицы и запросы выберите Запрос: ведомость проката.

    4. Перенесите в левое окно поле Название фильма и нажмите Далее

    5. Выберите Типленточный и нажмите Далее

    6. Выберите Стиль оформления по своему вкусу и нажмите далее

    7. Оставьте название формы без изменения, выберите Изменить макет формы и нажмите Готово.

    8. В Конструкторе увеличьте размеры Заголовка формы и области данных. Расширьте рабочее полотно Конструктора.

    9. Перенесите из Списка полей последовательно все поля (кроме поля Название фильма, так как оно уже есть) на Область данных Конструктора форм. Если окно Список полей отсутствует – меню Вид\Список полей.

    10. Перенесите заголовки полей в Заголовок формы Конструктора. Для этого последовательно с каждым заголовком проделайте следующие действия:

      1. выделите заголовок

      2. контекстное меню Вырезать

      3. щелчок мышью в области Заголовок формы

      4. Контекстное меню Вставить.

      5. Разместите заголовки и поля в соответствии с образцом





Сохраните изменения. Откройте форму и просмотрите результат


^ ЛАБОРАТОРНАЯ РАБОТА 6


MS ACCESS: создание запросов с условием


Задачи:


  1. Закрепить практические навыки в создании простых запросов

  2. Приобрести практические навыки в создании вычисляемых полей в запросах

  3. Приобрести практические навыки в создании форм для задания условия в запросах

Порядок выполнения работы:


  1. Скопировать в папку своей группы базу данных ЛР №7.




  1. Загрузить скопированную базу данных ЛР №7




  1. Создать запрос на выборку фильмов, находящихся у заказчика, с информацией о названии фирмы-прокатчика, и номере его телефона и количестве находящихся на руках копий фильма.




    1. Выдача фильмов заказчику фиксируется в таблице Прокат. Признаком того, что фильм находится у прокатчика, является отсутствие даты возврата. Поэтому необходимо создать запрос, который отбирал бы в таблице Прокат те записи, в которых поле Дата возврата не заполнено. Для создания такого запроса удобно воспользоваться уже существующим запросом Ведомость проката, внеся в него изменения. Для этого:

    2. Перейти на закладку Запросы.

    3. Выделить запрос Ведомость проката ? контекстное меню Копировать.

    4. Контекстное меню Вставить. В диалоговом окне Вставка введите имя запроса – Невозвращенные фильмы.

    5. Открыть запрос Невозвращенные фильмы в режиме Конструктора.

    6. Замените поле Банковские реквизиты на Телефон. Для этого щелкните в поле Банковские реквизиты и выпадающем списке выберите Телефон.

    7. Удалите поля Банк и Дата выдачи. Для этого выделите с столбец с удаляемым полем и нажмите Delete.

    8. Установите условие отбора для поля Дата возврата. Для этого щелкните в столбце Дата возврата в строке Условие отбора правой кнопкой мыши и выберите контекстное меню Построить. Появится окно Построитель выражений.

    9. В левом окне Построителя выражений выберите Константы.

    10. В правом окне Построителя выберите Null и нажмите Вставить. В окне Построителя появится запись Null. Нажмите ОК.

    11. Запись Null (потом Access заменит ее на is Null) появится в строке Условие отбора столбца Дата возврата. Это условие означает, что будут отбираться только те записи, у которых значение записи в поле Дата возврата есть Null, то есть пустое.

    12. Закройте Конструктор с сохранением изменений.




  1. (выполняется самостоятельно) Создайте форму Невозвращенные фильмы для просмотра результатов работы одноименного запроса.




  1. (выполняется самостоятельно) Создайте запрос на выборку фильмов, возвращенных прокатчиками в фильмотеку и форму для просмотра результатов работы запроса. Не забудьте предусмотреть в нем поле для Даты выдачи. Запрос и форму назовите Возвращенные фильмы.




  1. Добавить в запрос ^ Возвращенные фильмы информацию о сумме за прокат фильма. Эта сумма будет определяться как дневной тариф (он хранится в таблице Жанры) умноженный на количество дней проката и на количество копий. Для этого:

    1. Откройте запрос Возвращенные фильмы в режиме Конструктора.

    2. Добавьте таблицу Жанры (так как в ней находятся тарифы). Для этого – контекстное меню Добавить таблицу.

    3. Поместите курсор в строку Поле первого пустого столбца (рядом со столбцом Дата возврата). Вызовите контекстное меню и выберите Построить.

    4. В верхней части Построителя выражений наберите Количество дней:

    5. В левом окне разверните пункт Таблицы, выберите Прокат, в среднем окне выберите Дата возврата и нажмите Вставить.

    6. Введите знак вычитания, выберите в среднем окне Дата выдачи и нажмите Вставить.

    7. Сотрите в верхнем окне слово «Выражение» вместе с кавычками (если оно присутствует). У вас должно получиться следующее выражение:



    8. Нажмите ОК.




  1. ^ ЧТО МЫ СДЕЛАЛИ, Мы создали в запросе вычисляемое поле. Это поле, которое отсутствует в таблицах БД. Оно формируется только при выполнении запроса и уничтожается после его выполнения. В нашем случае, поле вычисляет количество дней, которое фильм находился у прокатчика, как разность между датой возврата и датой выдачи. Имя этого поля задается в начале выражении для вычисления и заканчивается двоеточием. То есть, двоеточие служит признаком окончания имени вычисляемого поля и, поэтому, является обязательным. В нашем случае имя поля - Количество дней. Далее следует само выражение для вычисления. В квадратных скобках указываются имена таблиц и имена полей (они разделяются восклицательным знаком), содержащих данные для вычисления. (Вспомните Excel, где аналогично задается ссылка на данные в формате [Лист]![Адрес ячейки]).

    1. Аналогично задаем поле для расчета Суммы за прокат. Проделайте это самостоятельно. Вы должны получить следующее выражение (часть квадратных скобок Access может самостоятельно убрать):




  1. Подумайте, где в Построителе найти поле Тариф за прокат.




  1. Внесите необходимые после выполнения п. 6 изменения в форму для вывода результатов работы запроса Возвращенные фильмы.




  1. Измените в форме формат поля Стоимость проката на денежный. Для этого:

    1. В режиме Конструктора форм выделите поле Стоимость проката, вызовите контекстное меню и выберите Свойства.

    2. Перейдите на закладку Макет и выберите Формат поля – Денежный.




  1. Создать запрос, позволяющий выбирать в таблице Фильмотека фильмы требуемого года выпуска. Год вводится в процессе запроса. Для этого:

    1. Создаем форму для ввода нужного года. Для этого:

      1. Создание формы в режиме Конструктора

      2. Внутри Конструктора формы вызвать контекстное меню Заголовок/примечание формы. Откроется область Заголовок формы.

      3. Введите заголовок формы Информационно-поисковая система «Прокат фильмов» (оформление – на Ваше усмотрение)

      4. Выберите на Панели элементов Поле и перенесите его на Область данных формы.

      5. Переименуйте Поле0 в Год выпуска. Измените размер и расположение элементов.

      6. На поле ввода (на нем написано Свободный) вызовите контекстное меню Свойства.

      7. Перейдите на закладку Другие и введите имя Год.

      8. Закройте окно Свойства и сохраните форму под именем ИПС «Прокат фильмов»

    2. Создайте новый запрос в режиме Конструктора запросов.

      1. Откройте таблицу Фильмотека.

      2. Перенесите в столбцы Конструктора все поля из таблицы Фильмотека, кроме полей Код и Количество копий.

      3. Задайте условие отбора для Года выпуска. Для этого: для столбца Год выпуска в строке Условие отбора вызовите контекстное меню Построитель выражений. В Построителе выражений в левом окне раскройте пункт Формы (Forms), раскройте пункт Все формы и выберите ИПС «Прокат фильмов». В среднем окне выберите Год и нажмите Вставить.

      4. Сохраните запрос под именем По году выпуска.

    3. Создайте в режиме Мастера ленточную форму По году выпуска для просмотра результатов запроса По году выпуска. Предусмотрите на ней кнопку для закрытия формы. Поле Год выпуска в форму не включайте

    4. Добавьте в форму ИПС «Прокат фильмов» кнопку для вызова формы По году выпуска. Разместите ее справа от поля Год выпуска и назовите Найти.

    5. Внесите в форме необходимые изменения оформления.

    6. Закройте Конструктор с сохранением всех изменений.

    7. Проверьте работоспособность запроса. Для этого:

      1. Откройте форму ИПС «Прокат фильмов». Введите в поле Год выпуска 2000 и нажмите кнопку Найти.

      2. Введите в поле Год выпуска 1998 и нажмите кнопку Найти.




  1. Создать запрос, позволяющий находить в фильмотеке фильмы требуемого жанра. Для этого:

    1. Откройте в режиме конструктора форму ИПС «Прокат фильмов».

    2. Убедитесь, что кнопка Мастер на панели элементов активна и добавьте на форму с помощью панели элементов Выпадающий список. Содержание выпадающего списка возьмите из таблицы Жанры (эту операцию Вы выполняли на предыдущей лабораторной работе).

    3. Вызовите на выпадающем списке контекстное меню Свойства, перейдите на вкладку Другие и в поле Имя введите Жанры

    4. Закройте Конструктор с сохранением изменений.

    5. Создайте новый запрос в режиме Конструктора.

      1. Откройте таблицу Фильмотека.

      2. Перенесите в столбцы Конструктора все поля из таблицы Фильмотека, кроме полей Код и Количество копий

      3. Задайте условие отбора для Жанра. Для этого: для столбца Жанр в строке Условие отбора вызовите контекстное меню Построитель. В Построителе выражений в левом окне раскройте пункт Формы (Forms), раскройте пункт Все формы и выберите ИПС «Прокат фильмов». В среднем окне выберите Жанры и нажмите Вставить.

      4. Сохраните запрос под именем По жанру.

    6. Создайте в режиме Мастера ленточную форму По жанру для просмотра результатов запроса По жанру. Предусмотрите на ней кнопку для закрытия формы. Поле Жанр в форму не включайте

    7. Добавьте в форму ИПС «Прокат фильмов» кнопку для вызова формы По жанру. Разместите ее справа от выпадающего списка Жанр и назовите Найти.

    8. Внесите в форме необходимые изменения оформления.

    9. Закройте Конструктор с сохранением всех изменений.

    10. Проверьте работоспособность запроса. Для этого:

      1. Откройте форму ИПС «Прокат фильмов». В выпадающем списке выберите Комедия и нажмите кнопку Найти.

      2. В выпадающем списке выберите Фантастика и нажмите кнопку Найти..



^ ЛАБОРАТОРНАЯ РАБОТА 7


MS ACCESS: cоздание сложных запросов, создание отчетов


Задачи:


  1. Приобрести практические навыки в создании сложных запросов

  2. Приобрести практические навыки в создании отчетов


Порядок выполнения работы:


  1. Скопировать в папку своей группы базу данных ЛР №8.




  1. Загрузить скопированную базу данных ЛР №8.




  1. Определить сумму, полученную за прокат фильмов за определенный период. Для этого сформируем отчет, подытоживающий суммы за прокат по каждому прокатчику за заданный период. Предварительно необходимо создать запрос, который давал возможность отобрать данные о прокате за определенный период. Этот запрос должен выполнять следующие действия:

    • отобрать из таблицы Прокат, те записи по фильмам, которые возвращены прокатчиками и по которым, следовательно, можно произвести расчет стоимости за прокат. Признаком того, что фильм возвращен, является наличие записи в поле Дата возврата.

    • среди отобранных записей выбрать те, у которых Дата возврата попадает в некоторый задаваемый диапазон времени.

    • рассчитать сумму за прокат по каждой отобранной записи.


Для этого:

  1. Самостоятельно создайте в режиме конструктора форму, на которую поместите начальную и конечную дату интересующего нас периода. Назовите форму Итоги проката.



  1. Создайте запрос на основе таблицы Прокат и связанных с ней таблиц, в который включите информацию о названии фирмы-прокатчика, ее банковских реквизитах и банке, дате возврата и названии фильма. Введите условие для выборки в поле Дата возврата, расчет суммы проката (подобную задачу Вы выполняли в ЛР №7). Назовите запрос Итоги проката.

  2. Создайте отчет на основе созданного запроса. Для этого:

    1. Закладка Отчеты. Создание отчета с помощью мастера.

    2. Таблицы и запросы: Запрос: Итоги проката

    3. Перенести в Выбранные поля все, кроме Дата возврата и Количество дней. Далее

    4. Добавьте уровень группировки – Название фирмы. Далее

    5. Нажмите кнопку Итоги. Поставьте флажок sum. ОК. Далее

    6. Макет – По левому краю. Далее.

    7. Выберите Стиль по своему усмотрению. Далее.

    8. Имя отчета – Итоги проката. Установите переключатель в Изменить макет отчета. Измените макет в соответствии с образцом.



    1. Закройте Конструктор с сохранением изменений.




  1. Дополните форму ^ Итоги проката кнопкой для вызова отчета Итоги проката. Для этого в Мастере создания кнопок выберите категорию Работа с отчетом, Действие – Просмотр отчета. Дайте кнопке название Показать итоги.

  2. Проверьте работоспособность созданного отчета. Для этого: откройте форму и введите начальную дату – 1.1.07 и конечную дату – 1.3.07. Нажмите кнопку Показать итоги.



  1. (Выполнить самостоятельно). Создать отчет, который позволял бы для конкретного фильма (задается пользователем с помощью выпадающего списка) выводить количество копий этого фильма и количество копий фильма, находящихся на руках у прокатчиков.



^ ЛАБОРАТОРНАЯ РАБОТА 8


POWER POINT: открытие, просмотр,

изменение презентаций


Задачи:


  1. Приобрести практические навыки в переключении режимов просмотра презентаций

  2. Приобрести практические навыки в перемещении, вставке и редактировании слайдов презентаций


Порядок выполнения работы:


  1. Скопировать в папку своей группы презентацию ЛР №9.




  1. Открыть презентацию ЛР №9.




  1. Установите режим просмотра Структура/Обычный режим

    1. Перейдите на слайд № 3 Для этого используйте или

      1. полосу прокрутки в Области структуры презентации или

      2. полосу прокрутки в Области Слайд или

      3. кнопки Предыдущий слайд и Следующий слайд в Области Слайд (расположены ниже полосы прокрутки) или

      4. клавиши PgUp и PgDn




  1. Перейдите в режим Слайды. Перейдите на слайд № 4




  1. Перейдите в Режим сортировщика слайдов.

    1. Выделите слайд № 9.

    2. Наведите на него курсор мыши и нажмите клавишу ALT и левую кнопку мыши. Вы увидите увеличенный заголовок слайда.




  1. Перейдите в режим Показ слайдов с текущего слайда.

    1. Переместите курсор мыши в левый нижний угол экрана. Появятся кнопки управления просмотром. Нажмите кнопку для перехода к предыдущему слайду.

    2. Нажмите кнопку инструментов и выберите Ручка. Подчеркните слово Страницы.

    3. Снова нажмите кнопку инструментов и выберите Фломастер. Обведите Вид/Страницы.

    4. Еще раз нажмите кнопку инструментов и выберите Выделение. Закрасьте слово меню.

    5. Отмените режим Выделение. Для этого нажмите кнопку инструментов и выберите Стрелка.

    6. Нажмите правую кнопку мыши. В контекстном меню выберите Перейти к слайду/1 Презентация Power Point.

    7. Щелкните левой кнопкой мыши. Вы перейдете к следующему слайду. Повторите эту операцию несколько раз для перемещения по слайдам.

    8. Завершите Показа слайдов. Для этого или

      1. Нажмите клавишу ESC или

      2. Контекстное меню Завершить показ слайдов.

    9. На предложение Сохранить рукописные примечания ответьте Сохранить. Обратите внимание, что Ваши подчеркивания/выделения сохранились на слайде 8.




  1. Переместить слайды

    1. Перемещение слайда в Режиме сортировщика слайда. Переместить слайд №6 на четвертую позицию. Для этого находясь в Режиме сортировщика слайдов выделите слайд №6 и перетащите его на позицию перед слайдом №4. Обратите внимание, что нумерация слайдов автоматически изменится.

    2. Перемещение слайдов в режиме Слайдов. Переместить слайд №5 на третью позицию. Для этого перейдите в режим Обычный/Слайды, захватите слайд №5 левой кнопкой мыши и перетащите его на позицию перед слайдом №3.




  1. Вставить новый слайд в режиме Структуры (вставку осуществить после слайда №8)

    1. Перейдите в режим Обычный/Структура

    2. Установите курсор перед заголовком слайда №9 (после и перед Режимы просмотра)

    3. Нажмите Enter

    4. Введите в появившийся слайд №9 следующий текст (без рамки)




      1. Ввод заметок к слайдам

      2. Если вы собираетесь представить свою презентацию широкой аудитории, то можно ввести заметки, которыми докладчик воспользуется в про­цессе показа. Каждому слайду соответствует собственная страница за­меток. При создании слайда введите заметку, соответствующую его содержанию

  1. Вставить новый слайд в режиме Слайды (вставку осуществить после слайда №2.)

    1. Перейдите в режим Обычный/Слайды

    2. Щелкните левой кнопкой мыши между слайдами №2 и №3. Должен появиться курсор в виде мерцающей горизонтальной черты.

    3. Меню Вставка\Создать слайд или кнопка Создать слайд на панели инструментов Форматирование.

    4. В Области задач Разметка слайда выберите в разделе Макеты текста Заголовок и текст. Если Область задач отсутствует, подключите ее через меню

    5. Введите следующий текст (без рамки). Обратите внимание, что текст вводиться в текстовые области, одна из которых предназначена для ввода заголовка слайда, а вторая – для текста слайда.


Рисование графических объектов

В PowerPoint можно самим нарисовать графический объект практически любой степени сложности. Для рисования предназначена панель инструментов Рисование

  1. Отформатировать слайд в режиме Структуры. Результаты форматирования будут отображаться в окне Слайд.

    1. Перейдите в режим Обычный\Структура

    2. Перейдите на слайд №1

    3. Выделите заголовок и отформатируйте его Шрифт Century Gotic 54 полужирный подчеркнутый цвет зеленый

    4. Установить фон слайда. Для этого:

      1. меню Формат/Фон

      2. В диалоговом окне Фон в выпадающем списке выбрать желтый цвет и градиентный способ заливки.

    5. Поэкспериментируйте с цветами текста, фона и способа заливки с целью получения наилучшего (с Вашей точки зрения) сочетания.




  1. Переместить текст на слайде

    1. Оставайтесь на слайде №1 (или перейдите на него, если Вы находитесь на другом слайде).

    2. Перейдите в окно Слайд, щелкнув мышью по макету слайда в нем.

    3. Щелкните по заголовку. Появиться граница текстовой области вокруг него.

    4. Захватите текстовую область за границу (курсор должен иметь вид скрещивающихся стрелок) и переместите в левый верхний угол слайда.

    5. Измените размер текстовой области, чтобы он занимал всю верхнюю половину слайда




  1. Уничтожить текстовую область. Для этого:

    1. Щелкните в области Подзаголовок слайда. Появится граница области.

    2. Щелкните по границе области.

    3. Нажмите клавишу Delete.




  1. Уничтожить графическую область.

    1. Перейдите на слайд №8

    2. щелкните мышью по подчеркиванию под словом Страницы. Появится граница графической области.

    3. Нажмите клавишу Delete.




  1. Добавить текстовую область на слайд. Для этого:

    1. Перейти на слайд №1

    2. Меню Вставка/Надпись. Обвести на слайде предполагаемые размеры текстовой области.

    3. Щелкнуть внутри текстовой области и ввести текст «Курс ИТ в ООС»




  1. Сохранить результат в папке своей группы под именем Фамилия_ЛР9.



^ ЛАБОРАТОРНАЯ РАБОТА 9


POWER POINT: создание новой презентации, текстовые области.


Задачи:


  1. Приобрести практические навыки в создании новых презентаций

  2. Приобрести практические навыки в создании списков в презентации

  3. Приобрести практические навыки в редактировании текста в презентации


Порядок выполнения работы:


  1. Откройте Power Point.




  1. Создайте структуру презентации. Для этого перейдите в режим просмотра Обычный/Структура

    1. Введите заголовок титульного слайда

Создание новой презентации

    1. Создайте новый слайд. Для этого установите курсор в конец набранного текста и нажмите ENTER. Появится слайд №2.

    2. Введите заголовок слайда (рамку не вводить).


Ввод текста в слайд


    1. Нажмите ENTER. Появится слайд №3. Для продолжения ввода слайда 2 нажмите кнопку Увеличить отступ на панели инструментов Форматирование

    2. Введите приведенный ниже текст (рамку не вводить). Для этого:

      1. Введите каждую строку, нажимая в конце ENTER. После ввода последней строки ENTER не нажимать.

      2. Удалите маркер в первой строке

      3. Выделите остальные строки. Меню Формат/Список, закладка нумерованный. Выбрать нужный вид маркера и нажать ОК.

        На слайд можно добавлять текст четырех типов:

        1. текст в рамке,

        2. текст в надписях

        3. текст в автофигурах

        4. текст WordArt.

    1. Создайте новый слайд. Для этого

      1. установите курсор в конце последней строки и нажмите ENTER.

      2. Нажмите кнопку Уменьшить отступ на панели инструментов Форматирование. Появится слайд №3 (рамку не вводить)

    2. Введите и отформатируйте приведенный ниже текст (рамку не вводить).



1   2   3

Схожі:

Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по курсу «вычислительная техника и программирование»
Методические указания к выполнению лабораторных работ по курсу «Вычислительная техника и программирование», (для студентов 2 курса...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
«Проектирование электромеханических устройств и систем» (для студентов 4 курса дневной формы обучения по специальности 092200 – «Электромеханические...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
«Элементы автоматизированного электропривода» (для студентов 3 курса дневной формы обучения по специальности 092200 – «Электромеханические...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
«Информатика и системология» Модуль 2 «Научно-техническое программное обеспечение» (для студентов 1 курса дневной формы обучения...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
«Информатика и системология» Модуль 1 «Основы информатики и вычислительной техники» (для студентов 1 курса дневной формы обучения...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине
«Информационные технологии в охране окружающей среды» (часть 1) (для студентов 2 курса дневной формы обучения спец. 070800 «Экология...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская национальная академия городского хозяйства
Методические указания к практическим занятиям и выполнению самостоятельной работы по курсу
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки Украины Харьковская национальная академия городского хозяйства
Харьковская национальная академия городского хозяйства по учебной дисциплине «водоотведение»
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки украины харьковская государственная академия городского хозяйства
Методические указания к выполнению курсовой работы «Проектирование совмещенного производства каменных и монтажных работ» (для студентов...
Министерство образования и науки украины харьковская национальная академия городского хозяйства методические указания к выполнению лабораторных работ по дисциплине iconМинистерство образования и науки Украины Харьковская национальная академия городского хозяйства
Методические указания к выполнению контрольной работы и задания по курсу „Прогнозирование” (для студентов 3, 4 курсов заочной формы...
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©zavantag.com 2000-2013
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи